dev-python/versioneer: add python3_8
authorAndrey Grozin <grozin@gentoo.org>
Sun, 1 Mar 2020 03:43:04 +0000 (10:43 +0700)
committerAndrey Grozin <grozin@gentoo.org>
Sun, 1 Mar 2020 03:43:04 +0000 (10:43 +0700)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
dev-python/versioneer/versioneer-0.18-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/versioneer/versioneer-0.18-r1.ebuild b/dev-python/versioneer/versioneer-0.18-r1.ebuild
new file mode 100644 (file)
index 0000000..f6e8f0c
--- /dev/null
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Easy VCS-based management of project version strings"
+HOMEPAGE="https://pypi.org/project/versioneer/ https://github.com/warner/python-versioneer"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="public-domain"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]"