dev-java/jpfcodegen: EAPI 5 bump.
authorPatrice Clement <monsieurp@gentoo.org>
Fri, 2 Oct 2015 08:58:12 +0000 (08:58 +0000)
committerPatrice Clement <monsieurp@gentoo.org>
Fri, 2 Oct 2015 09:09:32 +0000 (09:09 +0000)
Package-Manager: portage-2.2.18
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
dev-java/jpfcodegen/jpfcodegen-0.4-r1.ebuild [new file with mode: 0644]

diff --git a/dev-java/jpfcodegen/jpfcodegen-0.4-r1.ebuild b/dev-java/jpfcodegen/jpfcodegen-0.4-r1.ebuild
new file mode 100644 (file)
index 0000000..be5b3c1
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Generator of classes for accessing the attributes and extensions of JPF plug-ins"
+HOMEPAGE="http://jabref.sourceforge.net/"
+
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="LGPL-3"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+CDEPEND="dev-java/velocity:0
+       dev-java/jpf:1.5"
+DEPEND=">=virtual/jdk-1.6
+       app-arch/unzip
+       ${CDEPEND}"
+RDEPEND=">=virtual/jre-1.6
+       ${CDEPEND}"
+
+# doc target is name="-javadoc" and would need a patch, on demand
+EANT_BUILD_TARGET="jars"
+EANT_GENTOO_CLASSPATH="jpf-1.5,velocity"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+src_install() {
+       java-pkg_newjar JPFCodeGenerator-${PV}.jar JPFCodeGenerator.jar
+       java-pkg_newjar JPFCodeGenerator-${PV}-rt.jar JPFCodeGenerator-rt.jar
+       dohtml index.html
+}