net-misc/seafile: Bump to version 7.0.2
authorDenis Efremov <efremov@linux.com>
Sun, 29 Sep 2019 21:06:43 +0000 (00:06 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Wed, 16 Oct 2019 05:22:03 +0000 (08:22 +0300)
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Denis Efremov <efremov@linux.com>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
net-misc/seafile/Manifest
net-misc/seafile/metadata.xml
net-misc/seafile/seafile-7.0.2.ebuild [new file with mode: 0644]

index fce17d5214592a25f99c391931a2a33af98955ae..e982f9c433d42022829bf4b4f1571408cc2dc3a6 100644 (file)
@@ -1 +1,2 @@
 DIST seafile-6.2.11.tar.gz 703739 BLAKE2B a072b103875e3a90a9c457079d3101262abc826659c604130f7c3e9d1b129e7d806b687a5673109b37cf040bba02a0a862374997a819cf384ecf2bd3bb6af058 SHA512 90ff1ca4c2a75da9a44d7833209800629c7bec3e8d5b651a820d158261bee77a3b7e599748e6ed350fe919fb67685882a215c18720b0a9702d56e384b8561985
+DIST seafile-7.0.2.tar.gz 698373 BLAKE2B 171ef14253c260d0e1ed9e984219a545bc5c86895fd554223148515feeb8fd2c6f9ab802f0f505ada0ed504def01999cdd254683de6e0d00f77272eb9d491f4b SHA512 f348139662edb061bbb2da534cd099619f23e09b1383cc97a53116c7e1eb5b41e95d61f719a83f3a69d3914e64836baf15900a9597a7b6ddfb8d23f3e362b8cd
index 36923d5c87197381ba447372eed4f066882487cd..f2d263d441e98b4c67b8ff5390bcb6b58e743fed 100644 (file)
@@ -1,7 +1,14 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-       <!-- maintainer-needed -->
+       <maintainer type="person">
+               <email>efremov@linux.com</email>
+               <name>Denis Efremov</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
        <upstream>
                <remote-id type="github">haiwen/seafile</remote-id>
        </upstream>
diff --git a/net-misc/seafile/seafile-7.0.2.ebuild b/net-misc/seafile/seafile-7.0.2.ebuild
new file mode 100644 (file)
index 0000000..4c5040c
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+inherit autotools python-single-r1 vala
+
+DESCRIPTION="File syncing and sharing software with file encryption and group sharing"
+HOMEPAGE="https://github.com/haiwen/seafile/ http://www.seafile.com/"
+SRC_URI="https://github.com/haiwen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+-with-openssl-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+       net-libs/libsearpc[${PYTHON_USEDEP}]
+       dev-libs/glib:2
+       dev-libs/libevent:0
+       dev-libs/jansson
+       sys-libs/zlib:0
+       net-misc/curl
+       dev-libs/openssl:0
+       dev-db/sqlite:3"
+DEPEND="${RDEPEND}
+       $(vala_depend)"
+
+src_prepare() {
+       default
+       sed -i -e 's/valac /${VALAC} /' lib/Makefile.am || die
+       eautoreconf
+       vala_src_prepare
+}
+
+src_install() {
+       default
+       # Remove unnecessary .la files, as recommended by ltprune.eclass
+       find "${ED}" -name '*.la' -delete || die
+       python_fix_shebang "${ED}"/usr/bin
+}