Version bump. Unfortunately, upstream sucks and doesn't bother putting versions...
authorChris Gianelloni <wolf31o2@gentoo.org>
Tue, 12 Dec 2006 18:24:13 +0000 (18:24 +0000)
committerChris Gianelloni <wolf31o2@gentoo.org>
Tue, 12 Dec 2006 18:24:13 +0000 (18:24 +0000)
Package-Manager: portage-2.1.2_rc2-r2

games-strategy/x2-demo/ChangeLog
games-strategy/x2-demo/files/digest-x2-demo-1.4.03 [new file with mode: 0644]
games-strategy/x2-demo/x2-demo-1.4.03.ebuild [new file with mode: 0644]

index 751d685ea2cf4065c1e453c16b68350898a20b5c..975c5819c5e55204fdecd71b142d9ef03d5af4e0 100644 (file)
@@ -1,6 +1,14 @@
 # ChangeLog for games-strategy/x2-demo
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/x2-demo/ChangeLog,v 1.2 2006/12/06 21:09:36 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/x2-demo/ChangeLog,v 1.3 2006/12/12 18:24:13 wolf31o2 Exp $
+
+*x2-demo-1.4.03 (12 Dec 2006)
+
+  12 Dec 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+  -x2-demo-1.4.01.ebuild, +x2-demo-1.4.03.ebuild:
+  Version bump. Unfortunately, upstream sucks and doesn't bother putting
+  versions in their packaging. Because of this, we aren't mirroring this on
+  our mirrors. Closing bug #157294.
 
   06 Dec 2006; Chris Gianelloni <wolf31o2@gentoo.org> x2-demo-1.4.01.ebuild:
   Remove old virtual/x11 dependency.
diff --git a/games-strategy/x2-demo/files/digest-x2-demo-1.4.03 b/games-strategy/x2-demo/files/digest-x2-demo-1.4.03
new file mode 100644 (file)
index 0000000..3ff6708
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 9709414bfec6d961d0eb52191f09b871 x2-demo.run 188281527
+RMD160 30e1ca9938252bc42c05076e8c279da61fd7b139 x2-demo.run 188281527
+SHA256 653e68bf366172cffb6b77c0b1c55143d5a7bad6a8c08d9243bb646e0188bd4b x2-demo.run 188281527
diff --git a/games-strategy/x2-demo/x2-demo-1.4.03.ebuild b/games-strategy/x2-demo/x2-demo-1.4.03.ebuild
new file mode 100644 (file)
index 0000000..63e81b7
--- /dev/null
@@ -0,0 +1,66 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/x2-demo/x2-demo-1.4.03.ebuild,v 1.1 2006/12/12 18:24:13 wolf31o2 Exp $
+
+inherit eutils games
+
+DESCRIPTION="Open-ended space opera with trading, building & fighting"
+HOMEPAGE="http://www.linuxgamepublishing.com/info.php?id=x2"
+
+# Patches are in http://updatefiles.linuxgamepublishing.com/x2-demo/
+# Unversioned filename, grrr (is pre-patched).
+SRC_URI="http://demofiles.linuxgamepublishing.com/x2/${PN}.run"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror primaryuri strip"
+
+RDEPEND="media-libs/alsa-lib
+       sys-libs/glibc
+       x86? (
+               media-libs/libsdl
+               media-libs/openal
+               sys-libs/zlib
+               x11-libs/gtk+
+               x11-libs/libX11
+               x11-libs/libXau
+               x11-libs/libXdmcp
+               x11-libs/libXext
+               x11-libs/libXi )
+       amd64? (
+               app-emulation/emul-linux-x86-gtklibs
+               app-emulation/emul-linux-x86-sdl )"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+
+src_unpack() {
+       unpack_makeself ${PN}.run
+       unpack ./data.tar.gz
+       rm -rf data.tar.gz lgp_* setup*
+
+       # Prevents e.g. "cp: omitting directory bin/OpenBSD" warnings
+       rm -f bin/*{BSD,64} bin/Linux/*64
+}
+
+src_install() {
+       exeinto "${dir}"
+       doexe bin/Linux/x86/x2_demo{,.dynamic} || die "doexe x2"
+
+       insinto "${dir}"
+       doins -r * || die "doins -r failed"
+
+       keepdir "${dir}"/database
+       rm -rf "${Ddir}"/bin
+
+       # We don't support the dynamic version, even though we install it.
+       games_make_wrapper ${PN} ./x2_demo "${dir}" "${dir}"
+       newicon icon.xpm ${PN}.xpm || die "newicon failed"
+       make_desktop_entry ${PN} "X2 - The Threat (Demo)" ${PN}.xpm
+
+       prepgamesdirs
+}