dev-lang/perl: Combine -Dd_u32align definitions, add HPPA
authorJeroen Roovers <jer@gentoo.org>
Wed, 11 Sep 2019 15:32:46 +0000 (17:32 +0200)
committerJeroen Roovers <jer@gentoo.org>
Wed, 11 Sep 2019 16:03:42 +0000 (18:03 +0200)
Although unaligned accesses are not fatal on PARISC, as they are
automatically realigned as they occur, this has a non-trivial impact on
performance that ought to be fixed upstream. Work around it the same way
sparc*-* does and combine both efforts into a single myconf() call.

Package-Manager: Portage-2.3.75, Repoman-2.3.17
Bug: https://bugs.gentoo.org/676062
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
dev-lang/perl/perl-5.28.2-r1.ebuild
dev-lang/perl/perl-5.28.9999.ebuild
dev-lang/perl/perl-5.30.0.ebuild

index 9e4f13f26281c61353d90e82b3e5beab364e5bb4..a63c8091115a68047e74bf1ce9e5fe0bdf3038fb 100644 (file)
@@ -377,7 +377,6 @@ src_configure() {
        filter-flags "-flto"
 
        use sparc && myconf -Ud_longdbl
-       use sparc && myconf -Dd_u32align # bug #676062
 
        export BUILD_BZIP2=0
        export BZIP2_INCLUDE=${EROOT}/usr/include
@@ -469,7 +468,9 @@ src_configure() {
 
        # fix unaligned access misdetection
        # https://rt.perl.org/Public/Bug/Display.html?id=133495
-       [[ ${CHOST} == sparc*-solaris* ]] && myconf "-Dd_u32align='define'"
+       # bug #676062
+       use hppa || use sparc || [[ ${CHOST} == sparc*-solaris* ]] && \
+               myconf "-Dd_u32align='define'"
 
        # Prefix: the host system needs not to follow Gentoo multilib stuff, and in
        # Prefix itself we don't do multilib either, so make sure perl can find
index 2c066883bcebfae0bd09f0a7810e08151473e178..c5309aeccc88d09cf12d3a1ec667599d69dc3f70 100644 (file)
@@ -375,7 +375,6 @@ src_configure() {
        filter-flags "-flto"
 
        use sparc && myconf -Ud_longdbl
-       use sparc && myconf -Dd_u32align # bug #676062
 
        export BUILD_BZIP2=0
        export BZIP2_INCLUDE=${EROOT}/usr/include
@@ -467,7 +466,9 @@ src_configure() {
 
        # fix unaligned access misdetection
        # https://rt.perl.org/Public/Bug/Display.html?id=133495
-       [[ ${CHOST} == sparc*-solaris* ]] && myconf "-Dd_u32align='define'"
+       # bug #676062
+       use hppa || use sparc || [[ ${CHOST} == sparc*-solaris* ]] && \
+               myconf "-Dd_u32align='define'"
 
        # Prefix: the host system needs not to follow Gentoo multilib stuff, and in
        # Prefix itself we don't do multilib either, so make sure perl can find
index 922d04be075f3e3d62f87bc1005c0b8d68c26eb7..8f02f4a820cc39a294c93a83794f5a90be8cfd4f 100644 (file)
@@ -373,7 +373,6 @@ src_configure() {
        filter-flags "-flto"
 
        use sparc && myconf -Ud_longdbl
-       use sparc && myconf -Dd_u32align # bug #676062
 
        export BUILD_BZIP2=0
        export BZIP2_INCLUDE=${EROOT}/usr/include
@@ -465,7 +464,9 @@ src_configure() {
 
        # fix unaligned access misdetection
        # https://rt.perl.org/Public/Bug/Display.html?id=133495
-       [[ ${CHOST} == sparc*-solaris* ]] && myconf "-Dd_u32align='define'"
+       # bug #676062
+       use hppa || use sparc || [[ ${CHOST} == sparc*-solaris* ]] && \
+               myconf "-Dd_u32align='define'"
 
        # Prefix: the host system needs not to follow Gentoo multilib stuff, and in
        # Prefix itself we don't do multilib either, so make sure perl can find