net-wireless/gr-paint: new
authorZero_Chaos <zerochaos@gentoo.org>
Tue, 25 Aug 2015 04:37:07 +0000 (00:37 -0400)
committerZero_Chaos <zerochaos@gentoo.org>
Tue, 25 Aug 2015 04:38:00 +0000 (00:38 -0400)
Package-Manager: portage-2.2.20.1

net-wireless/gr-paint/gr-paint-9999.ebuild [new file with mode: 0644]
net-wireless/gr-paint/metadata.xml [new file with mode: 0644]

diff --git a/net-wireless/gr-paint/gr-paint-9999.ebuild b/net-wireless/gr-paint/gr-paint-9999.ebuild
new file mode 100644 (file)
index 0000000..11808a8
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit git-r3
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="paints monochrome images into the waterfall of a receiver"
+HOMEPAGE="https://github.com/drmpeg/gr-paint"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/drmpeg/gr-paint.git"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+               net-wireless/gnuradio:=[${PYTHON_USEDEP}]
+               dev-libs/boost:=[${PYTHON_USEDEP}]"
+RDEPEND="${COMMON_DEPEND}
+       media-gfx/imagemagick"
+DEPEND="${COMMON_DEPEND}
+       virtual/pkgconfig
+       dev-util/cppunit
+       dev-lang/swig
+       doc? ( app-doc/doxygen )"
+
+src_configure() {
+       mycmakeargs=(
+               $(cmake-utils_use_enable doc DOXYGEN)
+               -DPYTHON_EXECUTABLE="${PYTHON}"
+       )
+       cmake-utils_src_configure
+}
diff --git a/net-wireless/gr-paint/metadata.xml b/net-wireless/gr-paint/metadata.xml
new file mode 100644 (file)
index 0000000..d6c2331
--- /dev/null
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>zerochaos@gentoo.org</email>
+<name>Rick Farina</name>
+<description>maintainer</description>
+</maintainer>
+<herd>radio</herd>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>