sci-chemistry/probe: Drop old
authorJustin Lecher <jlec@gentoo.org>
Sun, 20 Sep 2015 10:39:08 +0000 (12:39 +0200)
committerJustin Lecher <jlec@gentoo.org>
Sun, 20 Sep 2015 10:39:08 +0000 (12:39 +0200)
obsoletes
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=556806

Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
sci-chemistry/probe/Manifest
sci-chemistry/probe/files/2.12.110413-as-needed.patch [deleted file]
sci-chemistry/probe/probe-2.12.110413.ebuild [deleted file]

index f5dd9226d404bdf5563af5d768f441f0d2ee0b9c..a22c524edb822ee7055d66351a72d3eacc833312 100644 (file)
@@ -1,2 +1 @@
-DIST probe.2.12.110413.src.zip 262460 SHA256 90cd0a693683958a8ac05d13a47c2b464f2939df24369bf5c568f59913756de4 SHA512 ac6a92f1666d1819c0dede5ea97113c9e03271c42b829d88a2b65041dec7f853441fc61e94e48782078884a9a69c1043432ca3576768d31bfe9190d3ea1da4c8 WHIRLPOOL f6e6ec43016d14114ae5cbfdbfd1cdb5bdf0c6a1c34742b0fef0cfe5ee39409a41b4b2127fbefe526d66d99c33b91ef5e3ea4c9de33784f9ea493700e8bc8784
 DIST probe.2.13.110909.src.zip 131063 SHA256 df14b76d27a7c43b2b57c315d0ad71cdf6acc7943c43195a797162be7816fa71 SHA512 5efa066873d0e139da66bf8edb541fe42df94e99cab171ad8d06a8a6f5caada982ef5b18481e748b224dbed86f63c99237d04ecd107c82855b44de91fb6d2b16 WHIRLPOOL 12f6fefe1b03b71268f39fa3aa7ad796230c76c2e029b8dc86955abd43c8e3f09f7591f84cd79c7ba11037d5b323c922ddf36abf6911d556981f5cc21378912f
diff --git a/sci-chemistry/probe/files/2.12.110413-as-needed.patch b/sci-chemistry/probe/files/2.12.110413-as-needed.patch
deleted file mode 100644 (file)
index 9536862..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
- Makefile |   13 ++++++-------
- 1 files changed, 6 insertions(+), 7 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index e6a740e..8f74d6a 100644
---- a/Makefile
-+++ b/Makefile
-@@ -1,14 +1,12 @@
--MACHINEFLAGS = 
--CFLAGS = $(MACHINEFLAGS)
--LFLAGS = -lm $(MACHINEFLAGS)
-+LIBS = -lm
- OBJLIST = dots.o abin.o readPDBrecs.o geom3d.o utility.o select.o \
--       parse.o atomprops.o stdconntable.o autobondrot.o
-+       parse.o atomprops.o stdconntable.o autobondrot.o hybrid_36_c.o
- .c.o:
--      cc -c $*.c $(CFLAGS)
-+      $(CC) $(CFLAGS) -c $*.c
- probe: probe.o $(OBJLIST)
--      cc -o $@ probe.o $(OBJLIST) $(LFLAGS)
-+      $(CC) $(CFLAGS) $(LDFLAGS) -o $@ probe.o $(OBJLIST) $(LIBS)
- clean:
-       @rm -f *.o *.ckp
-@@ -30,9 +28,10 @@ parse.o:    ./parse.h       ./utility.h     parse.c
- probe.o:      ./abin.h        ./atomprops.h   ./autobondrot.h ./dots.h        ./geom3d.h \
-               ./parse.h       ./probe.h       ./readPDBrecs.h ./select.h \
-               ./stdconntable.h        ./utility.h     probe.c
--readPDBrecs.o:        ./geom3d.h      ./readPDBrecs.h ./utility.h     readPDBrecs.c
-+readPDBrecs.o:        ./geom3d.h      ./readPDBrecs.h ./utility.h     ./hybrid_36_c.h readPDBrecs.c
- select.o:     ./abin.h        ./atomprops.h   ./geom3d.h      ./parse.h       ./select.h \
-               ./stdconntable.h        ./utility.h     select.c
- stdconntable.o:       ./stdconntable.h        stdconntable.c
- utility.o:    utility.c
-+hybrid_36_c.o:  ./hybrid_36_c.h       hybrid_36_c.c
- # DO NOT DELETE THIS 2nd LINE -- make depend uses it
diff --git a/sci-chemistry/probe/probe-2.12.110413.ebuild b/sci-chemistry/probe/probe-2.12.110413.ebuild
deleted file mode 100644 (file)
index bb0a36a..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-
-inherit eutils toolchain-funcs
-
-MY_P="${PN}.${PV}"
-
-DESCRIPTION="Evaluates atomic packing within or between molecules"
-HOMEPAGE="http://kinemage.biochem.duke.edu/software/probe.php"
-SRC_URI="http://kinemage.biochem.duke.edu/downloads/software/probe/${MY_P}.src.zip"
-
-SLOT="0"
-LICENSE="richardson"
-KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE=""
-
-RDEPEND=""
-DEPEND="${RDEPEND}
-       app-arch/unzip"
-
-S="${WORKDIR}"/trunk
-
-src_prepare() {
-       epatch "${FILESDIR}"/${PV}-as-needed.patch
-       # Respect CC
-       sed -i \
-               -e 's:cc:$(CC):g' \
-               "${S}"/Makefile || die
-       tc-export CC
-}
-
-src_install() {
-       dobin "${S}"/probe
-       dodoc "${S}"/README*
-}