dev-ruby/async_sinatra: cleanup
authorHans de Graaff <graaff@gentoo.org>
Wed, 21 Mar 2018 06:37:12 +0000 (07:37 +0100)
committerHans de Graaff <graaff@gentoo.org>
Wed, 21 Mar 2018 06:37:12 +0000 (07:37 +0100)
Package-Manager: Portage-2.3.24, Repoman-2.3.6

dev-ruby/async_sinatra/Manifest
dev-ruby/async_sinatra/async_sinatra-1.2.1.ebuild [deleted file]

index bdf58403593bab959b415f697a11a7366b2c923c..cedb8d72b112bc17c25f99da0a4261df66b76404 100644 (file)
@@ -1,2 +1 @@
-DIST async_sinatra-1.2.1-git.tgz 8314 BLAKE2B 13f338e1857c8dfa8e9586398f64892b51340dc610f69106fa668156498c19c0c89984718ec5f71f8f9626bfe49af1bdc1c72ffb85321faab9cf228b08c06ab5 SHA512 f1c7dc5aeeae366836bc2db6ae1c34967fa4a8d89d2f0fdcbcfeb7737e7b39615990c67ba9d55428cc0873329b5b54e9a1df727b09c5d79b03210b4e209b56ba
 DIST async_sinatra-1.3.0-git.tgz 8657 BLAKE2B ba41b01a9ad00794f19273d41cceaf80ae5159e38f93c1907db5fae78d5d2f5d6d583f31ff495722b3a241f7e0d2d91c5b3202fe5a8ff39f500e6ab0e1e0030b SHA512 2975e41557da539e1b6427a43d41811f4e17315c01da8d1141dbdafad68702395bfce011844b8b1db2c24bbf19d09b5e680cd10e039ceaab1263ea66bcb8f9f6
diff --git a/dev-ruby/async_sinatra/async_sinatra-1.2.1.ebuild b/dev-ruby/async_sinatra/async_sinatra-1.2.1.ebuild
deleted file mode 100644 (file)
index c06f325..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby20 ruby21 ruby22 ruby23"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.rdoc"
-RUBY_FAKEGEM_TASK_DOC="docs"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Asynchronous response API for Sinatra and Thin"
-HOMEPAGE="https://github.com/raggi/async_sinatra"
-SRC_URI="https://github.com/raggi/async_sinatra/archive/v${PV}.tar.gz -> ${P}-git.tgz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-
-ruby_add_bdepend "test? (
-       >=dev-ruby/hoe-3.13
-       >=dev-ruby/minitest-5.6:5
-       >=dev-ruby/eventmachine-0.12.11
-       dev-ruby/rack-test
-       )"
-ruby_add_bdepend "doc? ( >=dev-ruby/hoe-2.9.1 )"
-
-ruby_add_rdepend ">=dev-ruby/sinatra-1.3.2
-       >=dev-ruby/rack-1.4.1:*"
-
-all_ruby_prepare() {
-       # Remove development dependencies that we don't have from the gemspec
-       sed -i -e '/\(hoe\|rdoc\)/d' async_sinatra.gemspec || die
-}
-
-all_ruby_install() {
-       all_fakegem_install
-
-       insinto /usr/share/doc/${PF}/
-       doins -r examples || die "Failed to install examples"
-}