dev-ruby/em-websocket: fix FEATURES=test and dependencies
authorHans de Graaff <graaff@gentoo.org>
Mon, 26 Nov 2018 06:20:20 +0000 (07:20 +0100)
committerHans de Graaff <graaff@gentoo.org>
Mon, 26 Nov 2018 06:20:20 +0000 (07:20 +0100)
Match dependencies to gemspec.
Unbreak DEPEND and RDEPEND.
Run unit tests only due to unpackaged dependencies.
Install proper gemspec file.
Add ruby as co-maintainer.

Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

dev-ruby/em-websocket/em-websocket-0.5.1.ebuild
dev-ruby/em-websocket/metadata.xml

index 9e941fc5e43caf621bcd8d11062fa41bccf9c88d..42534c14304068f39f029cedf79cd459ba863887 100644 (file)
@@ -1,14 +1,18 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
 
 USE_RUBY="ruby23 ruby24 ruby25"
 
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
 RUBY_FAKEGEM_RECIPE_DOC="rdoc"
 RUBY_FAKEGEM_DOCDIR="rdoc"
 RUBY_FAKEGEM_EXTRADOC="README.md"
 
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
 inherit ruby-fakegem
 
 DESCRIPTION="EventMachine based WebSocket server"
@@ -20,14 +24,19 @@ SLOT="0"
 KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
 IUSE=""
 
-DEPEND=""
-RDEPEND=""
-
 ruby_add_rdepend "
-       >=dev-ruby/eventmachine-0.5
-       >=dev-ruby/http_parser_rb-0.6.0
+       >=dev-ruby/eventmachine-0.12.9
+       =dev-ruby/http_parser_rb-0.6*
 "
 
+all_ruby_prepare() {
+       # Only run unit tests since we require unpackaged code for the
+       # integration tests.
+       sed -i -e "/^require 'em-\(spec\|http\|websocket-client\)/ s:^:#:" \
+               -e "/^require 'integration/ s:^:#:" spec/helper.rb || die
+       rm -fr spec/integration || die
+}
+
 all_ruby_install() {
        all_fakegem_install
 
index 6c884949856991c0a168e0b501c4e1544814bacd..8cebe0b9e509a1582e90797c68d2005b432703be 100644 (file)
@@ -5,6 +5,10 @@
                <email>bman@gentoo.org</email>
                <name>Aaron Bauman</name>
        </maintainer>
+  <maintainer type="project">
+    <email>ruby@gentoo.org</email>
+    <name>Gentoo Ruby Project</name>
+  </maintainer>
        <upstream>
                <remote-id type="github">igrigorik/em-websocket</remote-id>
        </upstream>