media-plugins/vdr-wirbelscan: version bump
authorJoerg Bornkessel <hd_brummy@gentoo.org>
Fri, 27 Dec 2019 13:33:27 +0000 (14:33 +0100)
committerJoerg Bornkessel <hd_brummy@gentoo.org>
Fri, 27 Dec 2019 13:33:59 +0000 (14:33 +0100)
this version need >=vdr-2.4
thx to klaus818@gmail.com for reporting this
moved to eapi 7
fixed Homepage

Bug: https://bugs.gentoo.org/703810
Closes: https://bugs.gentoo.org/703810
Package-Manager: Portage-2.3.83, Repoman-2.3.18
Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org>
media-plugins/vdr-wirbelscan/Manifest
media-plugins/vdr-wirbelscan/vdr-wirbelscan-0.0.7-r1.ebuild
media-plugins/vdr-wirbelscan/vdr-wirbelscan-2018.11.04.ebuild [new file with mode: 0644]

index be8c7316db2488962780d769f610fa505650515b..67f1023011613cef4765ef98e141fa6d3632f38f 100644 (file)
@@ -1 +1,2 @@
 DIST vdr-wirbelscan-0.0.7.tgz 149949 BLAKE2B b0b258b91bef493c352b8a2e7edec821b4046a7a6c2751ffe0e1deacd1ddcf3a563cc4051eee6424526903444952a0d489b8bca00533ba89a8214943948c76d9 SHA512 754b3089b1a8536b501fd8b62ddafedaf8304518856152a49b97149113929b47d6c6299b8eb4b78b2d3dc5aba147a3e21c00554ad02d2dc5018c296f6c55d6a5
+DIST vdr-wirbelscan-2018.11.04.tar.gz 146140 BLAKE2B 067046dcd11837f2de5a44acce35cc1c58778b7cc110a69eb1f35e2c2e792a1dfac0f04dc50c230b0ee4940a3ed8bf8fe34484ba6cc988b7f7da59c361e2d1d8 SHA512 61d7109f47c3a1d87d520d3228b0737073762e877b9b08d2716337de071bdf7f8419ae5285a72c5e29e4c5081403edb2cb729adf6755a9e898a662af30a7b92c
index 5bdd8471ddc8ca6abd2f87a0db60405f495bacdc..7920122c681b8c1627db21b1b2691acf46bd6617 100644 (file)
@@ -1,21 +1,19 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=7
 
 inherit vdr-plugin-2
 
 DESCRIPTION="VDR Plugin: Scan for channels on DVB-? and on PVR*-Cards"
-HOMEPAGE="http://wirbel.htpc-forum.de/wirbelscan/index2.html"
+HOMEPAGE="https://github.com/CvH/vdr-plugin-wirbelscan"
 SRC_URI="http://wirbel.htpc-forum.de/wirbelscan/${P}.tgz"
 
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE=""
 
 DEPEND=">=media-video/vdr-2"
-RDEPEND="${DEPEND}"
 
 src_prepare() {
        # remove untranslated po files
@@ -24,7 +22,7 @@ src_prepare() {
        # new Makefile handling
        cp "${FILESDIR}/wirbelscan.mk" "${S}/Makefile"
 
-       epatch "${FILESDIR}/receiver-api-fixes.patch"
+       eapply "${FILESDIR}/receiver-api-fixes.patch"
 
        vdr-plugin-2_src_prepare
 
diff --git a/media-plugins/vdr-wirbelscan/vdr-wirbelscan-2018.11.04.ebuild b/media-plugins/vdr-wirbelscan/vdr-wirbelscan-2018.11.04.ebuild
new file mode 100644 (file)
index 0000000..e45baf0
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vdr-plugin-2
+
+GIT_VERSION="e1377b95312a138a41f93d7b06b3adb4ed4e7324"
+
+DESCRIPTION="VDR Plugin: Scan for channels on DVB-? and on PVR*-Cards"
+HOMEPAGE="https://github.com/CvH/vdr-plugin-wirbelscan"
+SRC_URI="https://github.com/CvH/vdr-plugin-wirbelscan/archive/${GIT_VERSION}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=media-video/vdr-2.4"
+
+S="${WORKDIR}/vdr-plugin-wirbelscan-${GIT_VERSION}"
+
+src_prepare() {
+       # remove untranslated po files
+       rm "${S}"/po/{ca_ES,cs_CZ,da_DK,es_ES,el_GR,et_EE,fi_FI,fr_FR,hr_HR,hu_HU,nl_NL,nn_NO,pl_PL,pt_PT,ro_RO,ru_RU,sl_SI,sv_SE,tr_TR}.po
+
+       vdr-plugin-2_src_prepare
+
+       fix_vdr_libsi_include scanfilter.h
+       fix_vdr_libsi_include scanfilter.c
+}