sys-devel/ucpp: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Sun, 16 Jun 2019 16:10:02 +0000 (18:10 +0200)
committerDavid Seifert <soap@gentoo.org>
Sun, 16 Jun 2019 16:10:02 +0000 (18:10 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: David Seifert <soap@gentoo.org>
sys-devel/ucpp/ucpp-1.3.4.ebuild

index a665fce81592981798f8a2b4995465da91e83368..54bf56e743f2e7c6852d4b14159e658a6f2e5a8c 100644 (file)
@@ -1,9 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
-
-inherit eutils
+EAPI=7
 
 DESCRIPTION="A quick and light preprocessor, but anyway fully compliant to C99"
 HOMEPAGE="https://code.google.com/p/ucpp/"
@@ -23,5 +21,6 @@ src_configure() {
 src_install() {
        default
 
-       prune_libtool_files --all
+       # package provides .pc files
+       find "${D}" -name '*.la' -delete || die
 }