dev-ros/rosbag_storage: Bump to 1.15.4.
authorAlexis Ballier <aballier@gentoo.org>
Wed, 13 May 2020 11:24:13 +0000 (13:24 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Wed, 13 May 2020 14:07:04 +0000 (16:07 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ros/rosbag_storage/Manifest
dev-ros/rosbag_storage/rosbag_storage-1.15.4.ebuild [new file with mode: 0644]

index 5461096f722e196f5d622bf48bf02b8acd468c93..5b87fbdb1f744fec0c4bb2d731a6c4c96e941893 100644 (file)
@@ -1,2 +1,3 @@
 DIST ros_comm-1.14.2.tar.gz 1044745 BLAKE2B 1a5d47a4c6682c7a629d9d84be121a5eafcfc16621dec9a9ab9b57c2c7f9070f0007e15492ee44d86e1879351fae20bb9a759093424dd22ae7d44ae0f28e00e1 SHA512 8cece09572dc6b94a42eb49537cbcddbb954f70df01dc7ac9bd8aba17f53207b86afd8ccff81d929eca33bb9642ad7c530835d3f43471de497611940edae4777
 DIST ros_comm-1.14.3.tar.gz 1045287 BLAKE2B c079983aa730e70028d1bf2c365d01d99ce09ced0c0f6443b18f9d0fb83715f6af4b313d6db4eb99dcc10052c81fa3e6560e7b3591b2fbe14b9ec20fac24babe SHA512 52df24f10f476697ee6fa340da354b45431f35018a25e2674dc9306f175929a4b0368753503ea143f87aeb4945a2e67c37f83d833f54b53f9a76a81022c280a3
+DIST ros_comm-1.15.4.tar.gz 1071246 BLAKE2B 57867c192bfd48f3a0534762808c668031081a6155510879e68f9618226b9c5eff0d5fc9ec0e7ec8d0cc1f0d74794a4e55151036275ae6fc5bb613cc42137ddc SHA512 f92233cbf5ee97832023545730d3e756dfa08507072c074ac3e0763db1c2c2ab9fcbb0c90995a0c5d43f0ddc2ee528c185173a664b19abe4f8159aa3f3cb20dc
diff --git a/dev-ros/rosbag_storage/rosbag_storage-1.15.4.ebuild b/dev-ros/rosbag_storage/rosbag_storage-1.15.4.ebuild
new file mode 100644 (file)
index 0000000..4095940
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Set of tools for recording from and playing back ROS message"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-libs/console_bridge
+       app-crypt/gpgme
+       dev-ros/pluginlib
+       dev-ros/cpp_common
+       dev-ros/roscpp_serialization
+       dev-ros/roscpp_traits
+       dev-ros/rostime
+       dev-ros/roslz4
+       dev-libs/boost:=
+       app-arch/bzip2
+       dev-libs/console_bridge:=
+       dev-libs/tinyxml2:=
+
+       dev-libs/openssl:0=
+       app-crypt/gpgme
+"
+DEPEND="${RDEPEND}"