dev-python/nuitka: bump version to 0.6.6
authorOz Tiram <oz.tiram@gmail.com>
Sat, 18 Jan 2020 09:18:23 +0000 (10:18 +0100)
committerJoonas Niilola <juippis@gentoo.org>
Tue, 28 Jan 2020 15:03:24 +0000 (17:03 +0200)
Closes: https://bugs.gentoo.org/705392
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Oz Tiram <oz.tiram@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/14374
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-python/nuitka/Manifest
dev-python/nuitka/nuitka-0.6.6.ebuild [new file with mode: 0644]

index 89ce04d4a344dc78b31787ebfb8922b3e69e6a98..875fa625e38462b39fd08219ce137b6677f6f9b4 100644 (file)
@@ -1,2 +1,3 @@
 DIST Nuitka-0.6.4.tar.gz 2211662 BLAKE2B 4831782516503f128911321bb9755db9ea7d48fe0438dbff1fbc9ded3c690dc0d2f4dd14f0f5a5b8c66cb2b8e8d380e9658b590a48316497b42f78e68a8ae5ea SHA512 89e882b5fa37fd5a1357f69e13db7c340bc6d5471e18b7796cc1b7bd9970c480f8fecb9a7b11e19e41e936c5f90ef204b7409146a362beb6946f3d8f88cdf93e
 DIST Nuitka-0.6.5.tar.gz 2239333 BLAKE2B 687b82863ad5cb78d1c1b3b353ecee8a44eccbcd73eee70181bfe274d7e9d6011323bde9e320cd13c8c67deeef86de5e93c61592b56ca9fa9412fcfa3d152a06 SHA512 785dc60b4a42061401066ed510a3bc82988a0f8947372dcbd381c7b9cf6c2907c9cc0510c8188b0526c7fa3d9f3ec43207b46190a8485cf1e546b5316fa6dbdb
+DIST Nuitka-0.6.6.tar.gz 2276002 BLAKE2B 74ada1032d5eef3068e6c0fbd088437014de8752b71ce98b90bb868bb7241efe301d4fa1ef661f00f54730ca3d27470cc6c804bc2b394085349ad9a1aed0feb4 SHA512 82752105fc5b5d5d09d460ba25a6424420ff055ea841a32c6e32ec9099870ceefe06dcadab347fe689cec94f4d8891a4125910f7cff504a8aa736139b29c2a8b
diff --git a/dev-python/nuitka/nuitka-0.6.6.ebuild b/dev-python/nuitka/nuitka-0.6.6.ebuild
new file mode 100644 (file)
index 0000000..08ab6c5
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1 eutils python-utils-r1
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="https://www.nuitka.net"
+SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="dev-util/scons[${PYTHON_USEDEP}]"
+
+RDEPEND="${BDEPEND}
+       dev-python/appdirs[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${P^}"
+
+python_install() {
+       distutils-r1_python_install
+       python_optimize
+}
+
+pkg_postinst() {
+       optfeature "support for stand-alone executables" app-admin/chrpath
+}