app-vim/lightline: add lightline to the tree.
authorPatrice Clement <monsieurp@gentoo.org>
Thu, 22 Sep 2016 08:04:19 +0000 (10:04 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Thu, 22 Sep 2016 08:04:36 +0000 (10:04 +0200)
lightline is a light and configurable statusline/tabline for Vim.

Package-Manager: portage-2.2.28

app-vim/lightline/lightline-9999.ebuild [new file with mode: 0644]
app-vim/lightline/metadata.xml [new file with mode: 0644]

diff --git a/app-vim/lightline/lightline-9999.ebuild b/app-vim/lightline/lightline-9999.ebuild
new file mode 100644 (file)
index 0000000..e2c2c5f
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit vim-plugin
+
+if [[ ${PV} == "9999" ]] ; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/itchyny/lightline.vim/"
+else
+       SRC_URI="https://github.com/itchyny/${PN}.vim/archive/master.zip -> ${P}.zip"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="vim plugin: A light and configurable statusline/tabline"
+HOMEPAGE="https://github.com/itchyny/lightline.vim/"
+LICENSE="vim.org"
+VIM_PLUGIN_HELPFILES="${PN}"
+
+src_compile() { :; }
diff --git a/app-vim/lightline/metadata.xml b/app-vim/lightline/metadata.xml
new file mode 100644 (file)
index 0000000..6c8987e
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="project">
+    <email>vim@gentoo.org</email>
+    <name>Gentoo Vim Project</name>
+  </maintainer>
+  <maintainer type="person">
+    <email>monsieurp@gentoo.org</email>
+  </maintainer>
+</pkgmetadata>