net-print/cups-filters: Version bump
authorManuel Rüger <mrueg@gentoo.org>
Thu, 27 Aug 2015 18:08:39 +0000 (20:08 +0200)
committerManuel Rüger <mrueg@gentoo.org>
Thu, 27 Aug 2015 18:08:39 +0000 (20:08 +0200)
Package-Manager: portage-2.2.20.1

net-print/cups-filters/Manifest
net-print/cups-filters/cups-filters-1.0.73.ebuild [new file with mode: 0644]

index fbae5cc01b9ad6d27b4d5a68605bbbb9fbbf87e4..e2dbba36640a66b48a7f737d194ec9fa913fb725 100644 (file)
@@ -1,2 +1,3 @@
 DIST cups-filters-1.0.66.tar.xz 1335740 SHA256 a46eea35d8c151f1f63c663c5dda290ba11a7f5951d48dba485a02f9146dfb1c SHA512 275d704a52889fd0f18b9c1ed5aad70efd0df3b0beac30fca5467135d9c9b0ccc0ea7e3d1274086cf475c4a569262edc85962b5076df3ba2e9d3fe4d2c376fa2 WHIRLPOOL 040fe61f197187913c90e42a26ada1957e9289854627af3cceff984027fb630417b9e8548e3ca7d713a74ad0074389459a41de3bc7579438335a84e30a694ba5
 DIST cups-filters-1.0.71.tar.xz 1339116 SHA256 3180aa209c383402822e568ccef8e1ca43f51e30b3af2039c34ebae919a69c1f SHA512 dc243e88d535c8d7e7fd53074b1093a46fc22742504efa09096d2b216846df875e4d914f25d2f726034692538cfdf1b713bc1ef44d199003a21e242b99f44a01 WHIRLPOOL 4afc7079594563f57af81501192cc0cba19db6cd5c10a9544339858a343e245b485e528fbf80eecd711341b23b8321bde817c49db7ddd2f0b801da2b4b9c580d
+DIST cups-filters-1.0.73.tar.xz 1351652 SHA256 84521dc5079e683144e95e22ffcdbc3d51c44f9d4079c5bcc7f7ff421e94ec75 SHA512 ae380403569640fab21c9a0914b894628bcc57b709d68c05b620ec425734436281fe752d99b83c114927110489e523ffdb676b723109094dc7ef6d53bc9e8f41 WHIRLPOOL 3c447ed182a73cab84349101f5846c0cf9784de0b50960bc689de3f4086becf392229d378cc5fa70857adc66191f67e564ed5b6f2c081a7184e62b788d1f80f9
diff --git a/net-print/cups-filters/cups-filters-1.0.73.ebuild b/net-print/cups-filters/cups-filters-1.0.73.ebuild
new file mode 100644 (file)
index 0000000..84982d8
--- /dev/null
@@ -0,0 +1,120 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+GENTOO_DEPEND_ON_PERL=no
+
+inherit base eutils perl-module autotools systemd
+
+if [[ "${PV}" == "9999" ]] ; then
+       inherit bzr
+       EBZR_REPO_URI="http://bzr.linuxfoundation.org/openprinting/cups-filters"
+       KEYWORDS=""
+else
+       SRC_URI="http://www.openprinting.org/download/${PN}/${P}.tar.xz"
+       KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~m68k-mint"
+fi
+DESCRIPTION="Cups PDF filters"
+HOMEPAGE="http://www.linuxfoundation.org/collaborate/workgroups/openprinting/pdfasstandardprintjobformat"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+IUSE="dbus +foomatic jpeg perl png static-libs tiff zeroconf"
+
+RDEPEND="
+       >=app-text/ghostscript-gpl-9.09
+       app-text/poppler:=[cxx,jpeg?,lcms,tiff?,xpdf-headers(+)]
+       >=app-text/qpdf-3.0.2:=
+       media-libs/fontconfig
+       media-libs/freetype:2
+       media-libs/lcms:2
+       >=net-print/cups-1.7.3
+       !<=net-print/cups-1.5.9999
+       sys-devel/bc
+       sys-libs/zlib
+       dbus? ( sys-apps/dbus )
+       foomatic? ( !net-print/foomatic-filters )
+       jpeg? ( virtual/jpeg:0 )
+       perl? ( dev-lang/perl:= )
+       png? ( media-libs/libpng:0= )
+       tiff? ( media-libs/tiff:0 )
+       zeroconf? ( net-dns/avahi[dbus] )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+       base_src_prepare
+       sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+               --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+               $(use_enable dbus) \
+               $(use_enable zeroconf avahi) \
+               $(use_enable static-libs static) \
+               --with-fontdir="fonts/conf.avail" \
+               --with-pdftops=pdftops \
+               --enable-imagefilters \
+               $(use_with jpeg) \
+               $(use_with png) \
+               $(use_with tiff) \
+               --with-rcdir=no \
+               --with-browseremoteprotocols=DNSSD,CUPS \
+               --without-php
+}
+
+src_compile() {
+       MAKEOPTS=-j1 default
+
+       if use perl; then
+               pushd "${S}/scripting/perl" > /dev/null
+               perl-module_src_configure
+               perl-module_src_compile
+               popd > /dev/null
+       fi
+}
+
+src_install() {
+       default
+
+       if use perl; then
+               pushd "${S}/scripting/perl" > /dev/null
+               perl-module_src_install
+               perl_delete_localpod
+               popd > /dev/null
+       fi
+
+       # workaround: some printer drivers still require pstoraster and pstopxl, bug #383831
+       dosym /usr/libexec/cups/filter/gstoraster /usr/libexec/cups/filter/pstoraster
+       dosym /usr/libexec/cups/filter/gstopxl /usr/libexec/cups/filter/pstopxl
+
+       prune_libtool_files --all
+
+       cp "${FILESDIR}"/cups-browsed.init.d "${T}"/cups-browsed || die
+
+       if ! use zeroconf ; then
+               sed -i -e 's:need cupsd avahi-daemon:need cupsd:g' "${T}"/cups-browsed || die
+               sed -i -e 's:cups\.service avahi-daemon\.service:cups.service:g' "${S}"/utils/cups-browsed.service || die
+       fi
+
+       if ! use foomatic ; then
+               # this needs an upstream solution / configure switch
+               rm -v "${ED}/usr/bin/foomatic-rip" || die
+               rm -v "${ED}/usr/libexec/cups/filter/foomatic-rip" || die
+               rm -v "${ED}/usr/share/man/man1/foomatic-rip.1" || die
+       fi
+
+       doinitd "${T}"/cups-browsed
+       systemd_dounit "${S}/utils/cups-browsed.service"
+}
+
+pkg_postinst() {
+       if ! use foomatic ; then
+               ewarn "You are disabling the foomatic code in cups-filters. Please do that ONLY if absolutely."
+               ewarn "necessary. net-print/foomatic-filters as replacement is deprecated and unmaintained."
+       fi
+}