www-servers/tornado: Remove py2
authorMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 07:12:35 +0000 (08:12 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 09:39:50 +0000 (10:39 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
www-servers/tornado/tornado-4.5.3.ebuild
www-servers/tornado/tornado-5.1-r1.ebuild

index 9de109a2f008dbb572b1171d45631754f692c051..2f8adca7e838f76d3eda51bad943c7528c3df387 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-PYTHON_COMPAT=( python2_7 python3_6 )
+PYTHON_COMPAT=( python3_6 )
 PYTHON_REQ_USE="threads(+)"
 
 inherit distutils-r1
@@ -21,18 +21,7 @@ RESTRICT="!test? ( test )"
 CDEPEND="
        dev-python/certifi[${PYTHON_USEDEP}]
        >=dev-python/pycurl-7.19.3.1[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7')
-       || (
-               >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
-               (       $(python_gen_cond_dep 'dev-python/twisted-names[${PYTHON_USEDEP}]' 'python2_7')
-                       $(python_gen_cond_dep 'dev-python/twisted-web[${PYTHON_USEDEP}]' 'python2_7')
-               )
-       )
-       $(python_gen_cond_dep '
-               dev-python/backports-abc[${PYTHON_USEDEP}]
-               dev-python/futures[${PYTHON_USEDEP}]
-               dev-python/singledispatch[${PYTHON_USEDEP}]
-       ' -2)
+       >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
 "
 DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
index d2edc90b33310fbf2f226b8c7b73c4042e65c953..9fe88cdfb0510ae00debb62aaca8d9833dd286ae 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6,7,8} )
 PYTHON_REQ_USE="threads(+)"
 
 inherit distutils-r1
@@ -19,14 +19,8 @@ IUSE="examples test"
 RESTRICT="!test? ( test )"
 
 CDEPEND="
-       $(python_gen_cond_dep 'dev-python/futures[${PYTHON_USEDEP}]' 'python2_7')
        >=dev-python/pycurl-7.19.3.1[${PYTHON_USEDEP}]
        >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep '
-               dev-python/backports-abc[${PYTHON_USEDEP}]
-               dev-python/futures[${PYTHON_USEDEP}]
-               dev-python/singledispatch[${PYTHON_USEDEP}]
-       ' -2)
 "
 DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]