dev-util/lttng-ust: fix missing numa dependency error
authorYixun Lan <dlan@gentoo.org>
Wed, 23 Oct 2019 02:23:54 +0000 (10:23 +0800)
committerYixun Lan <dlan@gentoo.org>
Wed, 23 Oct 2019 02:23:54 +0000 (10:23 +0800)
Closes: https://bugs.gentoo.org/698296
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Yixun Lan <dlan@gentoo.org>
dev-util/lttng-ust/lttng-ust-2.11.0.ebuild
dev-util/lttng-ust/metadata.xml

index ead5c2518d160ce5946bb623249a581d23bc7f20..ecc26c91c8acedc8cbee5eb9408cacb2db39309b 100644 (file)
@@ -15,9 +15,12 @@ SRC_URI="http://lttng.org/files/${PN}/${MY_P}.tar.bz2"
 LICENSE="GPL-2"
 SLOT="0/${MY_SLOT}"
 KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
-IUSE="examples"
+IUSE="examples numa"
 
-DEPEND="dev-libs/userspace-rcu:="
+DEPEND="
+       dev-libs/userspace-rcu:=
+       numa? ( sys-process/numactl )
+       "
 RDEPEND="${DEPEND}"
 
 S="${WORKDIR}"/${MY_P}
@@ -31,5 +34,7 @@ src_prepare() {
 }
 
 src_configure() {
-       econf --docdir=/usr/share/doc/${PF}
+       econf \
+               $(use_enable numa) \
+               --docdir=/usr/share/doc/${PF}
 }
index 6c50e4708494cff36b0fd29f20557e3db9fe4eaf..2b073ed003224a87d6812541b384ee3f41161b00 100644 (file)
@@ -5,7 +5,9 @@
                <email>dlan@gentoo.org</email>
                <name>Yixun Lan</name>
        </maintainer>
-
+       <use>
+               <flag name="numa">Enable numa support</flag>
+       </use>
        <longdescription>
                The userspace tracer is designed to provide detailed information about userspace activity. UST is a port of the LTTng kernel tracer to userspace. Like the LTTng kernel tracer, performance is the main goal. Tracing does not require system calls or traps. UST instrumentation points may be added in any userspace code including signal handlers and libraries.
        </longdescription>