old
authorMike Frysinger <vapier@gentoo.org>
Thu, 28 Dec 2006 18:59:41 +0000 (18:59 +0000)
committerMike Frysinger <vapier@gentoo.org>
Thu, 28 Dec 2006 18:59:41 +0000 (18:59 +0000)
net-p2p/bittorrent/bittorrent-3.4.2-r2.ebuild [deleted file]
net-p2p/bittorrent/bittorrent-4.2.2.ebuild [deleted file]
net-p2p/bittorrent/bittorrent-4.26.0.ebuild [deleted file]
net-p2p/bittorrent/files/btdownloadgui.desktop [deleted file]
net-p2p/bittorrent/files/bttrack.conf [deleted file]
net-p2p/bittorrent/files/bttrack.rc [deleted file]
net-p2p/bittorrent/files/digest-bittorrent-3.4.2-r2 [deleted file]
net-p2p/bittorrent/files/digest-bittorrent-4.2.2 [deleted file]
net-p2p/bittorrent/files/digest-bittorrent-4.26.0 [deleted file]
net-p2p/bittorrent/files/favicon.ico [deleted file]

diff --git a/net-p2p/bittorrent/bittorrent-3.4.2-r2.ebuild b/net-p2p/bittorrent/bittorrent-3.4.2-r2.ebuild
deleted file mode 100644 (file)
index e4945d7..0000000
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/bittorrent-3.4.2-r2.ebuild,v 1.11 2006/01/22 10:20:07 mkay Exp $
-
-inherit distutils
-
-MY_P="${P/bittorrent/BitTorrent}"
-MY_P="${MY_P/\.0/}"
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="tool for distributing files via a distributed network of nodes"
-HOMEPAGE="http://bitconjurer.org/BitTorrent"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ppc sparc x86"
-IUSE="gtk"
-
-RDEPEND="gtk? ( <dev-python/wxpython-2.5 )
-       >=dev-lang/python-2.1
-       !virtual/bittorrent"
-DEPEND="${RDEPEND}
-       app-arch/unzip
-       >=sys-apps/sed-4.0.5"
-PROVIDE="virtual/bittorrent"
-
-DOCS="credits.txt"
-PYTHON_MODNAME="BitTorrent"
-
-src_install() {
-       distutils_src_install
-       if ! use gtk; then
-               rm ${D}/usr/bin/*gui.py
-       fi
-       dohtml redirdonate.html
-       dodir etc
-       cp -pPR /etc/mailcap ${D}/etc/
-
-       MAILCAP_STRING="application/x-bittorrent; /usr/bin/btdownloadgui.py '%s'; test=test -n \"\$DISPLAY\""
-
-       if use gtk; then
-               if [ -n "`grep 'application/x-bittorrent' ${D}/etc/mailcap`" ]; then
-                       # replace bittorrent entry if it already exists
-                       einfo "updating bittorrent mime info"
-                       sed -i "s,application/x-bittorrent;.*,${MAILCAP_STRING}," ${D}/etc/mailcap
-               else
-                       # add bittorrent entry if it doesn't exist
-                       einfo "adding bittorrent mime info"
-                       echo "${MAILCAP_STRING}" >> ${D}/etc/mailcap
-               fi
-       else
-               # get rid of any reference to the not-installed gui version
-               sed -i '/btdownloadgui/d' ${D}/etc/mailcap
-       fi
-
-       insinto /usr/share/bittorrent
-       doins ${FILESDIR}/favicon.ico
-
-       insinto /etc/conf.d
-       newins ${FILESDIR}/bttrack.conf bttrack
-
-       exeinto /etc/init.d
-       newexe ${FILESDIR}/bttrack.rc bttrack
-}
-
-pkg_postinst() {
-       einfo "unofficial feature additions. If you would like statistics, please"
-       einfo "install net-p2p/bittorrent-stats."
-       distutils_pkg_postinst
-}
diff --git a/net-p2p/bittorrent/bittorrent-4.2.2.ebuild b/net-p2p/bittorrent/bittorrent-4.2.2.ebuild
deleted file mode 100644 (file)
index 978c5b7..0000000
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/bittorrent-4.2.2.ebuild,v 1.10 2006/02/07 02:47:06 agriffis Exp $
-
-inherit distutils fdo-mime eutils
-
-MY_P="${P/bittorrent/BitTorrent}"
-#MY_P="${MY_P/}"
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="tool for distributing files via a distributed network of nodes"
-HOMEPAGE="http://www.bittorrent.com/"
-SRC_URI="http://www.bittorrent.com/dl/${MY_P}.tar.gz"
-
-LICENSE="BitTorrent"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ppc sparc x86"
-IUSE="gtk"
-
-RDEPEND="gtk? (
-               >=x11-libs/gtk+-2.4
-               >=dev-python/pygtk-2.4
-       )
-       >=dev-lang/python-2.3
-       >=dev-python/pycrypto-2.0
-       !virtual/bittorrent"
-DEPEND="${RDEPEND}
-       app-arch/gzip
-       >=sys-apps/sed-4.0.5
-       dev-python/dnspython"
-PROVIDE="virtual/bittorrent"
-
-DOCS="TRACKERLESS.txt LICENSE.txt public.key"
-PYTHON_MODNAME="BitTorrent"
-
-src_unpack() {
-       unpack ${A}
-       cd ${S}
-
-       # path for documentation is in lowercase (see bug #109743)
-       sed -i -r "s:(dp.*appdir):\1.lower():" BitTorrent/platform.py
-}
-
-src_install() {
-       distutils_src_install
-       if ! use gtk; then
-               rm ${D}/usr/bin/bittorrent
-       fi
-       dohtml redirdonate.html
-
-       mv ${S}/{credits-l10n.txt,credits.txt} \
-               ${D}/usr/share/doc/${P}
-       mv ${D}/usr/share/doc/${PF} ${D}/usr/share/doc/${P}
-
-       if use gtk ; then
-               cp ${D}/usr/share/pixmaps/${MY_P}/bittorrent.ico ${D}/usr/share/pixmaps/
-               make_desktop_entry "bittorrent" "BitTorrent" \
-                       /usr/share/pixmaps/bittorrent.ico "Network"
-               echo "MimeType=application/x-bittorrent" \
-                       >> ${D}/usr/share/applications/bittorrent-${PN}.desktop
-       fi
-
-       insinto /etc/conf.d
-       newins ${FILESDIR}/bittorrent-tracker.confd bittorrent-tracker
-
-       exeinto /etc/init.d
-       newexe ${FILESDIR}/bittorrent-tracker.initd bittorrent-tracker
-}
-
-pkg_postinst() {
-       einfo
-       einfo "Remember that BitTorrent has changed file naming scheme"
-       einfo "To run BitTorrent just execute /usr/bin/bittorrent"
-       einfo
-       if [ -f ${ROOT}/etc/init.d/bttrack -o -f ${ROOT}/etc/conf.d/bttrack ]; then
-               einfo "Please use /etc/init.d/bittorrent-tracker and "
-               einfo "/etc/conf.d/bittorrent-tracker instead of"
-               einfo "/etc/init.d/bttrack and /etc/conf.d/bttrack. "
-               einfo "You can safety remove the old files"
-               einfo
-       fi
-       distutils_pkg_postinst
-       fdo-mime_desktop_database_update
-}
diff --git a/net-p2p/bittorrent/bittorrent-4.26.0.ebuild b/net-p2p/bittorrent/bittorrent-4.26.0.ebuild
deleted file mode 100644 (file)
index 32550d4..0000000
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/bittorrent-4.26.0.ebuild,v 1.2 2006/12/28 18:14:56 vapier Exp $
-
-inherit distutils fdo-mime eutils
-
-MY_P="${P/bittorrent/BitTorrent}"
-#MY_P="${MY_P/}"
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="tool for distributing files via a distributed network of nodes"
-HOMEPAGE="http://www.bittorrent.com/"
-SRC_URI="http://download.bittorrent.com/dl/${MY_P}.tar.gz"
-
-LICENSE="BitTorrent"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="gtk"
-
-RDEPEND="gtk? (
-               >=x11-libs/wxGTK-2.6
-               >=dev-python/wxpython-2.6
-       )
-       >=dev-lang/python-2.3
-       >=dev-python/pycrypto-2.0
-       >=dev-python/twisted-2
-       dev-python/twisted-web
-       !virtual/bittorrent"
-DEPEND="${RDEPEND}
-       app-arch/gzip
-       >=sys-apps/sed-4.0.5
-       dev-python/dnspython"
-PROVIDE="virtual/bittorrent"
-
-DOCS="TRACKERLESS.txt public.key"
-PYTHON_MODNAME="BitTorrent"
-
-pkg_setup() {
-       if use gtk ; then
-               if ! built_with_use x11-libs/wxGTK unicode ; then
-                       die "You must build wxGTK and wxpython with unicode support"
-               fi
-               if ! built_with_use dev-python/wxpython unicode ; then
-                       die "You must build wxGTK and wxpython with unicode support"
-               fi
-       fi
-}
-
-src_unpack() {
-       unpack ${A}
-       cd ${S}
-
-       # path for documentation is in lowercase (see bug #109743)
-       sed -i -r "s:(dp.*appdir):\1.lower():" BitTorrent/platform.py
-}
-
-src_install() {
-       distutils_src_install
-       if ! use gtk ; then
-               rm ${D}/usr/bin/bittorrent
-       fi
-       dohtml redirdonate.html
-
-       mv ${S}/{credits-l10n.txt,credits.txt} \
-               ${D}/usr/share/doc/${P}
-
-       if use gtk ; then
-               cp ${D}/usr/share/pixmaps/${MY_P}/bittorrent.ico ${D}/usr/share/pixmaps/
-               make_desktop_entry "bittorrent" "BitTorrent" \
-                       /usr/share/pixmaps/bittorrent.ico "Network"
-               echo "MimeType=application/x-bittorrent" \
-                       >> ${D}/usr/share/applications/bittorrent-${PN}.desktop
-       fi
-
-       insinto /etc/conf.d
-       newins ${FILESDIR}//bttrack.conf bttrack
-
-       exeinto /etc/init.d
-       newexe ${FILESDIR}/bttrack.rc bttrack
-}
-
-pkg_postinst() {
-       einfo "Remember that BitTorrent has changed file naming scheme"
-       einfo "To run BitTorrent just execute /usr/bin/bittorrent"
-       distutils_pkg_postinst
-       fdo-mime_desktop_database_update
-}
diff --git a/net-p2p/bittorrent/files/btdownloadgui.desktop b/net-p2p/bittorrent/files/btdownloadgui.desktop
deleted file mode 100644 (file)
index 577d0c0..0000000
+++ /dev/null
@@ -1,7 +0,0 @@
-[Desktop Entry]
-Name=BitTorrent
-Exec=/usr/bin/bittorrent
-Icon=/usr/share/pixmaps/bittorrent.ico
-Terminal=false
-Type=Application
-Categories=Application;Network;
diff --git a/net-p2p/bittorrent/files/bttrack.conf b/net-p2p/bittorrent/files/bttrack.conf
deleted file mode 100644 (file)
index 16408c4..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-# /etc/conf.d/bttrack
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/files/bttrack.conf,v 1.3 2006/02/16 17:34:14 sekretarz Exp $
-
-# Change this to this to the port you would like to connect to for the tracker.
-# It is accessible at http://localhost:PORT/ from any web browser.
-PORT=8082
-
-# where to store recent downloader info
-DFILE=/usr/share/bittorrent/tracker.dfile
-
-# path to favicon.ico which many popular web browsers can use
-FAVICON=/usr/share/pixmaps/bittorrent.ico
-
-# Connection logs are sent to stdout by default, so they should be sent to a
-# file when using this script.
-LOGFILE=/var/log/bttrack.log
diff --git a/net-p2p/bittorrent/files/bttrack.rc b/net-p2p/bittorrent/files/bttrack.rc
deleted file mode 100644 (file)
index fc445de..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2005Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/files/bttrack.rc,v 1.2 2006/02/16 17:34:14 sekretarz Exp $
-
-depend() {
-       need net
-}
-
-start() {
-       ebegin "Starting bttrack"
-       start-stop-daemon --start --quiet --background --make-pidfile \
-       --pidfile /var/run/bttrack.pid \
-       --exec /usr/bin/bittorrent-tracker -- --port ${PORT} \
-       --dfile ${DFILE} --favicon ${FAVICON} --logfile ${LOGFILE}
-       eend $?
-}
-
-stop() {
-       ebegin "Stopping bttrack"
-       start-stop-daemon --stop --quiet --pidfile /var/run/bttrack.pid
-       eend $?
-}
diff --git a/net-p2p/bittorrent/files/digest-bittorrent-3.4.2-r2 b/net-p2p/bittorrent/files/digest-bittorrent-3.4.2-r2
deleted file mode 100644 (file)
index 712b985..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 6ad4e128ddc82f8ebef6fbef59872f0d BitTorrent-3.4.2.zip 244989
-RMD160 ef296e28559570463e46bee299b46ebce473f87a BitTorrent-3.4.2.zip 244989
-SHA256 aa7f169a6e896413bb39a63b2522fe830cc0e98fd4e58b6f8d0fda712816fed1 BitTorrent-3.4.2.zip 244989
diff --git a/net-p2p/bittorrent/files/digest-bittorrent-4.2.2 b/net-p2p/bittorrent/files/digest-bittorrent-4.2.2
deleted file mode 100644 (file)
index c039fcf..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 2a85715b8ef0335ecc9e8ad91860231b BitTorrent-4.2.2.tar.gz 2238224
-RMD160 dd8a504490380b728d29b1d700abd8275c629a11 BitTorrent-4.2.2.tar.gz 2238224
-SHA256 cd14416698064015292ad128ddf349747f2cbb6e06d3c0ffa49b7ddfeda254ff BitTorrent-4.2.2.tar.gz 2238224
diff --git a/net-p2p/bittorrent/files/digest-bittorrent-4.26.0 b/net-p2p/bittorrent/files/digest-bittorrent-4.26.0
deleted file mode 100644 (file)
index 0c438e6..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 63200fd2d56f49c633624fda9436e0a8 BitTorrent-4.26.0.tar.gz 2475616
-RMD160 f32850486b717e035b86f30c629f9d707ffc50af BitTorrent-4.26.0.tar.gz 2475616
-SHA256 5877bbe4193b56ea2cea68cdee913edd88b4d1ed6e54abcdbf1bd1d3c7e3e567 BitTorrent-4.26.0.tar.gz 2475616
diff --git a/net-p2p/bittorrent/files/favicon.ico b/net-p2p/bittorrent/files/favicon.ico
deleted file mode 100644 (file)
index 47e6e70..0000000
Binary files a/net-p2p/bittorrent/files/favicon.ico and /dev/null differ