net-print/hplip: Add python 3.8 support.
authorDaniel Pielmeier <billie@gentoo.org>
Sun, 19 Apr 2020 14:41:15 +0000 (16:41 +0200)
committerDaniel Pielmeier <billie@gentoo.org>
Sun, 19 Apr 2020 14:41:46 +0000 (16:41 +0200)
Requires dev-python/distro thus dropping ppc support as it misses keywords.

Package-Manager: Portage-2.3.99, Repoman-2.3.20
Signed-off-by: Daniel Pielmeier <billie@gentoo.org>
net-print/hplip/hplip-3.20.3.ebuild

index 6abdff9d5b0ec141893d7d1d871b85613526a25c..d24a1c95865eb27accf543cba1b38b9653c8e41a 100644 (file)
@@ -3,13 +3,13 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
 PYTHON_REQ_USE="threads(+),xml"
 
 # 14 and 15 spit out a lot of warnings about subdirs
 WANT_AUTOMAKE="1.13"
 
-inherit autotools linux-info python-single-r1 readme.gentoo-r1 udev
+inherit autotools flag-o-matic linux-info python-single-r1 readme.gentoo-r1 udev
 
 DESCRIPTION="HP Linux Imaging and Printing - Print, scan, fax drivers and service tools"
 HOMEPAGE="https://developers.hp.com/hp-linux-imaging-and-printing"
@@ -18,7 +18,7 @@ SRC_URI="mirror://sourceforge/hplip/${P}.tar.gz
 
 LICENSE="GPL-2"
 SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
 
 IUSE="doc fax +hpcups hpijs kde libnotify libressl -libusb0 minimal parport policykit qt5 scanner +snmp static-ppds X"
 
@@ -54,6 +54,7 @@ RDEPEND="
                kernel_linux? ( virtual/udev )
                $(python_gen_cond_dep '
                        >=dev-python/dbus-python-1.2.0-r1[${PYTHON_MULTI_USEDEP}]
+                       dev-python/distro[${PYTHON_MULTI_USEDEP}]
                        fax? ( dev-python/reportlab[${PYTHON_MULTI_USEDEP}] )
                        qt5? (
                                >=dev-python/PyQt5-5.5.1[dbus,gui,widgets,${PYTHON_MULTI_USEDEP}]
@@ -147,6 +148,8 @@ src_prepare() {
 src_configure() {
        local myconf drv_build minimal_build
 
+       append-cppflags "$(python-config --includes)"
+
        if use libusb0 ; then
                myconf="${myconf} --enable-libusb01_build"
        else