sys-devel/clang: add rc version for testing
authorBernard Cafarelli <voyageur@gentoo.org>
Mon, 24 Aug 2015 15:01:24 +0000 (17:01 +0200)
committerBernard Cafarelli <voyageur@gentoo.org>
Mon, 24 Aug 2015 15:03:05 +0000 (17:03 +0200)
Package-Manager: portage-2.2.20.1

sys-devel/clang/clang-3.7.0_rc2-r100.ebuild [new file with mode: 0644]
sys-devel/clang/metadata.xml

diff --git a/sys-devel/clang/clang-3.7.0_rc2-r100.ebuild b/sys-devel/clang/clang-3.7.0_rc2-r100.ebuild
new file mode 100644 (file)
index 0000000..145a0f1
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib-build
+
+DESCRIPTION="C language family frontend for LLVM (meta-ebuild)"
+HOMEPAGE="http://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="UoI-NCSA"
+SLOT="0/3.6"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="debug multitarget python +static-analyzer"
+
+RDEPEND="~sys-devel/llvm-${PV}[clang(-),debug=,multitarget?,python?,static-analyzer,${MULTILIB_USEDEP}]"
+
+# Please keep this package around since it's quite likely that we'll
+# return to separate LLVM & clang ebuilds when the cmake build system
+# is complete.
+
+pkg_postinst() {
+       if has_version ">=dev-util/ccache-3.1.9-r2" ; then
+               #add ccache links as clang might get installed after ccache
+               "${EROOT}"/usr/bin/ccache-config --install-links
+       fi
+}
+
+pkg_postrm() {
+       if has_version ">=dev-util/ccache-3.1.9-r2" && [[ -z ${REPLACED_BY_VERSION} ]]; then
+               # --remove-links would remove all links, --install-links updates them
+               "${EROOT}"/usr/bin/ccache-config --install-links
+       fi
+}
index 735c9da104df50303386576da6d8f6c61604a9d4..466ad974778a8d1624ded42b23c10cbf50b7bfcd 100644 (file)
@@ -1,5 +1,5 @@
 <?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
        <maintainer>
                <email>clang@gentoo.org</email>