dev-libs/bemenu: remove merged patch
authorMatthew Thode <prometheanfire@gentoo.org>
Mon, 16 Mar 2020 03:09:37 +0000 (22:09 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Mon, 16 Mar 2020 03:09:56 +0000 (22:09 -0500)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-libs/bemenu/bemenu-9999.ebuild
dev-libs/bemenu/files/soname-fix.patch [deleted file]

index 8b4263622de982353f40617bd7f0aec14a7f3eaf..06c598e8072ca5489e574b610691ac28ee337387 100644 (file)
@@ -40,8 +40,6 @@ DEPEND="
 RDEPEND="${DEPEND}"
 BDEPEND="doc? ( app-doc/doxygen )"
 
-PATCHES=( "${FILESDIR}/soname-fix.patch" )
-
 src_compile() {
        emake clients $(usex ncurses curses) $(usex X x11) $(usex wayland wayland)
        use doc && emake doxygen
diff --git a/dev-libs/bemenu/files/soname-fix.patch b/dev-libs/bemenu/files/soname-fix.patch
deleted file mode 100644 (file)
index 7fe3338..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-commit 92929f9777b9c39a2829a9db1c19ef37859dc7fc
-Author: Matthew Thode <mthode@mthode.org>
-Date:   Sun Mar 15 14:00:14 2020 -0500
-
-    add soname to shared libraries
-    
-    Found in Gentoo QA
-    
-    * QA Notice: The following shared libraries lack a SONAME
-    * /usr/lib/libbemenu.so.0.4.0
-    
-    Signed-off-by: Matthew Thode <mthode@mthode.org>
-
-diff --git a/GNUmakefile b/GNUmakefile
-index c82bfd3..5b7b081 100644
---- a/GNUmakefile
-+++ b/GNUmakefile
-@@ -36,7 +36,7 @@ wayland: bemenu-renderer-wayland.so
-       $(LINK.c) -c $(filter %.c,$^) $(LDLIBS) -o $@
- $(libs): %: VERSION .git/index
--      $(LINK.c) -shared -fPIC $(filter %.c %.a,$^) $(LDLIBS) -o $(addsuffix .$(VERSION), $@)
-+      $(LINK.c) -shared -fPIC $(filter %.c %.a,$^) $(LDLIBS) -o $(addsuffix .$(VERSION), $@) -Wl,-soname
-       ln -fs $(addsuffix .$(VERSION), $@) $(addsuffix .$(firstword $(subst ., ,$(VERSION))), $@)
-       ln -fs $(addsuffix .$(VERSION), $@) $@