dev-lang/go-bootstrap: avoid stripping test data files
authorMichael Marineau <mike@marineau.org>
Fri, 21 Aug 2015 20:31:08 +0000 (13:31 -0700)
committerWilliam Hubbs <williamh@gentoo.org>
Sun, 23 Aug 2015 15:30:44 +0000 (10:30 -0500)
Go includes a number of pre-built object files for testing. Since they
are not actually executed and may not even be native to the local system
stripping them is meaningless. This syncs up STRIP_MASK with the same
list used by the latest go ebuilds.

One file, src/debug/dwarf/testdata/typedef.elf, includes a build-id
which causes a conflict with the go-1.4 when FEATURES=splitdebug is
enabled.

Fixes bug #549598

dev-lang/go-bootstrap/go-bootstrap-1.4.2.ebuild

index 2610ffedd63658bd87f8c9d6c6a2a72e8fec4ca7..faba1caae7c3bb3190df148bb385a77bbc0f315c 100644 (file)
@@ -26,9 +26,11 @@ RDEPEND=""
 QA_MULTILIB_PATHS="usr/lib/go1.4/pkg/tool/.*/.*"
 
 # The go language uses *.a files which are _NOT_ libraries and should not be
-# stripped.
-STRIP_MASK="/usr/lib/go1.4/pkg/linux*/*.a
-       /usr/lib/go1.4/pkg/freebsd*/*.a /usr/lib/go1.4/pkg/darwin*/*.a"
+# stripped. The test data objects should also be left alone and unstripped.
+STRIP_MASK="/usr/lib/go1.4/pkg/*.a
+       /usr/lib/go1.4/src/debug/elf/testdata/*
+       /usr/lib/go1.4/src/debug/dwarf/testdata/*
+       /usr/lib/go1.4/src/runtime/race/*.syso"
 
 S="${WORKDIR}"/go
 
@@ -63,7 +65,7 @@ src_install()
 {
        dodir /usr/lib/go1.4
        exeinto /usr/lib/go1.4/bin
-doexe bin/*
+       doexe bin/*
        insinto /usr/lib/go1.4
        doins -r lib pkg src
        fperms -R +x /usr/lib/go1.4/pkg/tool