dev-cpp/clucene: fix building w/ clang and libc++
authorDenis Pronin <dannftk@yandex.ru>
Fri, 21 Feb 2020 12:55:44 +0000 (15:55 +0300)
committerMichał Górny <mgorny@gentoo.org>
Mon, 2 Mar 2020 09:09:09 +0000 (10:09 +0100)
Signed-off-by: Denis Pronin <dannftk@yandex.ru>
Closes: https://github.com/gentoo/gentoo/pull/14730
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-cpp/clucene/clucene-2.3.3.4-r6.ebuild
dev-cpp/clucene/files/clucene-2.3.3.4-gmtime.patch [new file with mode: 0644]

index 31b96850ad9e84a795c2e90eaaaad29eb3fba923..49e53b0da09ddcbfb42587e8b8aae6f69256bd3f 100644 (file)
@@ -33,6 +33,7 @@ PATCHES=(
        "${FILESDIR}/${P}-contrib.patch"
        "${FILESDIR}/${P}-pkgconfig.patch"
        "${FILESDIR}/${P}-gcc6.patch"
+       "${FILESDIR}/${P}-gmtime.patch"
 )
 
 src_prepare() {
diff --git a/dev-cpp/clucene/files/clucene-2.3.3.4-gmtime.patch b/dev-cpp/clucene/files/clucene-2.3.3.4-gmtime.patch
new file mode 100644 (file)
index 0000000..d4c702b
--- /dev/null
@@ -0,0 +1,12 @@
+diff -Naur clucene-core-2.3.3.4/src/core/CLucene/document/DateTools.cpp clucene-core-2.3.3.4.new/src/core/CLucene/document/DateTools.cpp
+--- clucene-core-2.3.3.4/src/core/CLucene/document/DateTools.cpp       2011-03-17 03:21:07.000000000 +0300
++++ clucene-core-2.3.3.4.new/src/core/CLucene/document/DateTools.cpp   2020-02-21 15:20:17.382575302 +0300
+@@ -9,6 +9,8 @@
+ #include "DateTools.h"
+ #include "CLucene/util/Misc.h"
++#include <ctime>
++
+ CL_NS_USE(util)
+ CL_NS_DEF(document)