dev-java/saxon: Updated dev-java/jdom slot from 1.0 -> 0 for v1
authorWilliam L. Thomson Jr <wlt@o-sinc.com>
Fri, 18 Sep 2015 00:05:26 +0000 (20:05 -0400)
committerJames Le Cuirot <chewi@gentoo.org>
Tue, 29 Sep 2015 21:19:41 +0000 (22:19 +0100)
dev-java/saxon/saxon-6.5.5-r1.ebuild [new file with mode: 0644]
dev-java/saxon/saxon-8.4b-r4.ebuild [new file with mode: 0644]
dev-java/saxon/saxon-9.2.0.6-r1.ebuild [new file with mode: 0644]

diff --git a/dev-java/saxon/saxon-6.5.5-r1.ebuild b/dev-java/saxon/saxon-6.5.5-r1.ebuild
new file mode 100644 (file)
index 0000000..7b2871e
--- /dev/null
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc examples source"
+inherit java-pkg-2 java-ant-2 eutils versionator
+
+MY_P="${PN}$(replace_all_version_separators -)"
+DESCRIPTION="A collection of tools for processing XML documents: XSLT processor, XSL library, parser"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
+HOMEPAGE="http://saxon.sourceforge.net/"
+
+LICENSE="MPL-1.1"
+SLOT="6.5"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+COMMON_DEP="dev-java/jdom:0"
+
+RDEPEND=">=virtual/jre-1.4
+       ${COMMON_DEP}"
+
+DEPEND=">=virtual/jdk-1.4
+       app-arch/unzip
+       ${COMMON_DEP}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+       unpack ${A}
+
+       unzip -qq source.zip -d src || die "failed to unpack"
+
+       cp "${FILESDIR}/build-${PV}.xml" build.xml || die
+
+       rm -v *.jar || die
+       rm -rf doc/api || die
+       rm samples/java/*.class || die
+       mkdir lib && cd lib
+       java-pkg_jar-from jdom
+}
+
+src_compile() {
+       java-pkg_filter-compiler jikes
+
+       eant -Dproject.name=${PN} jar $(use_doc)
+}
+
+src_install() {
+       java-pkg_dojar dist/${PN}.jar
+
+       if use doc; then
+               java-pkg_dojavadoc dist/doc/api
+               dohtml -r doc/*
+       fi
+       use examples && java-pkg_doexamples samples
+       use source && java-pkg_dosrc src/*
+}
diff --git a/dev-java/saxon/saxon-8.4b-r4.ebuild b/dev-java/saxon/saxon-8.4b-r4.ebuild
new file mode 100644 (file)
index 0000000..20bb1ba
--- /dev/null
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc examples source"
+
+inherit java-pkg-2 eutils java-ant-2
+
+DESCRIPTION="A collection of tools for processing XML documents: XSLT processor, XSL library, parser"
+MyPV=${PV%b}
+SRC_URI="mirror://sourceforge/saxon/saxonb${MyPV/./-}.zip"
+HOMEPAGE="http://saxon.sourceforge.net/"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+COMMON_DEP="
+       dev-java/xom
+       dev-java/jdom:0
+       =dev-java/xml-commons-external-1.3*"
+RDEPEND=">=virtual/jre-1.4
+       ${COMMON_DEP}"
+
+DEPEND=">=virtual/jdk-1.4
+       app-arch/unzip
+       ${COMMON_DEP}"
+
+S=${WORKDIR}
+
+src_unpack() {
+       unpack ${A}
+
+       unpack ./source.zip
+       mkdir src
+       mv net src
+
+       epatch "${FILESDIR}/${P}-jikes.patch"
+
+       cp -i "${FILESDIR}/build-${PV}.xml" build.xml || die
+
+       rm -v *.jar || die
+       rm samples/java/*.class || die
+
+       mkdir lib && cd lib
+       java-pkg_jar-from jdom
+       java-pkg_jar-from xom
+       # Is not needed with 1.5 but gets pulled in by deps any way
+       # without this emerging with sun-jdk-1.4 fails with
+       # JAVA_PKG_STRICT
+       java-pkg_jar-from xml-commons-external-1.3
+}
+
+src_install() {
+       java-pkg_dojar dist/*.jar
+
+       # the jar is named saxon8 and and helps if new slots come along
+       java-pkg_dolauncher ${PN}8 --main net.sf.saxon.Transform
+       if use doc; then
+               java-pkg_dojavadoc dist/doc/api doc/*
+               java-pkg_dohtml doc/*
+       fi
+       use examples && java-pkg_doexamples samples
+       use source && java-pkg_dosrc src/*
+}
diff --git a/dev-java/saxon/saxon-9.2.0.6-r1.ebuild b/dev-java/saxon/saxon-9.2.0.6-r1.ebuild
new file mode 100644 (file)
index 0000000..0694e74
--- /dev/null
@@ -0,0 +1,98 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit versionator java-pkg-2 java-ant-2
+
+MY_PV="$(replace_all_version_separators -)"
+
+DESCRIPTION="A XSLT and XQuery Processor"
+HOMEPAGE="http://saxon.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}he${MY_PV}source.zip"
+
+LICENSE="MPL-1.0"
+SLOT="9"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
+
+IUSE=""
+
+# virtual/jdk slot for external javadoc
+JDK_VER="6"
+# dev-java/jdom slot for external javadoc
+JDOM_VER="0"
+# dev-java/dom4j slot
+DOM4J_VER="1"
+
+CDEPEND="dev-java/ant-core
+       dev-java/dom4j:${DOM4J_VER}
+       dev-java/jdom:${JDOM_VER}
+       dev-java/xom"
+RDEPEND=">=virtual/jre-1.${JDK_VER}
+       ${CDEPEND}"
+DEPEND=">=virtual/jdk-1.${JDK_VER}
+       app-arch/unzip
+       ${CDEPEND}"
+
+S="${WORKDIR}"
+
+# prepare eclass variables
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+JAVA_ANT_CLASSPATH_TAGS="javac javadoc"
+
+src_unpack() {
+       unpack ${A}
+
+       ### fedora-inspired remove
+
+       # deadNET
+       rm -rv net/sf/saxon/dotnet
+
+       # Depends on XQJ (javax.xml.xquery)
+       rm -rv net/sf/saxon/xqj
+
+       # This requires a EE edition feature (com.saxonica.xsltextn)
+       rm -v net/sf/saxon/option/sql/SQLElementFactory.java
+}
+
+java_prepare() {
+       # <major>.<minor> version
+       local version="$(get_version_component_range 1-2)"
+
+       # generate build.xml with external javadoc links
+       sed -e "s:@JDK@:${JDK_VER}:" \
+               -e "s:@JDOM@:${JDOM_VER}:" \
+               < "${FILESDIR}/${version}-build.xml" \
+               > "${S}/build.xml" \
+               || die "build.xml generation failed!"
+
+       # prepare creates the dir for properties
+       eant prepare
+
+       # properties
+       cp -v \
+               "${FILESDIR}/${version}-edition.properties" \
+               "${S}/build/classes/edition.properties"
+}
+
+src_compile() {
+       local gcp="$(java-pkg_getjars dom4j-${DOM4J_VER},jdom,xom)"
+       gcp="${gcp}:$(java-pkg_getjars --build-only ant-core)"
+       eant -Dgentoo.classpath="${gcp}" jar $(use_doc)
+}
+
+src_install() {
+       java-pkg_dojar build/lib/${PN}.jar
+
+       java-pkg_dolauncher ${PN}${SLOT}-transform --main net.sf.saxon.Transform
+       java-pkg_dolauncher ${PN}${SLOT}-query --main net.sf.saxon.Query
+
+       java-pkg_register-ant-task
+
+       use doc && java-pkg_dojavadoc build/api
+
+       use source && java-pkg_dosrc src
+}