mail-client/balsa: Version bump
authorPacho Ramos <pacho@gentoo.org>
Sat, 21 Jan 2017 19:41:31 +0000 (20:41 +0100)
committerPacho Ramos <pacho@gentoo.org>
Sat, 21 Jan 2017 19:51:07 +0000 (20:51 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

mail-client/balsa/Manifest
mail-client/balsa/balsa-2.5.3.ebuild [new file with mode: 0644]

index 43748d1b3794f578c7a9d8e2a1e1b5912d47ff80..569536c5c6acd6234d7076bd337f2fb821ef8018 100644 (file)
@@ -1 +1,2 @@
 DIST balsa-2.5.2.tar.bz2 4049163 SHA256 01218dd8cb2c052c2d221d96e4ef5e277271befb2b50bbf4913223913214d21d SHA512 f7a9127d87869d57acebaf33f9e3e4b82c5a5ba90aa5304ce40ba48a1a7f01eaf602555f8e97bce70b0baeb2ac8b5ac12941eaa8b85be1886bf22f7767dd75ba WHIRLPOOL 7b7d96cda21b50a4acb068e5989696acd02ebb1fa70563f47230a8c0a04da51cf3af4422c23d13c5dbff27d89cce6e7516a6eeaa6464c9dedd6d2d326587fc65
+DIST balsa-2.5.3.tar.bz2 4333815 SHA256 b896ea6b16b31725e0d81ba4eac398b39ad5c33f2337a260448d2feac7e55396 SHA512 34e69be050f6c502fa6651029b7d93bf9b7842bbe8489669924563c086def4dbe72109ba5244e0cacf3ef69d3d9d8c5679f870acf564b5551920fa77012e1ff8 WHIRLPOOL 549b452f16de7f56f3026c992add38177e9cedf4baa8ec7d13d47449e50542045f1b77c84fc9e21796feb648730e65716e66628cb17a28e899669cf14e03613c
diff --git a/mail-client/balsa/balsa-2.5.3.ebuild b/mail-client/balsa/balsa-2.5.3.ebuild
new file mode 100644 (file)
index 0000000..73686ad
--- /dev/null
@@ -0,0 +1,97 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="Email client for GNOME"
+HOMEPAGE="http://pawsa.fedorapeople.org/balsa/"
+SRC_URI="http://pawsa.fedorapeople.org/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="crypt gnome gtkhtml gnome-keyring kerberos ldap libnotify libressl rubrica
+spell sqlite webkit xface"
+REQUIRED_USE="gtkhtml? ( !webkit )"
+
+# TODO: esmtp can be optional, do we want it?
+RDEPEND="
+       >=dev-libs/glib-2.40.0:2
+       >=x11-libs/gtk+-3.10.0:3
+       dev-libs/gmime:2.6
+       >=net-libs/libesmtp-1.0.3:=
+       net-mail/mailbase
+       media-libs/libcanberra:=[gtk3]
+       x11-themes/hicolor-icon-theme
+       x11-themes/adwaita-icon-theme
+       crypt? ( >=app-crypt/gpgme-1.2.0:= )
+       gnome? ( >=x11-libs/gtksourceview-3.2.0:3.0 )
+       gnome-keyring? ( app-crypt/libsecret )
+       gtkhtml? ( gnome-extra/gtkhtml:4.0 )
+       sqlite? ( >=dev-db/sqlite-2.8:= )
+       libnotify? ( >=x11-libs/libnotify-0.7:= )
+       !libressl? ( dev-libs/openssl:0= )
+       libressl? ( dev-libs/libressl:0= )
+       kerberos? ( app-crypt/mit-krb5 )
+       ldap? ( net-nds/openldap )
+       rubrica? ( dev-libs/libxml2:2 )
+       spell? ( app-text/gspell:0= )
+       webkit? ( net-libs/webkit-gtk:4 )
+       xface? ( >=media-libs/compface-1.5.1:= )
+"
+DEPEND="${RDEPEND}
+       app-text/yelp-tools
+       dev-python/html2text
+       dev-util/intltool
+       virtual/pkgconfig
+       sys-devel/gettext
+"
+
+src_prepare() {
+       DOCS="AUTHORS ChangeLog HACKING NEWS README TODO docs/*"
+
+       # https://bugzilla.gnome.org/show_bug.cgi?id=750516
+       sed -i -e 's/@TOOLKIT_CATEGORIES@//' balsa-mailto-handler.desktop.in.in || die
+
+       # https://bugzilla.gnome.org/show_bug.cgi?id=750515
+       echo "src/balsa-print-object.c" >> po/POTFILES.in || die
+
+       gnome2_src_prepare
+}
+
+src_configure() {
+       local myconf
+
+       if use crypt ; then
+               myconf+=" --with-gpgme=gpgme-config"
+       else
+               myconf+=" --without-gpgme"
+       fi
+
+       if use webkit || use gtkhtml; then
+               if use gtkhtml ; then
+                       myconf+=" --with-html-widget=gtkhtml4"
+               else
+                       myconf+=" --with-html-widget=webkit2"
+               fi
+       else
+               myconf+=" --with-html-widget=no"
+       fi
+
+       gnome2_src_configure \
+               --with-canberra \
+               $(use_with gnome) \
+               $(use_with gnome gtksourceview) \
+               $(use_with gnome-keyring libsecret) \
+               $(use_with kerberos gss) \
+               $(use_with ldap) \
+               $(use_with libnotify) \
+               $(use_with rubrica) \
+               $(usex spell --with-spell-checker=gspell --with-spell-checker=no) \
+               $(use_with sqlite) \
+               $(use_with xface compface) \
+               ${myconf}
+}