games-emulation/mupen64plus*: Version bump to 2.5
authorMichał Górny <mgorny@gentoo.org>
Sun, 4 Oct 2015 09:59:28 +0000 (11:59 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 4 Oct 2015 10:11:24 +0000 (12:11 +0200)
Bump mupen64plus to 2.5 which brings a number of bug fixes. Switch to
SDL2 as its support become stable and the default. Also switch m64py to
SDL2 to match.

Package-Manager: portage-2.2.22

20 files changed:
games-emulation/m64py/m64py-0.2.3-r1.ebuild [moved from games-emulation/m64py/m64py-0.2.3.ebuild with 82% similarity]
games-emulation/mupen64plus-audio-sdl/Manifest
games-emulation/mupen64plus-audio-sdl/mupen64plus-audio-sdl-2.5.ebuild [new file with mode: 0644]
games-emulation/mupen64plus-core/Manifest
games-emulation/mupen64plus-core/metadata.xml
games-emulation/mupen64plus-core/mupen64plus-core-2.5.ebuild [new file with mode: 0644]
games-emulation/mupen64plus-input-sdl/Manifest
games-emulation/mupen64plus-input-sdl/mupen64plus-input-sdl-2.5.ebuild [new file with mode: 0644]
games-emulation/mupen64plus-rsp-hle/Manifest
games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.5.ebuild [new file with mode: 0644]
games-emulation/mupen64plus-ui-console/Manifest
games-emulation/mupen64plus-ui-console/mupen64plus-ui-console-2.5.ebuild [new file with mode: 0644]
games-emulation/mupen64plus-video-glide64mk2/Manifest
games-emulation/mupen64plus-video-glide64mk2/metadata.xml
games-emulation/mupen64plus-video-glide64mk2/mupen64plus-video-glide64mk2-2.5.ebuild [new file with mode: 0644]
games-emulation/mupen64plus-video-rice/Manifest
games-emulation/mupen64plus-video-rice/metadata.xml
games-emulation/mupen64plus-video-rice/mupen64plus-video-rice-2.5.ebuild [new file with mode: 0644]
games-emulation/mupen64plus/mupen64plus-2.5.ebuild [new file with mode: 0644]
profiles/package.mask

similarity index 82%
rename from games-emulation/m64py/m64py-0.2.3.ebuild
rename to games-emulation/m64py/m64py-0.2.3-r1.ebuild
index 18371403589fc608b453a2385dd145ee1ade3eb9..6ba5a09fe0c465bbcf9f4adbfba9ce3a498087d5 100644 (file)
@@ -6,7 +6,7 @@ EAPI=5
 
 PYTHON_COMPAT=( python3_4 )
 
-inherit distutils-r1
+inherit distutils-r1 versionator
 
 DESCRIPTION="A frontend for Mupen64Plus"
 HOMEPAGE="http://m64py.sourceforge.net/"
@@ -18,9 +18,9 @@ KEYWORDS="~amd64 ~x86"
 IUSE=""
 
 # SDL & libmupen64plus are through ctypes, so they rely on specific ABI
-RDEPEND="media-libs/libsdl:0/0[joystick]
+RDEPEND="media-libs/libsdl2:0/0[joystick]
        dev-python/PyQt5[opengl,${PYTHON_USEDEP}]
-       >=games-emulation/mupen64plus-core-2.0-r1:0/2"
+       >=games-emulation/mupen64plus-core-2.5:0/2-sdl2"
 
 python_prepare_all() {
        # set the correct search path
@@ -28,14 +28,9 @@ python_prepare_all() {
                SEARCH_DIRS = ["/usr/$(get_libdir)/mupen64plus"]
 _EOF_
 
-       # comment out SDL2 support since our mupen64plus uses SDL1
-       sed -e '/from m64py\.SDL2/s:^:#:' \
-               -e '/QT2SDL2\[/s:^:#:' \
-               -e '/KEYCODE2SCANCODE\[/s:^:#:' \
-               -e '/SCANCODE2KEYCODE\[/s:^:#:' \
-               -i src/m64py/frontend/keymap.py || die
+       # force SDL2 support to match >=mupen64plus-2.5
        sed -e '/--sdl2/d' \
-               -e '/SDL2/s:=.*$:= False:' \
+               -e '/SDL2/s:=.*$:= True:' \
                -i src/m64py/opts.py || die
 
        distutils-r1_python_prepare_all
index 1def790ff8df602f5cedc0ab239efc94f267c447..85aaa085b07ef2d12b0e497512d1396b20a86221 100644 (file)
@@ -1 +1,2 @@
 DIST mupen64plus-audio-sdl-src-2.0.tar.gz 26084 SHA256 943ffa6b6cdaf0cda2a24469dfa1d8e951c88c41472ded9e5c9ecbc111363286 SHA512 92ee4755c22da5a753374c7c6f5e074bf6c1ab06a0ab27d475566d50f8ed75b636b59ffe1a8c9d3d63558bf5783b999a600703951679f7bab346643c0c86871d WHIRLPOOL 82a56a49f0ffe620917dba92bf135593c7e66e2944ec0688b29cc2d5362221b81f76e162840e315476d959b445d38f3bc1bf05538fbf1fa9de96b616835b2198
+DIST mupen64plus-audio-sdl-src-2.5.tar.gz 26147 SHA256 1c59f8c2d70206350c0b9067a9722cf2dd67e5686994d5a55adbf51ee8812f59 SHA512 0c63e16449c40f15abdeed968383a218ed9876a92b2c15cbeb6554b20008d6d12996c0fd3bc1c502084791596b8535340596e95a11fe5d27576342740e76db6a WHIRLPOOL ad141c8dbe996590eecada88e943a7d8b0e2d9f4db3d02a17c8b4b1e198580b02ef28ef2b19f2267c77f3060396d068ab2fcbcd2da11ff2e6ecfa61af10bb30f
diff --git a/games-emulation/mupen64plus-audio-sdl/mupen64plus-audio-sdl-2.5.ebuild b/games-emulation/mupen64plus-audio-sdl/mupen64plus-audio-sdl-2.5.ebuild
new file mode 100644 (file)
index 0000000..4c5fd3c
--- /dev/null
@@ -0,0 +1,85 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P=${PN}-src-${PV}
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, SDL audio plugin"
+HOMEPAGE="http://www.mupen64plus.org/"
+SRC_URI="https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libsamplerate oss speex"
+
+RDEPEND=">=games-emulation/mupen64plus-core-2.5:0=
+       media-libs/libsdl2:0=[sound]
+       libsamplerate? ( media-libs/libsamplerate:0= )
+       speex? ( media-libs/speex:0= )"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+       epatch_user
+
+       # avoid implicitly appending CPU flags
+       sed -i -e 's:-mmmx::g' -e 's:-msse::g' projects/unix/Makefile || die
+}
+
+src_compile() {
+       MAKEARGS=(
+               # Note: please keep this in sync in all of mupen64plus-* packages
+
+               -C projects/unix
+
+               # this basically means: GNU userspace
+               UNAME=Linux
+
+               # verbose output
+               V=1
+
+               CROSS_COMPILE="${CHOST}-"
+               CC="$(tc-getCC)"
+               CXX="$(tc-getCXX)"
+               PKG_CONFIG="$(tc-getPKG_CONFIG)"
+               # usual CFLAGS, CXXFLAGS and LDFLAGS are respected
+               # so we can leave OPTFLAGS empty
+               OPTFLAGS=
+
+               # paths, some of them are used at compile time
+               PREFIX=/usr
+               LIBDIR=/usr/$(get_libdir)
+
+               # disable unwanted magic
+               LDCONFIG=:
+               INSTALL_STRIP_FLAG=
+
+               # Package-specific stuff
+
+               # CROSS_COMPILE causes it to look for ${CHOST}-sdl2-config...
+               SDL_CFLAGS="$($(tc-getPKG_CONFIG) --cflags sdl2)"
+               SDL_LDLIBS="$($(tc-getPKG_CONFIG) --libs sdl2)"
+
+               NO_SPEEX=$(usex speex 0 1)
+               NO_SRC=$(usex libsamplerate 0 1)
+               NO_OSS=$(usex oss 0 1)
+               # not packaged (https://github.com/nemomobile/libaudioresource)
+               USE_AUDIORESOURCE=0
+       )
+
+       use amd64 && MAKEARGS+=( HOST_CPU=x86_64 )
+       use x86 && MAKEARGS+=( HOST_CPU=i386 )
+
+       emake "${MAKEARGS[@]}" all
+}
+
+src_install() {
+       emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+       einstalldocs
+}
index 19006ccfa9e7a99a04ad1db02a7de0a7ddc91fda..4a2a712aa457f54a6a2af923afd8aaa5e328fcca 100644 (file)
@@ -1 +1,2 @@
 DIST mupen64plus-core-src-2.0.tar.gz 1127862 SHA256 7e98795dbe4646b858919078f58a6ed94f7cfa30867df6cf44ef33da6aaa7a28 SHA512 6f7391536c23b465af737b3b64f3488bc0275c472e27f97f1d8be61e917c6772cad2c747db8ffa251ba88ba4f4c0d29de2451325f3ea4bcc6049534ef1dac41e WHIRLPOOL c32c97071d911696c9b24a931287ba7da1bdb29434300d984926a2a1b0541660022b6a811f616e8ed18de8d59fdafd168a571b248165c950d80f4e045e25aa53
+DIST mupen64plus-core-src-2.5.tar.gz 895890 SHA256 59e99a79e7f862517232e3115bd1f72377e3e34da795c118ba617c478c839578 SHA512 1bf643798de4f17e2ce4f2a67dfd242a8b24d873c413b49cbcb280e4264131222e3f3bc02c46111868102b0b5174d117ababceab66551cb38b76b22b3a94f697 WHIRLPOOL 3ea76e1bd914c9f8f2857976df7ab1ee6cc8d41e7b34f2fc832e0f4030b139b702b0295fca157f475b90245dbfe93aaab05ec5677cd676010b69af873b5f8840
index c2134731fe1b248140698ca49101afd0f710532d..8345dfe1e7d3e96f85a533a0e07b1e8fabeb93e4 100644 (file)
@@ -10,6 +10,8 @@
                <name>Christian Birchinger</name>
        </maintainer>
        <use>
+               <flag name="debugger">Build the debugger</flag>
+               <flag name="gles2">Use GLES2 instead of OpenGL</flag>
                <flag name="new-dynarec">Enable new experimental dynamic recompiler implementation (only for x86 and arm)</flag>
                <flag name="osd">Overlay emulator messages using on-screen-display</flag>
        </use>
diff --git a/games-emulation/mupen64plus-core/mupen64plus-core-2.5.ebuild b/games-emulation/mupen64plus-core/mupen64plus-core-2.5.ebuild
new file mode 100644 (file)
index 0000000..a279007
--- /dev/null
@@ -0,0 +1,112 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P=${PN}-src-${PV}
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, core library"
+HOMEPAGE="http://www.mupen64plus.org/"
+SRC_URI="https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0/2-sdl2"
+KEYWORDS="~amd64 ~x86"
+IUSE="debugger gles2 lirc new-dynarec +osd cpu_flags_x86_sse"
+
+RDEPEND="media-libs/libpng:0=
+       media-libs/libsdl2:0=[joystick,opengl,video]
+       sys-libs/zlib:0=[minizip]
+       lirc? ( app-misc/lirc:0 )
+       osd? (
+               media-fonts/ttf-bitstream-vera
+               media-libs/freetype:2=
+               virtual/opengl:0=
+               virtual/glu:0=
+       )
+       !<games-emulation/mupen64plus-2.0"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+
+# block versions using SDL1
+RDEPEND="${RDEPEND}
+       !<games-emulation/m64py-0.2.3-r1
+       !<games-emulation/mupen64plus-audio-sdl-2.5
+       !<games-emulation/mupen64plus-input-sdl-2.5
+       !<games-emulation/mupen64plus-ui-console-2.5
+       !<games-emulation/mupen64plus-video-glide64mk2-2.5
+       !<games-emulation/mupen64plus-video-rice-2.5"
+
+REQUIRED_USE="gles2? ( !osd )"
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+       epatch_user
+
+       # avoid implicitly appending CPU flags
+       sed -i -e 's:-mmmx::g' -e 's:-msse::g' projects/unix/Makefile || die
+}
+
+src_compile() {
+       MAKEARGS=(
+               # Note: please keep this in sync in all of mupen64plus-* packages
+
+               -C projects/unix
+
+               # this basically means: GNU userspace
+               UNAME=Linux
+
+               # verbose output
+               V=1
+
+               CROSS_COMPILE="${CHOST}-"
+               CC="$(tc-getCC)"
+               CXX="$(tc-getCXX)"
+               PKG_CONFIG="$(tc-getPKG_CONFIG)"
+               # usual CFLAGS, CXXFLAGS and LDFLAGS are respected
+               # so we can leave OPTFLAGS empty
+               OPTFLAGS=
+
+               # paths, some of them are used at compile time
+               PREFIX=/usr
+               LIBDIR=/usr/$(get_libdir)
+
+               # disable unwanted magic
+               LDCONFIG=:
+               INSTALL_STRIP_FLAG=
+
+               # Package-specific stuff
+
+               # CROSS_COMPILE causes it to look for ${CHOST}-sdl2-config...
+               SDL_CFLAGS="$($(tc-getPKG_CONFIG) --cflags sdl2)"
+               SDL_LDLIBS="$($(tc-getPKG_CONFIG) --libs sdl2)"
+
+               OSD=$(usex osd 1 0)
+               NO_ASM=$(usex cpu_flags_x86_sse 0 1)
+               LIRC=$(usex lirc 1 0)
+               DEBUGGER=$(usex debugger 1 0)
+               NEW_DYNAREC=$(usex new-dynarec 1 0)
+               USE_GLES=$(usex gles2 1 0)
+       )
+
+       use amd64 && MAKEARGS+=( HOST_CPU=x86_64 )
+       use x86 && MAKEARGS+=( HOST_CPU=i386 )
+
+       emake "${MAKEARGS[@]}" all
+}
+
+src_install() {
+       emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+       einstalldocs
+       dodoc -r doc/{emuwiki-api-doc,new_dynarec.txt}
+
+       # replace bundled font with a symlink
+       # TODO: fix the code to not rely on it
+       local font_path=/usr/share/mupen64plus/font.ttf
+       rm "${D%/}/${font_path}" || die
+       if use osd; then
+               dosym /usr/share/fonts/ttf-bitstream-vera/Vera.ttf "${font_path}"
+       fi
+}
index f0bddf13ebcf3465d262cbbf26daacb30dda511a..0b1fc1d15cd193d1abaa233e3922ea967b80f850 100644 (file)
@@ -1 +1,2 @@
 DIST mupen64plus-input-sdl-src-2.0.tar.gz 43553 SHA256 b6be48e978683cced8c208ad03e27828c17ac7b2da5e699d6c34945db63d95b6 SHA512 adbeb83e01721aa74e5e65c05e4bff2a250c7bf51835a8b2c020752e9bf0bdb0f0672914fc5285ad9da2e6fa44259780aea6415d77914bb34e521f30eecf6747 WHIRLPOOL 647ccef13620c863077ae2eefb6934d966eaa413fe70437a38560e5fa03f479428e4848f2c2f3f38163a122a29f8b118fb50f9f772bfd1df96ab2860044352d7
+DIST mupen64plus-input-sdl-src-2.5.tar.gz 50580 SHA256 65e528667b7f57a307b92abba37a3601ee17e9dd9d303ba7e4163b27f3ef771b SHA512 014a5e21feb88b14bcee44a74556a257393b799745308421a611eb3b6c11a390a589fdd393f07e69a128ca60426d4dcf8847bcbabed77b0d570be282550148d6 WHIRLPOOL a3d60880c17939785af93f9a2a9de6d9180ae754580d9a21efd5cfc7b0774b7883115f71dde35b1c448c8fc259e4229866e92c7ac51053055e9878fc90ae48b1
diff --git a/games-emulation/mupen64plus-input-sdl/mupen64plus-input-sdl-2.5.ebuild b/games-emulation/mupen64plus-input-sdl/mupen64plus-input-sdl-2.5.ebuild
new file mode 100644 (file)
index 0000000..6c4856a
--- /dev/null
@@ -0,0 +1,77 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P=${PN}-src-${PV}
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, SDL input plugin"
+HOMEPAGE="http://www.mupen64plus.org/"
+SRC_URI="https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=games-emulation/mupen64plus-core-2.5:0=
+       media-libs/libsdl2:0=[joystick]"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+       epatch_user
+
+       # avoid implicitly appending CPU flags
+       sed -i -e 's:-mmmx::g' -e 's:-msse::g' projects/unix/Makefile || die
+}
+
+src_compile() {
+       MAKEARGS=(
+               # Note: please keep this in sync in all of mupen64plus-* packages
+
+               -C projects/unix
+
+               # this basically means: GNU userspace
+               UNAME=Linux
+
+               # verbose output
+               V=1
+
+               CROSS_COMPILE="${CHOST}-"
+               CC="$(tc-getCC)"
+               CXX="$(tc-getCXX)"
+               PKG_CONFIG="$(tc-getPKG_CONFIG)"
+               # usual CFLAGS, CXXFLAGS and LDFLAGS are respected
+               # so we can leave OPTFLAGS empty
+               OPTFLAGS=
+
+               # paths, some of them are used at compile time
+               PREFIX=/usr
+               LIBDIR=/usr/$(get_libdir)
+
+               # disable unwanted magic
+               LDCONFIG=:
+               INSTALL_STRIP_FLAG=
+
+               # Package-specific stuff
+
+               # CROSS_COMPILE causes it to look for ${CHOST}-sdl2-config...
+               SDL_CFLAGS="$($(tc-getPKG_CONFIG) --cflags sdl2)"
+               SDL_LDLIBS="$($(tc-getPKG_CONFIG) --libs sdl2)"
+       )
+
+       use amd64 && MAKEARGS+=( HOST_CPU=x86_64 )
+       use x86 && MAKEARGS+=( HOST_CPU=i386 )
+
+       emake "${MAKEARGS[@]}" all
+}
+
+src_install() {
+       emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+       einstalldocs
+}
index 0b5b6fd8fbba917e4fde22756c5917095c92e4f3..2264dc3e3390bf0daf3055e9237ed384713b21a3 100644 (file)
@@ -1 +1,2 @@
 DIST mupen64plus-rsp-hle-src-2.0.tar.gz 46291 SHA256 61c2bd163b3506d206957ba690dfd1b4d2921a6c8a3883ab6a8ef1204de7b736 SHA512 e1caa121d377be0856708fa5c13c234abc0bbb2cab90f40963983baf6230a1d4a4b7da9af0fa2ed6737538265b6392d8a43e9e537ccbd63bbb6ee44da8b29fdf WHIRLPOOL 9b3b1557bfc301390b5069892c4fabead82d7a6f1bf28da7a51ce8345fbbb12e611756d4818f423936517fbc51b0839eb25b3e9acf88160a9857ac7c7eb9ab35
+DIST mupen64plus-rsp-hle-src-2.5.tar.gz 46998 SHA256 4b2e11193746e0fbe4dfa78426c1214cf2e42779132eb2f668bf88f498517703 SHA512 564d96050890cc61df05163f99a0be8198e870f0d4071e87828bf58b283b2be8ca7de20ed03482ea8c45725bdd6f6baea618c068cced407892cf2add6ef373c6 WHIRLPOOL ea44abf46720879a0b781284c21dadbb776c12192f87ee362d8732d113cb8763e6a273a7aa7091866e58a01ace01581670440dcf81802346e1c61cdbc92a9670
diff --git a/games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.5.ebuild b/games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.5.ebuild
new file mode 100644 (file)
index 0000000..dac1892
--- /dev/null
@@ -0,0 +1,69 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P=${PN}-src-${PV}
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, HLE RSP plugin"
+HOMEPAGE="http://www.mupen64plus.org/"
+SRC_URI="https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=games-emulation/mupen64plus-core-2.0-r1:0="
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+       epatch_user
+
+       # avoid implicitly appending CPU flags
+       sed -i -e 's:-mmmx::g' -e 's:-msse::g' projects/unix/Makefile || die
+}
+
+src_compile() {
+       MAKEARGS=(
+               # Note: please keep this in sync in all of mupen64plus-* packages
+
+               -C projects/unix
+
+               # this basically means: GNU userspace
+               UNAME=Linux
+
+               # verbose output
+               V=1
+
+               CROSS_COMPILE="${CHOST}-"
+               CC="$(tc-getCC)"
+               CXX="$(tc-getCXX)"
+               PKG_CONFIG="$(tc-getPKG_CONFIG)"
+               # usual CFLAGS, CXXFLAGS and LDFLAGS are respected
+               # so we can leave OPTFLAGS empty
+               OPTFLAGS=
+
+               # paths, some of them are used at compile time
+               PREFIX=/usr
+               LIBDIR=/usr/$(get_libdir)
+
+               # disable unwanted magic
+               LDCONFIG=:
+               INSTALL_STRIP_FLAG=
+       )
+
+       use amd64 && MAKEARGS+=( HOST_CPU=x86_64 )
+       use x86 && MAKEARGS+=( HOST_CPU=i386 )
+
+       emake "${MAKEARGS[@]}" all
+}
+
+src_install() {
+       emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+       einstalldocs
+}
index 9af1c63c9bb5ecaab09a0247f37a968dcb01f9ff..886522e367fe16cf3624a1e22990d353a791e3c6 100644 (file)
@@ -1 +1,2 @@
 DIST mupen64plus-ui-console-src-2.0.tar.gz 37954 SHA256 87b9ac0a5ebbc835baa4e1fba0f50e7467e87da6469aa28fdb196e2040e54877 SHA512 7276e19772cfa047ea75c0c87930d7042a41d7d30912cae7f2c44e37ce6d446e8f5bf4e8ce89e69cabcb05185fe7b59a0ff5d12a7f7bbfa010404c2bedd94ea0 WHIRLPOOL 455a3fbb5eb0027ffbf52693e41f2fe8b5a098e32daa0d532b05f0841a35905beb0ffac9b942165d0b03f975468fff75f953cb9b9de02f8a5e49944e28dfccf8
+DIST mupen64plus-ui-console-src-2.5.tar.gz 47852 SHA256 71fee012678ff88f18130e339afd8c5467a2646b7e50da75ba2d5fa342b74a67 SHA512 70293a768c2bc5f80a2f71db229021d497d675536f5dc5eb098f91b62081f993f308d410adebce208a89880f57b037d5b42fa2f95c42ce94ffe2fca326a53046 WHIRLPOOL 4016d6b456d088b19dca2e44e615593bde6e611b36ff0837f9a8d821be87db028027b82daacfccc55488f61ea0110743efb5bed9703336187f88dd8668150e19
diff --git a/games-emulation/mupen64plus-ui-console/mupen64plus-ui-console-2.5.ebuild b/games-emulation/mupen64plus-ui-console/mupen64plus-ui-console-2.5.ebuild
new file mode 100644 (file)
index 0000000..e0a5e43
--- /dev/null
@@ -0,0 +1,78 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P=${PN}-src-${PV}
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, console UI"
+HOMEPAGE="http://www.mupen64plus.org/"
+SRC_URI="https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=games-emulation/mupen64plus-core-2.0-r1:0=
+       media-libs/libsdl2:0=
+       !<games-emulation/mupen64plus-2.0"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+       epatch_user
+
+       # avoid implicitly appending CPU flags
+       sed -i -e 's:-mmmx::g' -e 's:-msse::g' projects/unix/Makefile || die
+}
+
+src_compile() {
+       MAKEARGS=(
+               # Note: please keep this in sync in all of mupen64plus-* packages
+
+               -C projects/unix
+
+               # this basically means: GNU userspace
+               UNAME=Linux
+
+               # verbose output
+               V=1
+
+               CROSS_COMPILE="${CHOST}-"
+               CC="$(tc-getCC)"
+               CXX="$(tc-getCXX)"
+               PKG_CONFIG="$(tc-getPKG_CONFIG)"
+               # usual CFLAGS, CXXFLAGS and LDFLAGS are respected
+               # so we can leave OPTFLAGS empty
+               OPTFLAGS=
+
+               # paths, some of them are used at compile time
+               PREFIX=/usr
+               LIBDIR=/usr/$(get_libdir)
+
+               # disable unwanted magic
+               LDCONFIG=:
+               INSTALL_STRIP_FLAG=
+
+               # Package-specific stuff
+
+               # CROSS_COMPILE causes it to look for ${CHOST}-sdl2-config...
+               SDL_CFLAGS="$($(tc-getPKG_CONFIG) --cflags sdl2)"
+               SDL_LDLIBS="$($(tc-getPKG_CONFIG) --libs sdl2)"
+       )
+
+       use amd64 && MAKEARGS+=( HOST_CPU=x86_64 )
+       use x86 && MAKEARGS+=( HOST_CPU=i386 )
+
+       emake "${MAKEARGS[@]}" all
+}
+
+src_install() {
+       emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+       einstalldocs
+}
index 891c395ef0368b25fb1daa288859e435dd1a0f7b..36dbc5e4c8d23c44544bf4881c5048abc0a203d6 100644 (file)
@@ -1 +1,2 @@
 DIST mupen64plus-video-glide64mk2-src-2.0.tar.gz 445166 SHA256 7761594432e90aed2dd12a5f16b30674c65b1f1abad0d98ac6239c3b2c44a4d5 SHA512 043b84927219b574da3c489119007bd115c9fa0f3f476ea9e812c8321a7f1e9309af06bed0b975c00201bc35f925d3b85c3411aa02310fd1ea508191184afa9a WHIRLPOOL b55c7412139b5b31fc919947068a7ad06958b20e54b9ac350cac88af3fec0d03d4f36675c1b60ba330061e652d489113bd7b84f53e7677c3cc1f0039c2a135af
+DIST mupen64plus-video-glide64mk2-src-2.5.tar.gz 488988 SHA256 ef3dae0084e078d843605abdf5039eb8b5dd68ff1410b4fc12bdf19592a9fcb6 SHA512 b62620a364ca9e6bf729e5dd07fb84a73745c6533b95468d3f5411c0556824282f760efefea0968b0a9282f77c315bbed8b0b8a59d771893b7fd0f5f24ad725d WHIRLPOOL 63068d428d5a00a52911155e39cdd09ee79d1ca2d47b005799bf25e4438a476271aa786a3227d9f77e7cb80fe20b18906a70f7829947dbfb2f8d04ffd3da4e18
index 7eb8e678ad77f914d2f3804275fa4ea16101e323..31c47127496e6ea03890f066b99a6590667d40e1 100644 (file)
@@ -10,6 +10,7 @@
                <name>Christian Birchinger</name>
        </maintainer>
        <use>
+               <flag name="gles2">Use GLES2 instead of OpenGL</flag>
                <flag name="hires">Support hi-resolution textures (requires <pkg>dev-libs/boost</pkg>)</flag>
        </use>
        <upstream>
diff --git a/games-emulation/mupen64plus-video-glide64mk2/mupen64plus-video-glide64mk2-2.5.ebuild b/games-emulation/mupen64plus-video-glide64mk2/mupen64plus-video-glide64mk2-2.5.ebuild
new file mode 100644 (file)
index 0000000..eb83f47
--- /dev/null
@@ -0,0 +1,89 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P=${PN}-src-${PV}
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, glide64mk2 video plugin"
+HOMEPAGE="http://www.mupen64plus.org/"
+SRC_URI="https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gles2 hires cpu_flags_x86_sse"
+
+RDEPEND=">=games-emulation/mupen64plus-core-2.5:0=[gles2=]
+       media-libs/libpng:0=
+       media-libs/libsdl2:0=
+       media-libs/libtxc_dxtn
+       sys-libs/zlib:0=
+       virtual/opengl:0=
+       hires? ( dev-libs/boost:0= )"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+       epatch_user
+
+       # avoid implicitly appending CPU flags
+       sed -i -e 's:-mmmx::g' -e 's:-msse::g' projects/unix/Makefile || die
+}
+
+src_compile() {
+       MAKEARGS=(
+               # Note: please keep this in sync in all of mupen64plus-* packages
+
+               -C projects/unix
+
+               # this basically means: GNU userspace
+               UNAME=Linux
+
+               # verbose output
+               V=1
+
+               CROSS_COMPILE="${CHOST}-"
+               CC="$(tc-getCC)"
+               CXX="$(tc-getCXX)"
+               PKG_CONFIG="$(tc-getPKG_CONFIG)"
+               # usual CFLAGS, CXXFLAGS and LDFLAGS are respected
+               # so we can leave OPTFLAGS empty
+               OPTFLAGS=
+
+               # paths, some of them are used at compile time
+               PREFIX=/usr
+               LIBDIR=/usr/$(get_libdir)
+
+               # disable unwanted magic
+               LDCONFIG=:
+               INSTALL_STRIP_FLAG=
+
+               # Package-specific stuff
+
+               # CROSS_COMPILE causes it to look for ${CHOST}-sdl2-config...
+               SDL_CFLAGS="$($(tc-getPKG_CONFIG) --cflags sdl2)"
+               SDL_LDLIBS="$($(tc-getPKG_CONFIG) --libs sdl2)"
+
+               NOSSE=$(usex cpu_flags_x86_sse 0 1)
+               HIRES=$(usex hires 1 0)
+               USE_FRAMESKIPPER=1
+               USE_GLES=$(usex gles2 1 0)
+               # use external lib
+               TXCDXTN=1
+       )
+
+       use amd64 && MAKEARGS+=( HOST_CPU=x86_64 )
+       use x86 && MAKEARGS+=( HOST_CPU=i386 )
+
+       emake "${MAKEARGS[@]}" all
+}
+
+src_install() {
+       emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+       einstalldocs
+}
index 0ae3e56f2894c63effe52e16806a145d6ef47df3..26e5de834a0fb3ec070d792319bdd768b606d48f 100644 (file)
@@ -1 +1,2 @@
 DIST mupen64plus-video-rice-src-2.0.tar.gz 362013 SHA256 3eb076e7c38ab45c9ec752d30e00eca022a9e0c6ead1a22df13ad94902e08238 SHA512 bbab67be20b6d2ed6a246de8a2b955051489ac128ddecff0e3fc54782fc1d17ed8f9e1cded22d215b2c5c865b4b5fe831fffb28803247a2e494746565d23d764 WHIRLPOOL ab4399e0c70351e69995a5f40aa308b4d37489b7997d8a0eae97a183c62eea6976469c1e420c04cd24f9c32e9828d677264ce684e57af2500e7e57047bf98011
+DIST mupen64plus-video-rice-src-2.5.tar.gz 339012 SHA256 969f65b9f42f48bc7e840e4ed1342233e4371c2edca5aa8f36f69c4b20955828 SHA512 d3e9c3b3097ca9b9d896498bb34374a14ec1948fce8b795e755bb13a88f3066289fe2500666b4057e719bf3f1b38b840f8a60eaeccdcdddfab69b1986c953d61 WHIRLPOOL ff5f5fa9f74dc6110239998a2a0025b2fbf796dfd98a65f80d57ccb1197c4df7904890734445e073a2b89f90793da565527b6d7ab32a62e504d10fe6aaf9d6f5
index 9af84f31de7421afb92783fb0b7fc02b841f6388..31d3b719824bd74aca77fd50259913975c3e2fcc 100644 (file)
@@ -9,6 +9,9 @@
                <email>joker@gentoo.org</email>
                <name>Christian Birchinger</name>
        </maintainer>
+       <use>
+               <flag name="gles2">Use GLES2 instead of OpenGL</flag>
+       </use>
        <upstream>
                <remote-id type="github">mupen64plus/mupen64plus-video-rice</remote-id>
        </upstream>
diff --git a/games-emulation/mupen64plus-video-rice/mupen64plus-video-rice-2.5.ebuild b/games-emulation/mupen64plus-video-rice/mupen64plus-video-rice-2.5.ebuild
new file mode 100644 (file)
index 0000000..73fa381
--- /dev/null
@@ -0,0 +1,82 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P=${PN}-src-${PV}
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, rice video plugin"
+HOMEPAGE="http://www.mupen64plus.org/"
+SRC_URI="https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gles2 cpu_flags_x86_sse"
+
+RDEPEND=">=games-emulation/mupen64plus-core-2.5:0=[gles2=]
+       media-libs/libpng:0=
+       media-libs/libsdl2:0=[video]
+       virtual/opengl:0="
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+       epatch_user
+
+       # avoid implicitly appending CPU flags
+       sed -i -e 's:-mmmx::g' -e 's:-msse::g' projects/unix/Makefile || die
+}
+
+src_compile() {
+       MAKEARGS=(
+               # Note: please keep this in sync in all of mupen64plus-* packages
+
+               -C projects/unix
+
+               # this basically means: GNU userspace
+               UNAME=Linux
+
+               # verbose output
+               V=1
+
+               CROSS_COMPILE="${CHOST}-"
+               CC="$(tc-getCC)"
+               CXX="$(tc-getCXX)"
+               PKG_CONFIG="$(tc-getPKG_CONFIG)"
+               # usual CFLAGS, CXXFLAGS and LDFLAGS are respected
+               # so we can leave OPTFLAGS empty
+               OPTFLAGS=
+
+               # paths, some of them are used at compile time
+               PREFIX=/usr
+               LIBDIR=/usr/$(get_libdir)
+
+               # disable unwanted magic
+               LDCONFIG=:
+               INSTALL_STRIP_FLAG=
+
+               # Package-specific stuff
+
+               # CROSS_COMPILE causes it to look for ${CHOST}-sdl2-config...
+               SDL_CFLAGS="$($(tc-getPKG_CONFIG) --cflags sdl2)"
+               SDL_LDLIBS="$($(tc-getPKG_CONFIG) --libs sdl2)"
+
+               NO_ASM=$(usex cpu_flags_x86_sse 0 1)
+               USE_GLES=$(usex gles2 1 0)
+       )
+
+       use amd64 && MAKEARGS+=( HOST_CPU=x86_64 )
+       use x86 && MAKEARGS+=( HOST_CPU=i386 )
+
+       emake "${MAKEARGS[@]}" all
+}
+
+src_install() {
+       emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+       einstalldocs
+}
diff --git a/games-emulation/mupen64plus/mupen64plus-2.5.ebuild b/games-emulation/mupen64plus/mupen64plus-2.5.ebuild
new file mode 100644 (file)
index 0000000..746a4d0
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, meta-package"
+HOMEPAGE="http://www.mupen64plus.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+audio-sdl +input-sdl +rsp-hle +ui-console +ui-m64py +video-glide64mk2 +video-rice"
+
+RDEPEND=">=games-emulation/mupen64plus-core-2.5
+       audio-sdl? ( >=games-emulation/mupen64plus-audio-sdl-2.5 )
+       input-sdl? ( >=games-emulation/mupen64plus-input-sdl-2.5 )
+       rsp-hle? ( >=games-emulation/mupen64plus-rsp-hle-2.5 )
+       ui-console? ( >=games-emulation/mupen64plus-ui-console-2.5 )
+       ui-m64py? ( >=games-emulation/m64py-0.2.3-r1 )
+       video-glide64mk2? ( >=games-emulation/mupen64plus-video-glide64mk2-2.5 )
+       video-rice? ( >=games-emulation/mupen64plus-video-rice-2.5 )"
index bedc6b0b52d5b6f7056c972fdd80f05845a14f84..0a23a7c066d63660739c2996f00d50ded751c6f5 100644 (file)
 =sys-kernel/vanilla-sources-4.1.9
 =sys-kernel/gentoo-sources-4.1.9
 
-# Michał Górny <mgorny@gentoo.org> (1 Oct 2015)
-# Thoroughly broken for me since the switch to Python 3 / PyQt5. Masking
-# to account for opt-in testing.
-=games-emulation/m64py-0.2.3
-
 # Patrice Clement <monsieurp@gentoo.org> (1 Oct 2015)
 # Project is over 10 years old and seems to have stalled.
 # Masked for removal in 30 days. See bug 561954.