games-arcade/pengupop: Stop using games.eclass
authorPacho Ramos <pacho@gentoo.org>
Mon, 23 Apr 2018 18:11:23 +0000 (20:11 +0200)
committerPacho Ramos <pacho@gentoo.org>
Mon, 23 Apr 2018 19:17:00 +0000 (21:17 +0200)
Package-Manager: Portage-2.3.31, Repoman-2.3.9

games-arcade/pengupop/files/pengupop-2.2.5-underlink.patch
games-arcade/pengupop/pengupop-2.2.5-r1.ebuild [new file with mode: 0644]

index 5b6453accce7addb73db8b6eed21adda7a88c6f4..fbbb704a6a30f683e7c0e571b6a15a4c31d9e17e 100644 (file)
@@ -1,5 +1,5 @@
---- Makefile.am.old    2011-06-14 21:44:40.242317771 +0200
-+++ Makefile.am        2011-06-14 21:44:49.216882568 +0200
+--- a/Makefile.am.old  2011-06-14 21:44:40.242317771 +0200
++++ b/Makefile.am      2011-06-14 21:44:49.216882568 +0200
 @@ -17,7 +17,7 @@
  nodist_pengupop_SOURCES = images.h
  
diff --git a/games-arcade/pengupop/pengupop-2.2.5-r1.ebuild b/games-arcade/pengupop/pengupop-2.2.5-r1.ebuild
new file mode 100644 (file)
index 0000000..6938c53
--- /dev/null
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools desktop gnome2-utils
+
+DESCRIPTION="Networked multiplayer-only Puzzle Bubble clone"
+HOMEPAGE="http://freshmeat.net/projects/pengupop"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,video]
+       sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+       default
+
+       eapply "${FILESDIR}"/${P}-underlink.patch
+
+       sed -i \
+               -e '/Icon/s/\.png//' \
+               -e '/^Encoding/d' \
+               -e '/Categories/s/Application;//' \
+               pengupop.desktop || die
+
+       sed -i \
+               -e 's/-g -Wall -O2/-Wall/' \
+               Makefile.am || die
+
+       mv configure.in configure.ac || die
+       eautoreconf
+}
+
+src_install() {
+       default
+       domenu pengupop.desktop
+       doicon -s 48 pengupop.png
+}
+
+pkg_preinst() {
+       gnome2_icon_savelist
+}
+
+pkg_postinst() {
+       gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+}