dev-util/pkgcheck: version bump to 0.6.0
authorTim Harder <radhermit@gentoo.org>
Fri, 23 Aug 2019 09:47:42 +0000 (03:47 -0600)
committerTim Harder <radhermit@gentoo.org>
Fri, 23 Aug 2019 09:56:59 +0000 (03:56 -0600)
Signed-off-by: Tim Harder <radhermit@gentoo.org>
dev-util/pkgcheck/Manifest
dev-util/pkgcheck/pkgcheck-0.6.0.ebuild [new file with mode: 0644]
dev-util/pkgcheck/pkgcheck-9999.ebuild

index 7a4f119868699d38370881384bddb80238a19409..9e91bed678d62a3c4845444ecbcea8ada89ab891 100644 (file)
@@ -1 +1,2 @@
 DIST pkgcheck-0.5.4.tar.gz 95354 BLAKE2B ce39854d494db7a7d3412690b8a789f3d78d2a7d0519f11397ec8b02bd03118f171eeba8fe37207e9c18bdf28e7e321ec06d8bb84f9302c07b5238c0851df1e3 SHA512 3c196ce170bb01f0a9f15caa8557e30cad8e088ab9bc733ac754e9c5f6d9078a70a4d14649ee5342848cc170f3c34d7575b35872c5d1a5693fb7aad207727b1b
+DIST pkgcheck-0.6.0.tar.gz 153310 BLAKE2B b7484cd9bebe912f9c8877c0f09df059130c2dc5c4da8c926f8df7945bcb7b255cdf810ce8cd16a957fb5bca3d1e71c088cd894968641db5dfae1c4c059df836 SHA512 86ff9e1c4b9353b1fbb475c7bb9d2a97bd9db8421ea5190b5a84832930b34cb5b79f8c3da68a5eb8db334f06851ec129cc6611a371e47b7c5de7a615feec5e05
diff --git a/dev-util/pkgcheck/pkgcheck-0.6.0.ebuild b/dev-util/pkgcheck/pkgcheck-0.6.0.ebuild
new file mode 100644 (file)
index 0000000..8f6ecf1
--- /dev/null
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{6,7} )
+DISTUTILS_IN_SOURCE_BUILD=1
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+       EGIT_REPO_URI="https://github.com/pkgcore/pkgcheck.git"
+       inherit git-r3
+else
+       KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="pkgcore-based QA utility"
+HOMEPAGE="https://github.com/pkgcore/pkgcheck"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+if [[ ${PV} == *9999 ]]; then
+       RDEPEND="
+               ~dev-python/snakeoil-9999[${PYTHON_USEDEP}]
+               ~sys-apps/pkgcore-9999[${PYTHON_USEDEP}]"
+else
+       RDEPEND="
+               >=dev-python/snakeoil-0.8.1[${PYTHON_USEDEP}]
+               >=sys-apps/pkgcore-0.10.0[${PYTHON_USEDEP}]"
+fi
+RDEPEND+="
+       dev-python/chardet[${PYTHON_USEDEP}]
+       dev-python/lxml[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_compile_all() {
+       use doc && esetup.py build_man
+}
+
+python_test() {
+       esetup.py test
+}
+
+python_install_all() {
+       local DOCS=( AUTHORS NEWS.rst )
+       esetup.py install_docs \
+               --docdir="${ED%/}/usr/share/doc/${PF}" \
+               --mandir="${ED%/}/usr/share/man"
+       distutils-r1_python_install_all
+}
index 75dc351a4f38e605fa220c8ce1d7f2cde3a5fa29..8f6ecf17c089ccc2d1f9d95c1bd9f5a6a4022477 100644 (file)
@@ -17,9 +17,10 @@ fi
 DESCRIPTION="pkgcore-based QA utility"
 HOMEPAGE="https://github.com/pkgcore/pkgcheck"
 
-LICENSE="|| ( BSD GPL-2 )"
+LICENSE="BSD"
 SLOT="0"
-IUSE="doc"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
 
 if [[ ${PV} == *9999 ]]; then
        RDEPEND="
@@ -27,7 +28,7 @@ if [[ ${PV} == *9999 ]]; then
                ~sys-apps/pkgcore-9999[${PYTHON_USEDEP}]"
 else
        RDEPEND="
-               >=dev-python/snakeoil-0.8.0[${PYTHON_USEDEP}]
+               >=dev-python/snakeoil-0.8.1[${PYTHON_USEDEP}]
                >=sys-apps/pkgcore-0.10.0[${PYTHON_USEDEP}]"
 fi
 RDEPEND+="
@@ -35,8 +36,10 @@ RDEPEND+="
        dev-python/lxml[${PYTHON_USEDEP}]
 "
 DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
        doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       dev-python/setuptools[${PYTHON_USEDEP}]"
+       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
 
 python_compile_all() {
        use doc && esetup.py build_man