media-sound/spotify: version bump to 1.1.5
authorNikos Chantziaras <realnc@gmail.com>
Wed, 1 May 2019 07:50:50 +0000 (10:50 +0300)
committerMatthew Thode <prometheanfire@gentoo.org>
Wed, 1 May 2019 09:20:53 +0000 (04:20 -0500)
EAPI 7, BDEPEND on patchelf-0.10, sort RDEPEND, remove commented-out x86
support as it's extremely unlikely x86 builds will be brought back by
upstream.

Closes: https://bugs.gentoo.org/684852
Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: Nikos Chantziaras <realnc@gmail.com>
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
media-sound/spotify/Manifest
media-sound/spotify/spotify-1.1.5.ebuild [new file with mode: 0644]

index 9c780a8a64fe3c2651ec322bedf93bd5308702f9..59f9fd0a369501ce523fd1ae9e14785bae097741 100644 (file)
@@ -1,3 +1,4 @@
 DIST spotify-client_1.0.72.117.g6bd7cc73-35_i386.deb 95135550 BLAKE2B ad4587dd6b3c64a0398e0790203a7826e290a27542fa39ebbd6c7198d8ad1fd3fb06e8b030b64e1e61e0624ef20aafda08189266486cd073cb779ebff62ef502 SHA512 51d60f7592e5f31ea4b7e67736a85271cb48d4108459630da61c4ab67d2a470038240c1d6ff577280cb4498cf44f14d7bc7e0312f63d34265bcd1e70cd13142f
 DIST spotify-client_1.0.98.78.gb45d2a6b-10_amd64.deb 105135826 BLAKE2B e1641a738f8e03c86d9b28ac902ed9857e1bb406b03e7a1c59c522e86a211b13cfd442bf84f79af4302d32a4b1c041e8ef7297990e70912d8c0a5108838e0500 SHA512 f20f2c998a205f189a19f332b2e738a0ec98a34520765c0e1d27d95d92f7c9c2f78da32f9edcc61146be87e8d8df7d3521d2e84b427cd25586b9fe6bec8d1602
 DIST spotify-client_1.1.0.237.g378f6f25-11_amd64.deb 104760412 BLAKE2B d6cd695a41d80a47362b694e74b7d9d34a5c6480dbce189fa22d514126ab3022387871021a3d2a1301d9eb88c3b8f70755c1a5f880f9cc34c67c5faead7d84b8 SHA512 a1fcbf3463eea13a4ff38f4b40ae999c8e138abc8adf6988b4d764e597f166ef894baf449a6506a6b9b69ba3ed92c83dcb1a1eda23ab843c0441d2b71bbb0d51
+DIST spotify-client_1.1.5.153.gf614956d-16_amd64.deb 113728674 BLAKE2B bc7930a1935c0a05dba262abc384a699720be53e3bec83393c962761bee647a247d2ddf475a6812bdb969fc1f59e9d2c283de0da398a9b8f7ddfff8f1232fef1 SHA512 db354f161c35b5f1a2d633282fad8fccf565e0061e7d258012f28422d766630391d47d4dafe22448fb60f850bf4ccbfdf82443cf107e03727c077b2c62e524be
diff --git a/media-sound/spotify/spotify-1.1.5.ebuild b/media-sound/spotify/spotify-1.1.5.ebuild
new file mode 100644 (file)
index 0000000..bc815aa
--- /dev/null
@@ -0,0 +1,106 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit desktop pax-utils unpacker xdg
+
+DESCRIPTION="Spotify is a social music platform"
+HOMEPAGE="https://www.spotify.com/ch-de/download/previews/"
+SRC_BASE="http://repository.spotify.com/pool/non-free/s/${PN}-client/"
+BUILD_ID_AMD64="153.gf614956d-16"
+SRC_URI="${SRC_BASE}${PN}-client_${PV}.${BUILD_ID_AMD64}_amd64.deb"
+LICENSE="Spotify"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libnotify systray pax_kernel pulseaudio"
+RESTRICT="mirror strip"
+
+BDEPEND=">=dev-util/patchelf-0.10"
+# zenity needed for filepicker
+RDEPEND="
+       dev-libs/nss
+       dev-libs/openssl:0
+       dev-python/dbus-python
+       dev-python/pygobject:3
+       gnome-base/gconf
+       gnome-extra/zenity
+       libnotify? ( x11-libs/libnotify )
+       media-libs/alsa-lib
+       media-libs/fontconfig
+       media-libs/harfbuzz
+       media-libs/mesa
+       net-misc/curl[ssl]
+       net-print/cups[ssl]
+       pulseaudio? ( media-sound/pulseaudio )
+       systray? ( gnome-extra/gnome-integration-spotify )
+       x11-libs/gtk+:2
+       x11-libs/libXScrnSaver
+       x11-libs/libXtst
+"
+       #sys-libs/glibc
+
+S=${WORKDIR}/
+
+QA_PREBUILT="opt/spotify/spotify-client/spotify"
+
+src_prepare() {
+       # Fix desktop entry to launch spotify-dbus.py for systray integration
+       if use systray ; then
+               sed -i \
+                       -e 's/spotify \%U/spotify-dbus.py \%U/g' \
+                       usr/share/spotify/spotify.desktop || die "sed failed"
+       fi
+       default
+
+       # Spotify links against libcurl-gnutls.so.4, which does not exist in Gentoo.
+       patchelf --replace-needed libcurl-gnutls.so.4 libcurl.so.4 usr/bin/spotify \
+               || die "failed to patch libcurl library dependency"
+}
+
+src_install() {
+       gunzip usr/share/doc/spotify-client/changelog.gz || die
+       dodoc usr/share/doc/spotify-client/changelog
+
+       SPOTIFY_PKG_HOME=usr/share/spotify
+       insinto /usr/share/pixmaps
+       doins ${SPOTIFY_PKG_HOME}/icons/*.png
+
+       # install in /opt/spotify
+       SPOTIFY_HOME=/opt/spotify/spotify-client
+       insinto ${SPOTIFY_HOME}
+       doins -r ${SPOTIFY_PKG_HOME}/*
+       fperms +x ${SPOTIFY_HOME}/spotify
+
+       dodir /usr/bin
+       cat <<-EOF >"${D}"/usr/bin/spotify || die
+               #! /bin/sh
+               exec ${SPOTIFY_HOME}/spotify "\$@"
+       EOF
+       fperms +x /usr/bin/spotify
+
+       local size
+       for size in 16 22 24 32 48 64 128 256 512; do
+               newicon -s ${size} "${S}${SPOTIFY_PKG_HOME}/icons/spotify-linux-${size}.png" \
+                       "spotify-client.png"
+       done
+       domenu "${S}${SPOTIFY_PKG_HOME}/spotify.desktop"
+       if use pax_kernel; then
+               #create the headers, reset them to default, then paxmark -m them
+               pax-mark C "${ED}${SPOTIFY_HOME}/${PN}" || die
+               pax-mark z "${ED}${SPOTIFY_HOME}/${PN}" || die
+               pax-mark m "${ED}${SPOTIFY_HOME}/${PN}" || die
+               eqawarn "You have set USE=pax_kernel meaning that you intend to run"
+               eqawarn "${PN} under a PaX enabled kernel.  To do so, we must modify"
+               eqawarn "the ${PN} binary itself and this *may* lead to breakage!  If"
+               eqawarn "you suspect that ${PN} is being broken by this modification,"
+               eqawarn "please open a bug."
+       fi
+}
+
+pkg_postinst() {
+       xdg_pkg_postinst
+
+       ewarn "If Spotify crashes after an upgrade its cache may be corrupt."
+       ewarn "To remove the cache:"
+       ewarn "rm -rf ~/.cache/spotify"
+}