dev-python/webcolors: New package, ebuild written by me
authorJustin Lecher <jlec@gentoo.org>
Wed, 2 Sep 2015 10:38:44 +0000 (12:38 +0200)
committerJustin Lecher <jlec@gentoo.org>
Wed, 2 Sep 2015 11:05:31 +0000 (13:05 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/webcolors/Manifest [new file with mode: 0644]
dev-python/webcolors/metadata.xml [new file with mode: 0644]
dev-python/webcolors/webcolors-1.5.ebuild [new file with mode: 0644]

diff --git a/dev-python/webcolors/Manifest b/dev-python/webcolors/Manifest
new file mode 100644 (file)
index 0000000..9d49735
--- /dev/null
@@ -0,0 +1 @@
+DIST webcolors-1.5.tar.gz 29960 SHA256 b3b1c3a41e9c69d1982b76b6531239115519f91cc034a24e975749832dc51b8e SHA512 84ce8cbbbdb4523bb146cf379845b549570623411a56651a7f9b9687152b7adc9dc42a3a0f684b55b61fb7a3d51d49d3871100b56725c86a727e3374b53c84b6 WHIRLPOOL f779a1777bb1ad9dac92f4dc75981be7274864291e7fd53ad59aa11b2ebd3eab2ff35ec68944fe7d57658976ac7b29f0708a256fc0e73a96535af99a4313ad7e
diff --git a/dev-python/webcolors/metadata.xml b/dev-python/webcolors/metadata.xml
new file mode 100644 (file)
index 0000000..301d220
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/webcolors/webcolors-1.5.ebuild b/dev-python/webcolors/webcolors-1.5.ebuild
new file mode 100644 (file)
index 0000000..d81e75b
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Color names and value formats defined by the HTML and CSS specifications"
+HOMEPAGE="https://pypi.python.org/pypi/webcolors https://github.com/ubernostrum/webcolors"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="
+       test? ( dev-python/nose[${PYTHON_USEDEP}] )
+       "
+
+python_test() {
+       nosetests --verbose || die
+}