app-emulation/domi: QA: Change einstall to emake, EAPI bump, keyword for amd64
authorChris Reffett <creffett@gentoo.org>
Mon, 24 Aug 2015 21:40:10 +0000 (17:40 -0400)
committerChris Reffett <creffett@gentoo.org>
Mon, 24 Aug 2015 21:40:10 +0000 (17:40 -0400)
Gentoo-Bug: 521448

Package-Manager: portage-2.2.20.1

app-emulation/domi/domi-20060816.ebuild
app-emulation/domi/files/fix_install_links.patch [deleted file]

index 5384bc754b3ff1df9e02e38243f22f9ae7d65bc6..2a870ab36e69312138f18c5f2e4307173de27c62 100644 (file)
@@ -1,7 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
+EAPI=5
+
 inherit eutils
 DESCRIPTION="Scripts for building Xen domains"
 HOMEPAGE="http://www.bytesex.org"
@@ -9,14 +11,16 @@ EXTRA_VERSION="153213"
 SRC_URI="http://dl.bytesex.org/cvs-snapshots/${P}-${EXTRA_VERSION}.tar.gz"
 LICENSE="GPL-2"
 SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
 IUSE=""
-DEPEND="app-emulation/xen-tools
+DEPEND="
+       app-emulation/xen-tools
        app-arch/rpm
        sys-block/parted
        sys-apps/yum
        sys-fs/lvm2
-       sys-fs/multipath-tools"
+       sys-fs/multipath-tools
+"
 # there are some other depends we may need depending on the target system
 # these packages aren't in gentoo yet. feel free to submit ebuilds via bugzilla.
 # y2pmsh
@@ -24,15 +28,13 @@ RESTRICT="test"
 
 S=${WORKDIR}/${PN}
 
-src_unpack() {
-       unpack ${A}
+src_configure() {
+       sed -i -e 's@/usr/local@/usr@' "${S}"/Makefile
        sed -i -e 's:/dev/loop\$:/dev/loop/\$:' "${S}"/domi
-       cd "${S}"
-       epatch "${FILESDIR}"/fix_install_links.patch
 }
 
 src_install() {
-       einstall || die
+       emake DESTDIR="${D}" install
        insinto /etc
        doins "${FILESDIR}"/domi.conf || die
 }
diff --git a/app-emulation/domi/files/fix_install_links.patch b/app-emulation/domi/files/fix_install_links.patch
deleted file mode 100644 (file)
index 29a7eb7..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
---- Makefile.orig      2008-10-05 18:59:51.000000000 +0200
-+++ Makefile   2008-10-05 19:37:58.000000000 +0200
-@@ -23,9 +23,9 @@
-       install -d $(DESTDIR)$(mandir)/man8
-       install -m755 $(scripts) $(DESTDIR)$(libdir)
-       install -m644 domi.man $(DESTDIR)$(mandir)/man8/domi.8
--      ln -s $(libdir)/domi $(DESTDIR)$(bindir)/domi
--      ln -s $(libdir)/ttylinux $(DESTDIR)$(bindir)/ttylinux
--      ln -s $(libdir)/initramfs $(DESTDIR)$(bindir)/busybox.initramfs
-+      ln -s ../share/domi/domi $(bindir)/domi
-+      ln -s ../share/domi/ttylinux $(bindir)/ttylinux
-+      ln -s ../share/domi/initramfs $(bindir)/busybox.initramfs
- test:
-       su -c tests/Run