dev-python/chameleon: Remove old
authorMichał Górny <mgorny@gentoo.org>
Mon, 11 May 2020 16:24:44 +0000 (18:24 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 11 May 2020 16:48:48 +0000 (18:48 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/chameleon/Manifest
dev-python/chameleon/chameleon-2.25.ebuild [deleted file]

index e5c10978e7bbeda6bec91625939c98ee64c18086..d0401f78f581b517acfce0730d2792501e6510db 100644 (file)
@@ -1,2 +1 @@
-DIST Chameleon-2.25.tar.gz 193965 BLAKE2B a6ae7768c52807a82229d75fc044116a77df5ae3032a98e44558a1d2b3ee2f427f3291b7c2895639050ea1e9fda0e6868ca7b8299cbbf1d5e1b0714af0d835c0 SHA512 b2ffc05c6ab5268757ae6a93a0579d8031dfe7e09882f0f3f0b9a25677ecf896af99a8e7cf6bec98648e9c8526365e7e517bc174d36137734968d80f3f14a05d
 DIST chameleon-3.7.0.gh.tar.gz 135209 BLAKE2B 14e890eca1a3c211dfb5a658457473b21948b6f252e76e5391e862850a29e9e0fe4aaa31a03da7ec1674a2b563d083ee31fb342be2dc9bf4e7b4dbccbabf8637 SHA512 9f1d2a9222b795ac139f0c06ea8169ec132c00714ec4608e58dd5781dba8380f988141f6659c47e8920ee0cd4d4bcde9070794cd0e2b5f34d0fce21d24e2dc98
diff --git a/dev-python/chameleon/chameleon-2.25.ebuild b/dev-python/chameleon/chameleon-2.25.ebuild
deleted file mode 100644 (file)
index ea608fe..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 pypy3 )
-
-inherit distutils-r1
-
-MY_PN="Chameleon"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Fast HTML/XML template compiler for Python"
-HOMEPAGE="http://chameleon.repoze.org https://pypi.org/project/Chameleon/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="repoze"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-python_compile_all() {
-       use doc && emake html
-}
-
-python_test() {
-       esetup.py test
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( _build/html/{[a-z]*,_static} )
-
-       distutils-r1_python_install_all
-}