version bump
authorMichael Sterrett <mr_bones_@gentoo.org>
Mon, 21 Sep 2015 14:55:03 +0000 (10:55 -0400)
committerMichael Sterrett <mr_bones_@gentoo.org>
Mon, 21 Sep 2015 14:58:29 +0000 (10:58 -0400)
Package-Manager: portage-2.2.20.1

games-util/nml/Manifest
games-util/nml/nml-0.4.2.ebuild [new file with mode: 0644]

index 4f225e14669b24866f53e0429fe4fcb8930abd6b..8d290690fea6625effef5eaf94905ca751dfe2b5 100644 (file)
@@ -1 +1,2 @@
 DIST nml-0.4.1.tar.gz 377419 SHA256 f53c06a209655407a8e9604f15bb30f137c20b3754ceb9449b4904a1956d0ae0 SHA512 3ac1b3c716b62975261fc55d5a70eba1616d65a4e68e0520da63d6be4a85646dce7fc5f17b9ae896eb8e232d756f9604b9dbc020a76020f5cd73b0419e11f006 WHIRLPOOL c122ad3301f9f5e4f4cba85c776675e66984b82123db81a97d79d3e266231afebc611d8203f9a532a23b9c485595031aa9c1b1e6f3987d67118d85b4cce49cf0
+DIST nml-0.4.2.tar.gz 377834 SHA256 eb4c2107682f14c58c5fbffc5f26c206fd3c8fc6972a3e28478e3e7f2bb773d7 SHA512 0d9c9f1de91cd91962aeacc0e5c59b351a2e4729f97d7fc2eb49f6d6487c1e1a7a98fb8f793689520c6e828fd6cdf39e952f13d0dc2f198234e3e6ad47fe6d8b WHIRLPOOL d4d994125c04c53528ae4cf9e3ca4643d2ef1e71636453404196b200a275649b2846683406bbae6f76e98573ea92962c23e295adeba3f6086026c0b8fd676c75
diff --git a/games-util/nml/nml-0.4.2.ebuild b/games-util/nml/nml-0.4.2.ebuild
new file mode 100644 (file)
index 0000000..c98bdab
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{3_3,3_4} )
+inherit distutils-r1
+
+DESCRIPTION="Compiler of NML files into grf/nfo files"
+HOMEPAGE="http://dev.openttdcoop.org/projects/nml"
+SRC_URI="http://bundles.openttdcoop.org/nml/releases/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+RDEPEND="dev-python/pillow[zlib,${PYTHON_USEDEP}]
+       dev-python/ply[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( docs/{changelog,readme}.txt )
+
+src_install() {
+       distutils-r1_src_install
+       doman docs/nmlc.1
+}