dev-ruby/net-scp: add 2.0.0
authorHans de Graaff <graaff@gentoo.org>
Mon, 22 Apr 2019 05:25:38 +0000 (07:25 +0200)
committerHans de Graaff <graaff@gentoo.org>
Mon, 22 Apr 2019 05:25:38 +0000 (07:25 +0200)
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Package-Manager: Portage-2.3.62, Repoman-2.3.11

dev-ruby/net-scp/Manifest
dev-ruby/net-scp/net-scp-2.0.0.ebuild [new file with mode: 0644]

index 48e9b30f24d1596a539935bf86c11de4bb960373..790a5263e9e4f381cb6f6851918779cc8037c927 100644 (file)
@@ -1 +1,2 @@
 DIST net-scp-1.2.1.gem 32768 BLAKE2B 67abf0b66aa6e8f28bdfa314a20f594eedafc5aeaf5d0ae8884cb7e27203699a791623968da98aaebda1630d47bf5859cc3e38875fe17dc8c7ce7926b50848a5 SHA512 64645a4517d6e408e3acfdb24576c8ded3b6ff981035ca10a2e081f9e3ab093f97b4848da4acca03ade364483766677e31296d09a31db4c81eb40123fc966829
+DIST net-scp-2.0.0.tar.gz 27835 BLAKE2B 2f5c9504ade26226a31fd766869f4deef3b344e99e71f780f184361efc75cad880c0dd266779d7f2550f176a86e89740edf27943c9ed81691378e5c3bf3241f0 SHA512 cd3470dfb2afba91911c429828d158e97e4feb17e211807abb05ab251622dc066e392521de250a8f2d4cf9d53c79598d636ef70c559b6aca7e1e7aa59ea3b36e
diff --git a/dev-ruby/net-scp/net-scp-2.0.0.ebuild b/dev-ruby/net-scp/net-scp-2.0.0.ebuild
new file mode 100644 (file)
index 0000000..8c3e843
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pure Ruby implementation of the SCP client protocol"
+HOMEPAGE="https://github.com/net-ssh/net-scp"
+SRC_URI="https://github.com/net-ssh/net-scp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_PATCHES=(
+       ${P}-raise-correct-errors.patch
+       ${P}-fix-common.path
+       ${P}-fix-download_test.patch
+       ${P}-fix-download_test_2.patch
+       ${P}-fix-download_test_3.patch
+       ${P}-fix-upload_tests.patch
+       ${P}-raise-correct-errors-net-ssh-4.0-compat.patch
+       )
+
+ruby_add_bdepend "
+       doc? ( || ( dev-ruby/net-ssh:5 dev-ruby/net-ssh:4 ) )
+       test? (
+               || ( dev-ruby/net-ssh:5 dev-ruby/net-ssh:4 )
+               dev-ruby/mocha
+       )"
+
+ruby_add_rdepend "|| ( dev-ruby/net-ssh:5 dev-ruby/net-ssh:4 )"
+
+each_ruby_test() {
+       ${RUBY} -Ilib:test test/test_all.rb || die
+}