dev-python/humanfriendly: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 11:41:56 +0000 (12:41 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 11:41:56 +0000 (12:41 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/humanfriendly/Manifest
dev-python/humanfriendly/humanfriendly-4.17.ebuild [deleted file]

index 696f85ba420aa1761a97a4de89ba28d226fea960..3a5643b6a47b43fdd68f04e9590c5804de78d831 100644 (file)
@@ -1,2 +1 @@
-DIST humanfriendly-4.17.tar.gz 344455 BLAKE2B 985ae142ea5378fcceb9f5f28773ac4dcaf0ea55ef1a7269fd1840a0b7119b54362aa93c330aa62e5424cc6f329e88717b45255c62b8e1d3f9ff5dd43a3c16c2 SHA512 a5786f28eaa0ff33919d9164ff30037fef5dbf60a31aece7679d1dddf3239f5a0d27209c710053cb0ac6779c1ef39102b1441fc620063283e90ef2ae11f8b621
 DIST humanfriendly-4.18.tar.gz 345853 BLAKE2B 9b03ea0679f787e216ee78efe8feb77f83562998813718845f4d21b7ce3f42cadff0e80b96f02da3cf6dc7f35cb0714f746940cf2ac0ec8e8981377989650c8a SHA512 01c7ee50d35154fe0b7ad39662ca6ff2dcd3e0f2a2eacc62f0184102c9db1c0fd99257273982aff56710b4e59024e8c20ee77ddd10c68e427c077ed4ca7e0022
diff --git a/dev-python/humanfriendly/humanfriendly-4.17.ebuild b/dev-python/humanfriendly/humanfriendly-4.17.ebuild
deleted file mode 100644 (file)
index 9fe2f4d..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_6 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-MY_PN="python-${PN}"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Human friendly output for text interfaces using Python"
-HOMEPAGE="https://pypi.org/project/humanfriendly/ https://humanfriendly.readthedocs.org"
-SRC_URI="https://github.com/xolox/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       dev-python/monotonic[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               >=dev-python/capturer-2.1[${PYTHON_USEDEP}]
-               >=dev-python/coloredlogs-2.0[${PYTHON_USEDEP}]
-               >=dev-python/pytest-3.0.7[${PYTHON_USEDEP}]
-       )
-       "
-
-S="${WORKDIR}/${MY_P}"
-
-python_test() {
-       pytest -v || die
-}