dev-python/cement: QA fixes
authorJustin Lecher <jlec@gentoo.org>
Fri, 2 Oct 2015 08:37:59 +0000 (10:37 +0200)
committerJustin Lecher <jlec@gentoo.org>
Fri, 2 Oct 2015 09:41:17 +0000 (11:41 +0200)
use eclass functions (esetup.py)
Make buildtime deps DEPEND
fix doc isntallation

Package-Manager: portage-2.2.22
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/cement/cement-2.0.2.ebuild
dev-python/cement/metadata.xml

index e24041324bc969fa275a02236009b2212f432f5a..21dbb27851aff18f9e6f131bb0b5df1520765fdc 100644 (file)
@@ -19,28 +19,29 @@ SLOT="0"
 KEYWORDS="amd64 x86"
 IUSE="test doc"
 
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+RDEPEND=""
 DEPEND="${RDEPEND}
-       test? ( dev-python/nose[${PYTHON_USEDEP}]
-               dev-python/coverage[${PYTHON_USEDEP}] )"
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+       test? (
+               dev-python/nose[${PYTHON_USEDEP}]
+               dev-python/coverage[${PYTHON_USEDEP}]
+       )"
 
 DOCS=( ChangeLog CONTRIBUTORS README.md )
 PATCHES=( "${FILESDIR}"/tests-installation.patch )
 # https://github.com/cement/cement/issues/185
 
 python_test() {
-       nosetests || die "Tests fail with ${EPYTHON}"
+       nosetests --verbose || die "Tests fail with ${EPYTHON}"
 }
 
 python_compile_all() {
-       if use doc; then
-               "${PYTHON}" setup.py build_sphinx || die "couldn't build docs"
-       fi
+       use doc && esetup.py build_sphinx
 }
 
 python_install_all() {
-       use doc && HTML_DOCS=( doc/build/html/* )
+       use doc && HTML_DOCS=( doc/build/html/. )
 
        distutils-r1_python_install_all
 }
index e81878f9464498a91909f77f5743507a8d1ee83e..e95d6e192d10fbc1b60cadf0272d0d3c9888c603 100644 (file)
@@ -6,4 +6,3 @@
                Cement is an advanced CLI Application Framework for Python. Its goal is to introduce a standard, and feature-full platform for both simple and complex command line applications as well as support rapid development needs without sacrificing quality.
        </longdescription>
 </pkgmetadata>
-