sys-apps/man-db: live ebuild requires gnulib sources
authorLars Wendler <polynomial-c@gentoo.org>
Thu, 24 Oct 2019 09:37:25 +0000 (11:37 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Thu, 24 Oct 2019 10:22:26 +0000 (12:22 +0200)
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-apps/man-db/man-db-9999.ebuild

index 4d2bfc884fe9accc9b68e5fb841aaa40dbf1bc54..0d01ad57258fa11741c45acf55fa2f629de55e54 100644 (file)
@@ -8,7 +8,7 @@ inherit systemd
 DESCRIPTION="a man replacement that utilizes berkdb instead of flat files"
 HOMEPAGE="http://www.nongnu.org/man-db/"
 if [[ "${PV}" = 9999* ]] ; then
-       inherit git-r3
+       inherit autotools git-r3
        EGIT_REPO_URI="https://git.savannah.gnu.org/git/man-db.git"
 else
        SRC_URI="mirror://nongnu/${PN}/${P}.tar.xz"
@@ -52,6 +52,36 @@ pkg_setup() {
        fi
 }
 
+src_unpack() {
+       if [[ "${PV}" == *9999 ]] ; then
+               git-r3_src_unpack
+
+               # We need to mess with gnulib :-/
+               EGIT_REPO_URI="https://git.savannah.gnu.org/r/gnulib.git" \
+               EGIT_CHECKOUT_DIR="${WORKDIR}/gnulib" \
+               git-r3_src_unpack
+       else
+               default
+       fi
+}
+
+src_prepare() {
+       default
+       if [[ "${PV}" == *9999 ]] ; then
+               local bootstrap_opts=(
+                       --gnulib-srcdir=../gnulib
+                       --no-bootstrap-sync
+                       --copy
+                       --no-git
+               )
+               AUTORECONF="/bin/true" \
+               LIBTOOLIZE="/bin/true" \
+               sh ./bootstrap "${bootstrap_opts[@]}" || die
+
+               eautoreconf
+       fi
+}
+
 src_configure() {
        export ac_cv_lib_z_gzopen=$(usex zlib)
        local myeconfargs=(