dev-libs/hiredis: remove old
authorMichael Palimaka <kensington@gentoo.org>
Fri, 24 Feb 2017 23:56:26 +0000 (10:56 +1100)
committerMichael Palimaka <kensington@gentoo.org>
Fri, 24 Feb 2017 23:57:33 +0000 (10:57 +1100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-libs/hiredis/Manifest
dev-libs/hiredis/hiredis-0.11.0-r1.ebuild [deleted file]
dev-libs/hiredis/hiredis-0.13.1.ebuild [deleted file]

index 030a7ccdb699a47776717133f60e5627905fbe2f..e70e39f05aad79c9219e87402caa9fe051ef63cd 100644 (file)
@@ -1,3 +1 @@
-DIST hiredis-0.11.0.tar.gz 42137 SHA256 ff7b2849e55bf3589eecced7125934feb9645c36a4d490d001dc08c93553eafd SHA512 a506c3e09267bd431dea87fdb7f9a44fb1d4795cbecb31323fe2fb9d66c10351fbf6d931fdaf2731fc2d0a985234e5d6ba0c9e694374d2f414294d27b6f060b8 WHIRLPOOL 0d4d4385452b4fe3aabc7cbdbef95914fea685a65f44a6b2addaec8f0f7779ed7f72c50cfbb976e1838553746ae90f2ce8685c208727e450738ff2bb29cca144
-DIST hiredis-0.13.1.tar.gz 54912 SHA256 8865105e15331156a74b64aafbfd3f8c784a8375e003a55512dcca3d82168487 SHA512 70b533a6cfbc3ce2b64018978e4f4460ca9a204ede92b571638ed4f04960199be0704cff16fcaf368e5c997a01e3b2da98e3c556c2f05c8316381f989684fcf1 WHIRLPOOL 6b2884217544a78153b33d4bc758f8d5bfe2cf29a16c768df7ffefbe7def43c7ae1477f1826790fdc64999b272bd33f72e10a968e606324366cb2b5539a0df71
 DIST hiredis-0.13.3.tar.gz 58291 SHA256 717e6fc8dc2819bef522deaca516de9e51b9dfa68fe393b7db5c3b6079196f78 SHA512 0d8b71d5ee4105e8aaeeee308795afc2c1f60a04b0bfe8ae873d800a0c157882ec307efa04a8d0e63b538fd3fc3f88eedf4d46cb87c8937e2403927aeb7e434c WHIRLPOOL 511f86f680a005bd1fa75494707bf5a16670c3f2b7ac0fd61684546368868a2545fa7aa74b63e3865be8ec7cb301417c5a945fe090de398066f098bef01d664b
diff --git a/dev-libs/hiredis/hiredis-0.11.0-r1.ebuild b/dev-libs/hiredis/hiredis-0.11.0-r1.ebuild
deleted file mode 100644 (file)
index 1c82e73..0000000
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-
-inherit eutils multilib
-
-DESCRIPTION="Minimalistic C client library for the Redis database"
-HOMEPAGE="https://github.com/redis/hiredis"
-SRC_URI="https://github.com/redis/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x64-solaris"
-IUSE="static-libs"
-
-src_prepare() {
-       epatch "${FILESDIR}/${P}-disable-network-tests.patch"
-
-       # use GNU ld syntax on Solaris
-       sed -i -e '/DYLIB_MAKE_CMD=.* -G/d' Makefile || die
-}
-
-_emake() {
-       emake \
-               AR="$(tc-getAR)" \
-               CC="$(tc-getCC)" \
-               ARCH= \
-               DEBUG= \
-               OPTIMIZATION="${CPPFLAGS}" \
-               "$@"
-}
-
-src_compile() {
-       # The static lib re-uses the same objects as the shared lib, so
-       # overhead is low w/creating it all the time.  It's also needed
-       # by the tests.
-       _emake dynamic static
-}
-
-src_test() {
-       _emake test
-}
-
-src_install() {
-       _emake PREFIX="${ED}/usr" LIBRARY_PATH="$(get_libdir)" install
-       use static-libs || rm "${ED}/usr/$(get_libdir)/libhiredis.a"
-       dodoc CHANGELOG.md README.md
-}
diff --git a/dev-libs/hiredis/hiredis-0.13.1.ebuild b/dev-libs/hiredis/hiredis-0.13.1.ebuild
deleted file mode 100644 (file)
index 6d9684d..0000000
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils multilib
-
-DESCRIPTION="Minimalistic C client library for the Redis database"
-HOMEPAGE="https://github.com/redis/hiredis"
-SRC_URI="https://github.com/redis/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ppc64 ~x86 ~x86-fbsd ~x64-solaris"
-IUSE="examples static-libs test"
-
-DEPEND="test? ( dev-db/redis )"
-
-src_prepare() {
-       epatch "${FILESDIR}/${P}-disable-network-tests.patch"
-
-       # use GNU ld syntax on Solaris
-       sed -i -e '/DYLIB_MAKE_CMD=.* -G/d' Makefile || die
-}
-
-_build() {
-       emake \
-               AR="$(tc-getAR)" \
-               CC="$(tc-getCC)" \
-               PREFIX="${EPREFIX%/}/usr" \
-               LIBRARY_PATH="$(get_libdir)" \
-               ARCH= \
-               DEBUG= \
-               OPTIMIZATION="${CPPFLAGS}" \
-               "$@"
-}
-
-src_compile() {
-       # The static lib re-uses the same objects as the shared lib, so
-       # overhead is low w/creating it all the time.  It's also needed
-       # by the tests.
-       _build dynamic static hiredis.pc
-}
-
-src_test() {
-       local REDIS_PID="${T}"/hiredis.pid
-       local REDIS_SOCK="${T}"/hiredis.sock
-       local REDIS_PORT=56379
-       local REDIS_TEST_CONFIG="daemonize yes
-               pidfile ${REDIS_PID}
-               port ${REDIS_PORT}
-               bind 127.0.0.1
-               unixsocket //${REDIS_SOCK}"
-
-       _build hiredis-test
-
-       /usr/sbin/redis-server - <<< "${REDIS_TEST_CONFIG}" || die
-       ./hiredis-test -h 127.0.0.1 -p ${REDIS_PID} -s ${REDIS_SOCK}
-       local ret=$?
-
-       kill "$(<"${REDIS_PID}")" || die
-       [ ${ret} != "0" ] && die "tests failed"
-}
-
-src_install() {
-       _build PREFIX="${ED%/}/usr" install
-       if use static-libs; then
-               rm "${ED%/}/usr/$(get_libdir)/libhiredis.a" || die
-       fi
-       use examples && dodoc -r examples
-
-       insinto /usr/$(get_libdir)/pkgconfig
-       doins ${PN}.pc
-
-       dodoc CHANGELOG.md README.md
-}