media-sound/multimux: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Thu, 17 Oct 2019 09:00:10 +0000 (11:00 +0200)
committerDavid Seifert <soap@gentoo.org>
Thu, 17 Oct 2019 09:00:10 +0000 (11:00 +0200)
Bug: https://bugs.gentoo.org/697274
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: David Seifert <soap@gentoo.org>
media-sound/multimux/files/multimux-0.2.4-makefiles.patch
media-sound/multimux/multimux-0.2.5.2.ebuild

index 61ab8b8b395c1488847f20942357210dbd36f084..108d14eee2b1c8eae9cdb9b310c872e618250336 100644 (file)
@@ -1,13 +1,27 @@
-Index: multimux-0.2.4/Makefile
-===================================================================
---- multimux-0.2.4.orig/Makefile
-+++ multimux-0.2.4/Makefile
-@@ -17,7 +17,7 @@ multimux.o
- all:
-       $(CC) $(CFLAGS) -c $(SRC1)
+--- a/Makefile
++++ b/Makefile
+@@ -1,9 +1,3 @@
+-CC = gcc
+-#CC  = g++
+-
+-
+-#CFLAGS = -O2 -Wall -D_FILE_OFFSET_BITS=64
+-CFLAGS = -O2 -Wall -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
+ LIBRARY =
  
+ SRC1  = \
+@@ -12,13 +6,7 @@
+ OBJECT1 = \
+ multimux.o
+-all:
+-      $(CC) $(CFLAGS) -c $(SRC1)
+-
 -      $(CC) -o multimux   $(OBJECT1) $(LIBRARY)
-+      $(CC) $(LDFLAGS) -o multimux   $(OBJECT1) $(LIBRARY)
+-
+-# DEPENDENCIES
+-multimux.o : multimux.c multimux.h multimux_proto.h wave_header.h
++all: multimux
  
- # DEPENDENCIES
- multimux.o : multimux.c multimux.h
+ install: 
+       cp multimux   /usr/local/bin/
index 8bc954c852816333cccff1df9448041b1265fd15..da2b0b17ecfb2dab1558f678992986087b3fe57d 100644 (file)
@@ -1,11 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
-inherit eutils toolchain-funcs flag-o-matic
-
-IUSE=""
+inherit flag-o-matic toolchain-funcs
 
 DESCRIPTION="combines up to 8 audio mono wave ch. into one big multi ch. wave file"
 HOMEPAGE="http://panteltje.com/panteltje/dvd/"
@@ -15,18 +13,14 @@ LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="amd64 ~ppc ~sparc x86"
 
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
-       epatch "${FILESDIR}/${PN}-0.2.4-makefiles.patch"
-}
+PATCHES=( "${FILESDIR}"/${PN}-0.2.4-makefiles.patch )
 
-src_compile() {
-       append-flags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
-       emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+src_configure() {
+       append-lfs-flags
+       tc-export CC
 }
 
 src_install() {
        dobin multimux
-       dodoc CHANGES README
+       einstalldocs
 }