dev-util/spirv-headers: 9999 cleanup, cmake.eclass
authorMatt Turner <mattst88@gentoo.org>
Sun, 15 Mar 2020 20:11:46 +0000 (13:11 -0700)
committerMatt Turner <mattst88@gentoo.org>
Sun, 15 Mar 2020 21:28:02 +0000 (14:28 -0700)
Signed-off-by: Matt Turner <mattst88@gentoo.org>
dev-util/spirv-headers/spirv-headers-9999.ebuild

index 7a7e30be5d45f694853230915dcdaba38c56ef50..7da32106bb4b47a4e21f87ae310378964a07b9e1 100644 (file)
@@ -1,14 +1,22 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
-inherit cmake-utils git-r3
+MY_PN=SPIRV-Headers
+inherit cmake
+
+if [[ ${PV} == *9999* ]]; then
+       EGIT_REPO_URI="https://github.com/KhronosGroup/${MY_PN}.git"
+       inherit git-r3
+else
+       SRC_URI="https://github.com/KhronosGroup/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~ppc64 ~x86"
+       S="${WORKDIR}"/${MY_PN}-${PV}
+fi
 
 DESCRIPTION="Machine-readable files for the SPIR-V Registry"
-HOMEPAGE="https://www.khronos.org/registry/spir-v/"
-EGIT_REPO_URI="https://github.com/KhronosGroup/SPIRV-Headers.git"
-SRC_URI=""
+HOMEPAGE="https://www.khronos.org/registry/spir-v/ https://github.com/KhronosGroup/SPIRV-Headers"
 
 LICENSE="MIT"
 SLOT="0"