dev-python/pandas: version bump.
authorBenda Xu <heroxbd@gentoo.org>
Mon, 9 Mar 2020 12:39:12 +0000 (20:39 +0800)
committerBenda Xu <heroxbd@gentoo.org>
Mon, 9 Mar 2020 12:44:48 +0000 (20:44 +0800)
upstream have fixed the parallel issue by forcing the build system to
be mostly serial.

3 s3 tests fails because dev-python/s3fs is not new enough (>=0.3).

drop amd64-linux x86-linux keywords because the dependencies are not
met.

Reported-By: Thomas Beutin, Andrew
Closes: https://bugs.gentoo.org/680036
Package-Manager: Portage-2.3.88, Repoman-2.3.18
Signed-off-by: Benda Xu <heroxbd@gentoo.org>
dev-python/pandas/Manifest
dev-python/pandas/pandas-1.0.1.ebuild [new file with mode: 0644]

index 979d04182ba1af40d7926690d89943c5fbf7ad13..6e981506a514ee3d8f0a285c60edfddfde88b37c 100644 (file)
@@ -1 +1,2 @@
 DIST pandas-0.24.2.tar.gz 11837693 BLAKE2B 3762e94554a3ae3c803c9a412c5c551c15a9fbf15cb05633f7d1b0ccbfddc646f68f0306666e688a83a4495b0537cea2fec671157f5a63aaa5f9cad6b791261e SHA512 0795c6bb8a47a511853558ea59d371b4540ec175f213cfba4ad2361d6481fea5d3f7074bb4961c32f2f0080a72d7436a9b3706f5cc692074f98d83bfc587fd15
+DIST pandas-1.0.1.tar.gz 4852368 BLAKE2B d6d3ae757d245b665e4b67bd237c090ddff97688934268b171e278a14d2439f5d993addc304f16a0ac9ab7bc34bfe36df807f998148106b062c567a5a7f14f4a SHA512 6755d17a4a4a8c3770f413199a12b3c4d6b5f5fcc925bec9b9b0f813fcd020df0b2c0a32dc8528c795b16556e00c078a03e4a6746192b44bfbd7ffc809c1e56c
diff --git a/dev-python/pandas/pandas-1.0.1.ebuild b/dev-python/pandas/pandas-1.0.1.ebuild
new file mode 100644 (file)
index 0000000..c2bd75a
--- /dev/null
@@ -0,0 +1,164 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_REQ_USE="threads(+)"
+
+VIRTUALX_REQUIRED="manual"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 eutils flag-o-matic virtualx
+
+DESCRIPTION="Powerful data structures for data analysis and statistics"
+HOMEPAGE="https://pandas.pydata.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P/_/}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc full-support minimal test X"
+RESTRICT="!test? ( test )"
+
+RECOMMENDED_DEPEND="
+       >=dev-python/bottleneck-1.2.1[${PYTHON_USEDEP}]
+       >=dev-python/numexpr-2.1[${PYTHON_USEDEP}]
+"
+
+# TODO: add pandas-gbq to the tree
+OPTIONAL_DEPEND="
+       dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+       dev-python/blosc[${PYTHON_USEDEP}]
+       || (
+               dev-python/html5lib[${PYTHON_USEDEP}]
+               dev-python/lxml[${PYTHON_USEDEP}]
+       )
+       dev-python/jinja[${PYTHON_USEDEP}]
+       dev-python/matplotlib[${PYTHON_USEDEP}]
+       || (
+               dev-python/openpyxl[${PYTHON_USEDEP}]
+               dev-python/xlsxwriter[${PYTHON_USEDEP}]
+       )
+       >=dev-python/pytables-3.2.1[${PYTHON_USEDEP}]
+       dev-python/s3fs[${PYTHON_USEDEP}]
+       dev-python/statsmodels[${PYTHON_USEDEP}]
+       >=dev-python/sqlalchemy-0.8.1[${PYTHON_USEDEP}]
+       >=dev-python/xarray-0.10.8[${PYTHON_USEDEP}]
+       >=dev-python/xlrd-1.0.0[${PYTHON_USEDEP}]
+       dev-python/xlwt[${PYTHON_USEDEP}]
+       >=sci-libs/scipy-1.1[${PYTHON_USEDEP}]
+       X? (
+               || (
+                       dev-python/PyQt5[${PYTHON_USEDEP}]
+                       x11-misc/xclip
+                       x11-misc/xsel
+               )
+       )
+"
+COMMON_DEPEND="
+       >dev-python/numpy-1.13.1[${PYTHON_USEDEP}]
+       dev-python/python-dateutil[${PYTHON_USEDEP}]
+       dev-python/pytz[${PYTHON_USEDEP}]
+"
+DEPEND="${COMMON_DEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       dev-python/cython[${PYTHON_USEDEP}]
+       doc? (
+               ${VIRTUALX_DEPEND}
+               app-text/pandoc
+               dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+               dev-python/html5lib[${PYTHON_USEDEP}]
+               dev-python/ipython[${PYTHON_USEDEP}]
+               dev-python/lxml[${PYTHON_USEDEP}]
+               dev-python/matplotlib[${PYTHON_USEDEP}]
+               dev-python/nbsphinx[${PYTHON_USEDEP}]
+               >=dev-python/numpydoc-0.9.1[${PYTHON_USEDEP}]
+               >=dev-python/openpyxl-1.6.1[${PYTHON_USEDEP}]
+               >=dev-python/pytables-3.0.0[${PYTHON_USEDEP}]
+               dev-python/pytz[${PYTHON_USEDEP}]
+               dev-python/rpy[${PYTHON_USEDEP}]
+               dev-python/sphinx[${PYTHON_USEDEP}]
+               dev-python/xlrd[${PYTHON_USEDEP}]
+               dev-python/xlwt[${PYTHON_USEDEP}]
+               sci-libs/scipy[${PYTHON_USEDEP}]
+               x11-misc/xclip
+       )
+       test? (
+               ${VIRTUALX_DEPEND}
+               ${RECOMMENDED_DEPEND}
+               ${OPTIONAL_DEPEND}
+               dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+               dev-python/hypothesis[${PYTHON_USEDEP}]
+               dev-python/nose[${PYTHON_USEDEP}]
+               dev-python/pymysql[${PYTHON_USEDEP}]
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/pytest-mock[${PYTHON_USEDEP}]
+               dev-python/psycopg:2[${PYTHON_USEDEP}]
+               x11-misc/xclip
+               x11-misc/xsel
+       )
+"
+# dev-python/statsmodels invokes a circular dep
+#  hence rm from doc? ( ), again
+RDEPEND="${COMMON_DEPEND}
+       !minimal? ( ${RECOMMENDED_DEPEND} )
+       full-support? ( ${OPTIONAL_DEPEND} )
+"
+
+S="${WORKDIR}/${P/_/}"
+
+python_prepare_all() {
+       # Prevent un-needed download during build
+       sed -e "/^              'sphinx.ext.intersphinx',/d" \
+               -i doc/source/conf.py || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+       # To build docs the need be located in $BUILD_DIR,
+       # else PYTHONPATH points to unusable modules.
+       if use doc; then
+               cd "${BUILD_DIR}"/lib || die
+               cp -ar "${S}"/doc . && cd doc || die
+               LANG=C PYTHONPATH=. virtx ${EPYTHON} make.py html
+       fi
+}
+
+python_test() {
+       pushd  "${BUILD_DIR}"/lib > /dev/null
+       "${EPYTHON}" -c "import pandas; pandas.show_versions()" || die
+       PYTHONPATH=. virtx pytest pandas -v --skip-slow --skip-network \
+               -m "not single"
+       find . -name .pytest_cache -exec rm -r {} + || die
+       popd > /dev/null
+}
+
+python_install_all() {
+       if use doc; then
+               dodoc -r "${BUILD_DIR}"/lib/doc/build/html
+               einfo "An initial build of docs is absent of references to statsmodels"
+               einfo "due to circular dependency. To have them included, emerge"
+               einfo "statsmodels next and re-emerge pandas with USE doc"
+       fi
+
+       distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+       optfeature "accelerating certain types of NaN evaluations, using specialized cython routines to achieve large speedups." dev-python/bottleneck
+       optfeature "accelerating certain numerical operations, using multiple cores as well as smart chunking and caching to achieve large speedups" ">=dev-python/numexpr-2.1"
+       optfeature "needed for pandas.io.html.read_html" dev-python/beautifulsoup:4 dev-python/html5lib dev-python/lxml
+       optfeature "for msgpack compression using blosc" dev-python/blosc
+       optfeature "necessary for Amazon S3 access" dev-python/s3fs
+       optfeature "Template engine for conditional HTML formatting" dev-python/jinja
+       optfeature "Plotting support" dev-python/matplotlib
+       optfeature "Needed for Excel I/O" ">=dev-python/openpyxl-1.6.1" dev-python/xlsxwriter dev-python/xlrd dev-python/xlwt
+       optfeature "necessary for HDF5-based storage" ">=dev-python/pytables-3.2.1"
+       optfeature "R I/O support" dev-python/rpy
+       optfeature "Needed for parts of pandas.stats" dev-python/statsmodels
+       optfeature "SQL database support" ">=dev-python/sqlalchemy-0.8.1"
+       optfeature "miscellaneous statistical functions" sci-libs/scipy
+       optfeature "necessary to use pandas.io.clipboard.read_clipboard support" dev-python/PyQt5 dev-python/pygtk x11-misc/xclip x11-misc/xsel
+}