app-misc/color: EAPI bump
authorAndreas K. Hüttel <dilfridge@gentoo.org>
Sun, 9 Apr 2017 20:45:56 +0000 (22:45 +0200)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Sun, 9 Apr 2017 20:47:07 +0000 (22:47 +0200)
Package-Manager: Portage-2.3.5, Repoman-2.3.2

app-misc/color/color-1.2-r2.ebuild [new file with mode: 0644]

diff --git a/app-misc/color/color-1.2-r2.ebuild b/app-misc/color/color-1.2-r2.ebuild
new file mode 100644 (file)
index 0000000..e14fb84
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Easily add ANSI colouring to shell scripts"
+HOMEPAGE="http://www.runslinux.net/?page_id=10"
+SRC_URI="http://runslinux.net/projects/color/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+src_prepare() {
+       eapply "${FILESDIR}"/${PV}-ldflags.patch
+       default
+       tc-export CC
+}
+
+src_install() {
+       dobin color
+       dodoc CHANGELOG README
+
+       # symlink for british users.
+       dosym color /usr/bin/colour
+}
+
+pkg_postinst() {
+       elog "For information on using colour in your shell scripts,"
+       elog "run \`color\` without any arguments."
+       elog
+       elog "To see all the colours available, use this command"
+       elog "  $ color --list"
+       elog
+       elog "More examples are available in ${EPREFIX}/usr/share/doc/${PF}."
+}