app-vim/vim-nftables: New package
authorPatrick McLean <patrick.mclean@sony.com>
Thu, 20 Feb 2020 23:26:11 +0000 (15:26 -0800)
committerPatrick McLean <chutzpah@gentoo.org>
Thu, 20 Feb 2020 23:29:38 +0000 (15:29 -0800)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
app-vim/vim-nftables/Manifest [new file with mode: 0644]
app-vim/vim-nftables/files/vim-nftables-0_pre20200220-extra-keywords.patch [new file with mode: 0644]
app-vim/vim-nftables/metadata.xml [new file with mode: 0644]
app-vim/vim-nftables/vim-nftables-0_pre20200220.ebuild [new file with mode: 0644]

diff --git a/app-vim/vim-nftables/Manifest b/app-vim/vim-nftables/Manifest
new file mode 100644 (file)
index 0000000..7cda0a9
--- /dev/null
@@ -0,0 +1 @@
+DIST vim-nftables-0_pre20200220.tar.gz 2419 BLAKE2B 7ee16e013f0873f5bd5d1e6beb3c824eabe38b759145a20aa0c9bb16b0abbb640d10eed59ffdc77ae0b4a7091158cc6d732cdec2589886edf52a8f6574f1145e SHA512 061b4410f261ea5449c366261ff8b3fd9ab15995ab73ac2f77a6de58e0d8764a0828973cbde152eb637f4bc6a8882c56efecdda65c7ecd6ca69df4f92fd190fe
diff --git a/app-vim/vim-nftables/files/vim-nftables-0_pre20200220-extra-keywords.patch b/app-vim/vim-nftables/files/vim-nftables-0_pre20200220-extra-keywords.patch
new file mode 100644 (file)
index 0000000..b063491
--- /dev/null
@@ -0,0 +1,22 @@
+From e378b1484a85399032ff32d86ad2a5bde936762f Mon Sep 17 00:00:00 2001
+From: adrian5 <adrian5@users.noreply.github.com>
+Date: Mon, 17 Feb 2020 22:13:50 +0100
+Subject: [PATCH] Add icmpv6 keyword
+
+---
+ syntax/nftables.vim | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/syntax/nftables.vim b/syntax/nftables.vim
+index c80eb9d..d5d0e3f 100644
+--- a/syntax/nftables.vim
++++ b/syntax/nftables.vim
+@@ -23,7 +23,7 @@ syn keyword Function table chain
+ syn keyword Statement type hook
+ syn keyword Type ip ip6 inet arp bridge
+ syn keyword Type filter nat route
+-syn keyword Type ether vlan arp ip ip6 tcp udp udplite sctp dccp ah esp ipcomp icmp
++syn keyword Type ether vlan arp ip ip6 tcp udp udplite sctp dccp ah esp ipcomp icmp icmpv6 igmp
+ syn keyword Type ct
+ syn keyword Type length protocol priority mark iif iifname iiftype oif oifname oiftype skuid skgid rtclassid
+ syn keyword Constant prerouting input forward output postrouting
diff --git a/app-vim/vim-nftables/metadata.xml b/app-vim/vim-nftables/metadata.xml
new file mode 100644 (file)
index 0000000..0172dae
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="person">
+    <email>chutzpah@gentoo.org</email>
+    <name>Patrick McLean</name>
+  </maintainer>
+  <maintainer type="project">
+    <email>vim@gentoo.org</email>
+  </maintainer>
+</pkgmetadata>
diff --git a/app-vim/vim-nftables/vim-nftables-0_pre20200220.ebuild b/app-vim/vim-nftables/vim-nftables-0_pre20200220.ebuild
new file mode 100644 (file)
index 0000000..779cf13
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+COMMIT_ID="aad8540ef56f495baa589f646edc1253db990f1a"
+
+DESCRIPTION="vim plugin: "
+HOMEPAGE="https://github.com/nfnty/vim-nftables"
+SRC_URI="https://github.com/nfnty/${PN}/archive/${COMMIT_ID}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT_ID}"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+       "${FILESDIR}/vim-nftables-0_pre20200220-extra-keywords.patch"
+)
+
+src_prepare() {
+       default
+
+       # will install license file by default
+       rm LICENSE || die
+}