dev-python/backports-functools-lru-cache: Remove old
authorMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 10:21:45 +0000 (12:21 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 10:23:39 +0000 (12:23 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/backports-functools-lru-cache/Manifest
dev-python/backports-functools-lru-cache/backports-functools-lru-cache-1.3.ebuild [deleted file]
dev-python/backports-functools-lru-cache/backports-functools-lru-cache-1.4-r1.ebuild [deleted file]
dev-python/backports-functools-lru-cache/backports-functools-lru-cache-1.5.ebuild [deleted file]

index 45e4eb6183c2db27b270286f8a8ec451398e23fe..46a85ff90f0107cb6c42bd53bbdf44617a5685cc 100644 (file)
@@ -1,4 +1 @@
-DIST backports.functools_lru_cache-1.3.tar.gz 6685 BLAKE2B 7007b08fc536ba2a31d215999a73399004b2db0f5c9e00706cb03df35882cfd987026fffa7e1deee2fde6142bbe0c5b7707ba06567e702e0781136572c0b17a0 SHA512 946156266d4b1bccb3eb444d1cceff6568b8c2a62e09bc9197281bdafe912069efa4c857089a7e6ea0247ab9407256a7a7c92485599692e0c0159c428137a342
-DIST backports.functools_lru_cache-1.4.tar.gz 6927 BLAKE2B a0ef9f56abcfde51b9d7f03cb9170c3d500652e43c9498fb7dc4c404276ceea15dcd6ffb2fc7efd723cb12790f99e6fe249136ae0d4c949f06ea06cc41318793 SHA512 78dcd12f392bc110d1556f567a9f8fe977fa4ddc98a2121ceaf43606687171866832b8d32220dfb4ca335f53e89acecabda9e48ad48571f1741b21ab2d3b8a21
-DIST backports.functools_lru_cache-1.5.tar.gz 7891 BLAKE2B 5de046672e25f95e8b224d79deb4ce7eb40aef72ea80e0788ef54076fc98ea3a993daf5a607a6670925707f357b4be14affc626b45bae100c6feba9a41e4c606 SHA512 083a69beb050a6de0f838231ceae05cd1825f42310b2cd4f0e53f7ca043af4c699ad7042c32831ee365bb6b374d33189136e45689c77815b99773d145f0ef4f1
 DIST backports.functools_lru_cache-1.6.1.tar.gz 12426 BLAKE2B 361cc71e0a18e6d578ac007d4990c2f7ae86a5753c25da378a7a3cfbece63b088278fc998adfea3eccaa51146659d658cdd7ce4e4e19d6d2fd7639f8df0a7262 SHA512 5764cc6ed83dc4abc2a7e5f8b5bb30c7b7554aafcbb6dfcececdb3646fe9298a8c1791a02112238ec94a0e383855bdec43bf9094f40b57124d0a0c9aa7c67f88
diff --git a/dev-python/backports-functools-lru-cache/backports-functools-lru-cache-1.3.ebuild b/dev-python/backports-functools-lru-cache/backports-functools-lru-cache-1.3.ebuild
deleted file mode 100644 (file)
index e04f64b..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-MY_PN="${PN/-/.}"
-MY_PN="${MY_PN//-/_}"
-DESCRIPTION="Backport of functools.lru_cache from Python 3.3"
-HOMEPAGE="https://github.com/jaraco/backports.functools_lru_cache"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ppc ppc64 sparc x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
-       doc? (
-               dev-python/sphinx[${PYTHON_USEDEP}]
-               dev-python/rst-linker[${PYTHON_USEDEP}]
-       )
-       test? (
-               >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
-               dev-python/pytest-runner[${PYTHON_USEDEP}]
-       )
-"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_compile_all() {
-       use doc && esetup.py build_sphinx
-}
-
-python_test() {
-       PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/backports-functools-lru-cache/backports-functools-lru-cache-1.4-r1.ebuild b/dev-python/backports-functools-lru-cache/backports-functools-lru-cache-1.4-r1.ebuild
deleted file mode 100644 (file)
index 467adf7..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-MY_PN="${PN/-/.}"
-MY_PN="${MY_PN//-/_}"
-DESCRIPTION="Backport of functools.lru_cache from Python 3.3"
-HOMEPAGE="https://github.com/jaraco/backports.functools_lru_cache"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/backports[${PYTHON_USEDEP}]"
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
-       doc? (
-               >=dev-python/jaraco-packaging-3.2[${PYTHON_USEDEP}]
-               dev-python/rst-linker[${PYTHON_USEDEP}]
-               dev-python/sphinx[${PYTHON_USEDEP}]
-       )
-       test? (
-               >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
-       )
-"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_compile_all() {
-       if use doc; then
-               cd docs || die
-               sphinx-build . _build/html || die
-               HTML_DOCS=( docs/_build/html/. )
-       fi
-}
-
-python_test() {
-       PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
-}
-
-python_install() {
-       # avoid a collision with dev-python/backports
-       rm "${BUILD_DIR}"/lib/backports/__init__.py || die
-       distutils-r1_python_install --skip-build
-}
diff --git a/dev-python/backports-functools-lru-cache/backports-functools-lru-cache-1.5.ebuild b/dev-python/backports-functools-lru-cache/backports-functools-lru-cache-1.5.ebuild
deleted file mode 100644 (file)
index 873ce21..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-MY_PN="${PN/-/.}"
-MY_PN="${MY_PN//-/_}"
-DESCRIPTION="Backport of functools.lru_cache from Python 3.3"
-HOMEPAGE="https://github.com/jaraco/backports.functools_lru_cache"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/backports[${PYTHON_USEDEP}]"
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
-       doc? (
-               >=dev-python/jaraco-packaging-3.2[${PYTHON_USEDEP}]
-               dev-python/rst-linker[${PYTHON_USEDEP}]
-               dev-python/sphinx[${PYTHON_USEDEP}]
-       )
-       test? (
-               >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
-       )
-"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_compile_all() {
-       if use doc; then
-               cd docs || die
-               sphinx-build . _build/html || die
-               HTML_DOCS=( docs/_build/html/. )
-       fi
-}
-
-python_test() {
-       PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
-}
-
-python_install() {
-       # avoid a collision with dev-python/backports
-       rm "${BUILD_DIR}"/lib/backports/__init__.py || die
-       distutils-r1_python_install --skip-build
-}