dev-python/tqdm: Bump to 4.46.0
authorMichał Górny <mgorny@gentoo.org>
Tue, 26 May 2020 19:22:16 +0000 (21:22 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 26 May 2020 20:02:57 +0000 (22:02 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/tqdm/Manifest
dev-python/tqdm/tqdm-4.46.0.ebuild [new file with mode: 0644]

index 8ac04ee3c6f75c2c6bcd4a61c47af306bc023c9f..cb9044ba656743852782169faf4f6d1c85b21bba 100644 (file)
@@ -2,3 +2,4 @@ DIST tqdm-4.23.3.tar.gz 75941 BLAKE2B 9e5810765e8f7ea4f54b0f93f453d278d5ad4b1710
 DIST tqdm-4.33.0.tar.gz 121571 BLAKE2B f4ee73cfa710462e148f6034ac69144d845d216bd97e16a78bc1f1ed5d658b6cd695d07aa1ea6ec93e2e747ab8fc52263a580c01516d1f111dcb5766b019925d SHA512 de86a2dc2c5f887b9671ee01e7c05820375b0ef83dec92f17da4d944dd02cbf96a133fd9d349ba5f9c75af70e7b87110a9a7ad3293c7eb81e49ed6ea288ba73c
 DIST tqdm-4.40.0.tar.gz 129225 BLAKE2B 85030c11bdba6c1d6da461e3c648bae6ae173577fb18986e3153badd73a28352f807782759aa52ed082d7ee0c13dc5f850c1da563ee5892f6bf5e8f49c48c7ee SHA512 1c326d98130c79f614cea502723e4202baa57b7b4639e208133cb464785e4a8d4eaa9d262ea484246d45e5eb8f21994e7ecf3fd6ef0f4966f9049fc8013d7442
 DIST tqdm-4.45.0.tar.gz 140990 BLAKE2B 8699b3a820859406e9bbafaaa48ba1b418e3083898d2b6c3401078996dd03431db259d5ad8a377226a50b80513ef0fc55bdaf2b67fc4a2bdd490bc5fdc04d681 SHA512 7b35f86205c6581ede9bdb0788e7f55be525c3f0f77952803046661c6a7a6cd3c15ed0323376ecedb5cddace1b32a41fee1932033dcaa49f9096dc3b9b674f10
+DIST tqdm-4.46.0.tar.gz 144312 BLAKE2B 93b902d9a362e658f244f3c1b15a3496425cb3e401adf291dc0a9c7c0bd551baa1171a753be8d1c3b877d2cd3ab25e81dddbd8492668d0b0f6ca3cb47d13be1c SHA512 ccdfce4d273e78ced172fc3edb24ac038465169f7b765e7bf779831ef3d0dc72c648c5fb165aba02e0c6dc86c5d0ea3d93d5530b642ddd84e3d284c7354739cf
diff --git a/dev-python/tqdm/tqdm-4.46.0.ebuild b/dev-python/tqdm/tqdm-4.46.0.ebuild
new file mode 100644 (file)
index 0000000..4bafe9e
--- /dev/null
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7,8}} )
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/tqdm/tqdm"
+else
+       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+       KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~sparc ~x86"
+fi
+
+DESCRIPTION="Add a progress meter to your loops in a second"
+HOMEPAGE="https://github.com/tqdm/tqdm"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="examples"
+
+distutils_enable_tests nose
+
+python_prepare_all() {
+       sed -r \
+               -e "s:'nose'(,[[:space:]]*|)::" \
+               -e "s:'flake8'(,[[:space:]]*|)::" \
+               -e "s:'coverage'(,[[:space:]]*|)::" \
+               -i setup.py
+
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       # tests_main.py requires the package to be installed
+       distutils_install_for_testing
+       # Skip unpredictable performance tests
+       nosetests tqdm -v --ignore 'tests_perf.py' \
+               || die "tests failed with ${EPYTHON}"
+}
+
+python_install() {
+       doman "${BUILD_DIR}"/lib/tqdm/tqdm.1
+       rm "${BUILD_DIR}"/lib/tqdm/tqdm.1 || die
+       distutils-r1_python_install --skip-build
+}
+
+python_install_all() {
+       if use examples; then
+               dodoc -r examples
+               docompress -x /usr/share/doc/${PF}/examples
+       fi
+       distutils-r1_python_install_all
+}