app-pda/usbmuxd: Bump to pre-1.1.1 snapshot, EAPI 7
authorJames Le Cuirot <chewi@gentoo.org>
Sun, 22 Mar 2020 22:28:32 +0000 (22:28 +0000)
committerJames Le Cuirot <chewi@gentoo.org>
Mon, 23 Mar 2020 22:58:09 +0000 (22:58 +0000)
Package-Manager: Portage-2.3.94, Repoman-2.3.20
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
app-pda/usbmuxd/Manifest
app-pda/usbmuxd/usbmuxd-1.1.1_pre20200121.ebuild [new file with mode: 0644]

index 7e34f3e1521c2691be06500caff8db9337e6aed4..7c2c79565f0fb5c9a8ee345fdb2caf8389ed0223 100644 (file)
@@ -1 +1,2 @@
 DIST usbmuxd-1.1.0.tar.bz2 321897 BLAKE2B 3ca5d1da222e457ac01f3e87fb7573c6405e51fd5d270a2b3dab7601118f21be22232d5100b4d027273fc837e6a57f7a7d17d2c41ae59d7c5aa41f76bef5a03d SHA512 66aa0c40e912bf596b819098b87d88e9cf30b2e6352e607eeb778bd4f23bf9bb123fb6a6ecca2d4e4be3171e35d66200d632d2c9c80b1f2462bb45be8aa6912d
+DIST usbmuxd-1.1.1_pre20200121.tar.bz2 51859 BLAKE2B 339d53904f7484bebb6d7524313ee065bf5a244efab16c77b30b8932071012105f21aa56083d82667b06088af83464ea8c86e3c28c5a45cb9abbe574a634533e SHA512 cc113b054e8e04d228af740ec43d2dbf29c015dc9d8e1cdd0eaf84bfcaa9838d5b1bf6db2efed30ffb84c35c88db5469983a115ffdbddbb6acd0df9fd2a5182f
diff --git a/app-pda/usbmuxd/usbmuxd-1.1.1_pre20200121.ebuild b/app-pda/usbmuxd/usbmuxd-1.1.1_pre20200121.ebuild
new file mode 100644 (file)
index 0000000..371f8cb
--- /dev/null
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+COMMIT="8a69f1a78a58476f77b66916091d2405d0cd815f"
+
+inherit autotools systemd udev
+
+DESCRIPTION="USB multiplex daemon for use with Apple iPhone/iPod Touch devices"
+HOMEPAGE="https://www.libimobiledevice.org/"
+SRC_URI="https://cgit.libimobiledevice.org/usbmuxd.git/snapshot/usbmuxd-${COMMIT}.tar.bz2 -> ${P}.tar.bz2"
+
+# src/utils.h is LGPL-2.1+, rest is found in COPYING*
+LICENSE="GPL-2 GPL-3 LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="systemd"
+
+DEPEND="
+       acct-user/usbmux
+       >=app-pda/libimobiledevice-1.2.1_pre0:=
+       >=app-pda/libplist-1.11:=
+       virtual/libusb:1"
+
+RDEPEND="
+       ${DEPEND}
+       virtual/udev
+"
+
+BDEPEND="
+       virtual/pkgconfig
+"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+               $(use_with systemd) \
+               --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
+               --with-udevrulesdir="$(get_udevdir)"/rules.d
+}