games-simulation/flightgear: Version bump 2016.2.1, bug 584302.
authorMaciej Mrozowski <reavertm@gentoo.org>
Sat, 28 May 2016 00:50:15 +0000 (02:50 +0200)
committerMaciej Mrozowski <reavertm@gentoo.org>
Sat, 28 May 2016 00:51:56 +0000 (02:51 +0200)
dev-games/simgear/Manifest
dev-games/simgear/files/simgear-2016.2.1-unbundle-udns.patch [new file with mode: 0644]
dev-games/simgear/metadata.xml
dev-games/simgear/simgear-2016.1.1.ebuild
dev-games/simgear/simgear-2016.2.1.ebuild [new file with mode: 0644]
dev-games/simgear/simgear-9999.ebuild
games-simulation/flightgear-data/Manifest
games-simulation/flightgear-data/flightgear-data-2016.2.1.ebuild [new file with mode: 0644]
games-simulation/flightgear/Manifest
games-simulation/flightgear/flightgear-2016.2.1.ebuild [new file with mode: 0644]
games-simulation/flightgear/flightgear-9999.ebuild

index a9e5a714f32f095ec8268444c52ad48e528d147f..6fa9e7b77560af2de29493efa21c5d128acb5510 100644 (file)
@@ -1,2 +1,3 @@
 DIST simgear-2016.1.1.tar.bz2 1065810 SHA256 dbbc40115bc41563d930102484a3682e9fa4dda6f120feaa1fe82e0eb9d96c0d SHA512 ccc3384beef2e2ff3819928f22289a774da28c1df11f42ddc58ad4913c2c329a2cc14ca0359a312b9684ae31e598dda8a7a49e27c9148d079858dc0bf8e6ae63 WHIRLPOOL 2cf05f28c3318ea678f728c87e447c73934348b8862c97602b264f63bbecca82fd7e6db17affe84c78e1a9c42e31ad64aca243e97723e3e54ffca8481609ba50
+DIST simgear-2016.2.1.tar.bz2 1161873 SHA256 601d4ef75a7f9e7012f85d6f63219f3e2ef90f98249eaa5d16cc6b1a3c737a0a SHA512 22046873b67c2dd530d9734f799ea8a7238f6ffb58999b5a1d72053c4837212906048ec681cb2b704cd55d6b7aba03729d4f6a6a7e351f1e5aa2e497cc78d937 WHIRLPOOL 4f4fd697b301dfcd27a623d9475e63a46709d1e27b0324bdf097a8260d2759e7dedb16de6dbf1a82430dc3d80a32b58abf3bc82026894b83c2ec5c06391dcdcf
 DIST simgear-3.4.0.tar.bz2 1057455 SHA256 927d66fe72aacb9dacced4506430bd5fc7726bc8d3d07d6f1866bc4cb11a5894 SHA512 9ebf49ea2f024f0e52a4d18ba6f77361e7b9f51a0e7238661b4b2fd9db0176bdd948612d9b4aec3ae4d8210676e7533dfc0308b9c71bdeb22e99a68b90d81320 WHIRLPOOL bb48b6640409a96816ade77c22a91f88c452d339165dd0241354c26ff27572a14538ecfd91265c239def4621657be8766c081cffc237711a691d7ef54461b548
diff --git a/dev-games/simgear/files/simgear-2016.2.1-unbundle-udns.patch b/dev-games/simgear/files/simgear-2016.2.1-unbundle-udns.patch
new file mode 100644 (file)
index 0000000..40bad3c
--- /dev/null
@@ -0,0 +1,144 @@
+From 2b15b6b8adce06107866fff0028503c1b92b0de4 Mon Sep 17 00:00:00 2001
+From: Maciej Mrozowski <reavertm@gmail.com>
+Date: Thu, 26 May 2016 02:24:19 +0200
+Subject: [PATCH] Add SYSTEM_UDNS CMake option. Remove spurious EXPAT_LIBRARIES
+ linking when using bundled expat.
+
+---
+ 3rdparty/CMakeLists.txt     |  2 +-
+ CMakeLists.txt              | 19 ++++++++++++++-----
+ CMakeModules/FindUdns.cmake | 42 ++++++++++++++++++++++++++++++++++++++++++
+ simgear/CMakeLists.txt      | 11 ++++++++++-
+ 4 files changed, 67 insertions(+), 7 deletions(-)
+ create mode 100644 CMakeModules/FindUdns.cmake
+
+diff --git a/3rdparty/CMakeLists.txt b/3rdparty/CMakeLists.txt
+index e9b5282..a03a82d 100644
+--- a/3rdparty/CMakeLists.txt
++++ b/3rdparty/CMakeLists.txt
+@@ -4,6 +4,6 @@ endif()
+ add_subdirectory(utf8)
+-if (ENABLE_DNS)
++if (ENABLE_DNS AND NOT SYSTEM_UDNS)
+       add_subdirectory(udns)
+ endif()
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index a67d65e..7de1a0a 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -114,12 +114,14 @@ endif()
+ if (NOT MSVC)
+ option(SIMGEAR_SHARED   "Set to ON to build SimGear as a shared library/framework" OFF)
+-option(SYSTEM_EXPAT     "Set to ON to build SimGear using the system libExpat" OFF)
++option(SYSTEM_EXPAT     "Set to ON to build SimGear using the system expat library" OFF)
++option(SYSTEM_UDNS      "Set to ON to build SimGear using the system udns library" OFF)
+ else()
+ # Building SimGear DLLs is currently not supported for MSVC.
+ set(SIMGEAR_SHARED OFF)
+-# Using a system expat is currently not supported for MSVC - it would require shared simgear (DLL).
++# Using external 3rd party libraries is currently not supported for MSVC - it would require shared simgear (DLL).
+ set(SYSTEM_EXPAT OFF)
++set(SYSTEM_UDNS OFF)
+ endif()
+ option(SIMGEAR_HEADLESS "Set to ON to build SimGear without GUI/graphics support" OFF)
+@@ -426,9 +428,16 @@ endif()
+ install (FILES ${PROJECT_BINARY_DIR}/simgear/simgear_config.h  DESTINATION include/simgear/)
+ include_directories(3rdparty/utf8/source)
+-if (ENABLE_DNS)
+-    message(STATUS "DNS resolver: ENABLED")
+-    include_directories(3rdparty/udns)
++
++if(ENABLE_DNS)
++    if(SYSTEM_UDNS)
++        message(STATUS "Requested to use system udns library, forcing SIMGEAR_SHARED to true")
++        set(SIMGEAR_SHARED ON)
++        find_package(Udns REQUIRED)
++    else()
++        message(STATUS "DNS resolver: ENABLED")
++        include_directories(3rdparty/udns)
++    endif()
+ else()
+     message(STATUS "DNS resolver: DISABLED")
+ endif()
+diff --git a/CMakeModules/FindUdns.cmake b/CMakeModules/FindUdns.cmake
+new file mode 100644
+index 0000000..a436361
+--- /dev/null
++++ b/CMakeModules/FindUdns.cmake
+@@ -0,0 +1,42 @@
++# - Try to find UDNS library
++# Once done this will define
++#
++#  UDNS_FOUND - system has UDNS
++#  UDNS_INCLUDE_DIRS - the UDNS include directory
++#  UDNS_LIBRARIES - Link these to use UDNS
++#  UDNS_DEFINITIONS - Compiler switches required for using UDNS
++#
++#  Copyright (c) 2016 Maciej Mrozowski <reavertm@gmail.com>
++#
++# Distributed under the Boost Software License, Version 1.0.
++# (See accompanying file LICENSE_1_0.txt or copy at
++# http://www.boost.org/LICENSE_1_0.txt)
++
++
++if (UDN_LIBRARIES AND UDN_INCLUDE_DIRS)
++  # in cache already
++  set(UDNS_FOUND TRUE)
++else ()
++  set(UDNS_DEFINITIONS "")
++
++  find_path(UDNS_INCLUDE_DIRS NAMES udns.h)
++  find_library(UDNS_LIBRARIES NAMES udns)
++
++  if (UDNS_INCLUDE_DIRS AND UDNS_LIBRARIES)
++    set(UDNS_FOUND TRUE)
++  endif ()
++
++  if (UDNS_FOUND)
++    if (NOT Udns_FIND_QUIETLY)
++      message(STATUS "Found UDNS: ${UDNS_LIBRARIES}")
++    endif ()
++  else ()
++    if (Udns_FIND_REQUIRED)
++      message(FATAL_ERROR "Could not find UDNS")
++    endif ()
++  endif ()
++
++  # show the UDNS_INCLUDE_DIRS and UDNS_LIBRARIES variables only in the advanced view
++  mark_as_advanced(UDNS_INCLUDE_DIRS UDNS_LIBRARIES)
++
++endif ()
+diff --git a/simgear/CMakeLists.txt b/simgear/CMakeLists.txt
+index 5976833..516ea6c 100644
+--- a/simgear/CMakeLists.txt
++++ b/simgear/CMakeLists.txt
+@@ -128,11 +128,20 @@ target_link_libraries(SimGearCore
+     ${ZLIB_LIBRARY}
+     ${RT_LIBRARY}
+     ${DL_LIBRARY}
+-    ${EXPAT_LIBRARIES}
+     ${CMAKE_THREAD_LIBS_INIT}
+     ${COCOA_LIBRARY}
+     ${CURL_LIBRARIES})
++if(SYSTEM_EXPAT)
++    target_link_libraries(SimGearCore
++        ${EXPAT_LIBRARIES})
++endif()
++
++if(ENABLE_DNS AND SYSTEM_UDNS)
++    target_link_libraries(SimGearCore
++        ${UDNS_LIBRARIES})
++endif()
++
+ if(NOT SIMGEAR_HEADLESS)
+     target_link_libraries(SimGearScene
+         SimGearCore
+-- 
+2.7.3
+
index 0971f9a8bb0f18dbc5cec81dac6a735d75208acb..37fa7b496782145c98108be9e5e3be4edf26f0a9 100644 (file)
@@ -14,6 +14,7 @@ SimGear is a set of open-source libraries designed to be used as building blocks
 quickly assembling 3d simulations, games, and visualization applications.
 </longdescription>
 <use>
+       <flag name="dns">Enables DNS resolver via <pkg>net-libs/udns</pkg></flag>
        <flag name="subversion">Enables terrasync scenery downloader</flag>
 </use>
 </pkgmetadata>
index 899b65f0dd0d2d60a903fb0985ba8dd3c643a877..de8291dd2175323f65d22bca334f0d412eca0adf 100644 (file)
@@ -4,7 +4,6 @@
 
 EAPI=6
 
-CMAKE_WARN_UNUSED_CLI=1
 inherit eutils cmake-utils
 
 DESCRIPTION="Development library for simulation games"
diff --git a/dev-games/simgear/simgear-2016.2.1.ebuild b/dev-games/simgear/simgear-2016.2.1.ebuild
new file mode 100644 (file)
index 0000000..9104575
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils cmake-utils
+
+DESCRIPTION="Development library for simulation games"
+HOMEPAGE="http://www.simgear.org/"
+SRC_URI="mirror://sourceforge/flightgear/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+IUSE="+dns debug subversion test"
+
+COMMON_DEPEND="
+       dev-libs/expat
+       >=dev-games/openscenegraph-3.2.0
+       media-libs/openal
+       net-misc/curl
+       sys-libs/zlib
+       virtual/opengl
+       dns? ( net-libs/udns )
+"
+DEPEND="${COMMON_DEPEND}
+       >=dev-libs/boost-1.44
+"
+RDEPEND="${COMMON_DEPEND}
+       subversion? ( dev-vcs/subversion )
+"
+
+PATCHES=(
+       "${FILESDIR}/simgear-2016.2.1-unbundle-udns.patch"
+)
+
+DOCS=(AUTHORS ChangeLog NEWS README Thanks)
+
+src_configure() {
+       local mycmakeargs=(
+               -DENABLE_DNS=$(usex dns)
+               -DENABLE_PKGUTIL=ON
+               -DENABLE_RTI=OFF
+               -DENABLE_SOUND=ON
+               -DENABLE_TESTS=$(usex test)
+               -DSIMGEAR_HEADLESS=OFF
+               -DSIMGEAR_SHARED=ON
+               -DSYSTEM_EXPAT=ON
+               -DSYSTEM_UDNS=ON
+       )
+       cmake-utils_src_configure
+}
index f1512179d7a97444e4488d71385b3c1c12c24494..2c5c92dfcc7217520c0e2f710f24c052bec53e3f 100644 (file)
@@ -4,7 +4,6 @@
 
 EAPI=6
 
-CMAKE_WARN_UNUSED_CLI=1
 inherit eutils cmake-utils git-r3
 
 DESCRIPTION="Development library for simulation games"
@@ -16,15 +15,16 @@ EGIT_BRANCH="next"
 LICENSE="GPL-2"
 KEYWORDS=""
 SLOT="0"
-IUSE="curl debug subversion test"
+IUSE="+dns debug subversion test"
 
 COMMON_DEPEND="
        dev-libs/expat
        >=dev-games/openscenegraph-3.2.0
        media-libs/openal
+       net-misc/curl
        sys-libs/zlib
        virtual/opengl
-       curl? ( net-misc/curl )
+       dns? ( net-libs/udns )
 "
 DEPEND="${COMMON_DEPEND}
        >=dev-libs/boost-1.44
@@ -33,11 +33,15 @@ RDEPEND="${COMMON_DEPEND}
        subversion? ( dev-vcs/subversion )
 "
 
+PATCHES=(
+       "${FILESDIR}/simgear-2016.2.1-unbundle-udns.patch"
+)
+
 DOCS=(AUTHORS ChangeLog NEWS README Thanks)
 
 src_configure() {
        local mycmakeargs=(
-               -DENABLE_CURL=$(usex curl)
+               -DENABLE_DNS=$(usex dns)
                -DENABLE_PKGUTIL=ON
                -DENABLE_RTI=OFF
                -DENABLE_SOUND=ON
@@ -45,6 +49,7 @@ src_configure() {
                -DSIMGEAR_HEADLESS=OFF
                -DSIMGEAR_SHARED=ON
                -DSYSTEM_EXPAT=ON
+               -DSYSTEM_UDNS=ON
        )
        cmake-utils_src_configure
 }
index cc1eccf934bf801051512426521c49a9b89cd72c..0600b5fc0f96b49bf81436b7b1696504407845b0 100644 (file)
@@ -1,2 +1,3 @@
 DIST FlightGear-2016.1.1-data.tar.bz2 1266743984 SHA256 36016ac5ab83fc6ad44c5cebe0f4fa7a14cf55ff5b699016abdeacf5a04c4c18 SHA512 605d610d001f959e2434228b9c3741af0df5fd047af31e1d60ad5bdb1041cde3299cab622014735cff6534d2a8f0edbe44ab3528bae2072454aaf0b363e765b8 WHIRLPOOL 3c1c50d2a47a9c68839cea1c24439c1052fc8b4a8ff7ee4378913fe3aaa9c4f08feb3a2a8aca520087aa745a4bda0ef43d8ea4679072cd56ff1311acf27261e3
+DIST FlightGear-2016.2.1-data.tar.bz2 1562126790 SHA256 225b32f4d813635ece72f09541640e818fba95386ff8715015693978c37eaace SHA512 1c22d2afcb33ef8552fa9712a25fc116e31d585f4973339b134b6461421da1b47c3e5c795c5f1ee99d13a1c107f3a7a615c07843de2332a1e9f729bc64dd269d WHIRLPOOL b664f65c23342c0e13d58c431896019085780cf413da4c3350e3e22efb3aa1686fee6f3e1b97568711d5218eb2f1dab554d2d5559f06358c75eff1e711fcb7b8
 DIST FlightGear-data-3.4.0.tar.bz2 1145893777 SHA256 8cefa7c323d974d8e51fd23c97ae79dc731e65b81e1729cb1bc9bc1f99df128b SHA512 791ff1b1f7f759ccc73f738ba6cb6fd050d1341ae031a872745b4c1145cdb92de62193df7ea6e9fe05a1c95a60fa664da56015d643244d38c7b0b72a2c3146d9 WHIRLPOOL 0abaa4da7e9032469da80500fc23c84d6b696fc596529853a3a614bb3627ef6081c12ea78e6e8c987e6b11b303cca0d8da5c9628164d2a93bed452230302a655
diff --git a/games-simulation/flightgear-data/flightgear-data-2016.2.1.ebuild b/games-simulation/flightgear-data/flightgear-data-2016.2.1.ebuild
new file mode 100644 (file)
index 0000000..1a1745f
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="FlightGear data files"
+HOMEPAGE="http://www.flightgear.org/"
+SRC_URI="mirror://sourceforge/flightgear/FlightGear-${PV}-data.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+# data files split to separate package since 2.10.0
+RDEPEND="
+       !<games-simulation/flightgear-2.10.0
+"
+
+S=${WORKDIR}/fgdata
+
+src_install() {
+       insinto /usr/share/flightgear
+       rm -fr .git
+       doins -r *
+}
index cce1b8fad2cb7d7ed5fc3ff0955199deb07e9a95..1e2f0039e7ee62200ad432814ba74f777a80017f 100644 (file)
@@ -1,2 +1,3 @@
 DIST flightgear-2016.1.1.tar.bz2 7541607 SHA256 acdffb8a6a000cd44b23816f5d1467dbcf375d3cbd6233b2998467bd55dd60ac SHA512 bcebbf100e383a808154dbdf2b0f28ffcf0e3c0415a2db90e0daabb0073e83be69b3989dfc9e299c35fa6e39ddb5b9d4dfefd7f4c23ca8cd981768d8ab89e9c0 WHIRLPOOL d431c59c160a383c4f91f34f1e7ad322502704a4693c6c189cf258958703b0fe97290ab9db60a7de93f99511c79993c1a02de5ae559be0f0fab83b1bea371791
+DIST flightgear-2016.2.1.tar.bz2 7556269 SHA256 b554170ca6b5943fd90496759b055fb60f362ea96f6c46dfff89e3d12c940a94 SHA512 679cb8e6aa4c2d601e7b984da6e4317fd454d14b1357d08cc64350eb973a6700a0dddd18b50cd50fcdce48fba2864ce0f7484b67a15e38cb5f5e8e7d4fc7b017 WHIRLPOOL 6d04982bb107d59094facb4d0430cb25de5ea994f25f1ea3a18351626335c1bc136228e376fd680baacb1e731718b49c317adb390737fd5641b51f8228303c48
 DIST flightgear-3.4.0.tar.bz2 7522457 SHA256 b5645d05b50728a89f091292bc557f440d8f8719dd9cebf7f5bf3fa8ea795780 SHA512 10626d00b34255753dc5a5c82076909c296219472faf51c38460cc357ac014b40bd127454f28b2d857f1a1a299716430fd8f04dc7881552b3c24dee6eb616b1e WHIRLPOOL 636ca7e012175141bc4b081cb6137e5348d49b873d241c5d0f1ed0a2581b32d2f23f4fe0ed97d5a1b72440afd14687e5de4e6ebeeaf07b4e854b0ca47875b82f
diff --git a/games-simulation/flightgear/flightgear-2016.2.1.ebuild b/games-simulation/flightgear/flightgear-2016.2.1.ebuild
new file mode 100644 (file)
index 0000000..87a25f2
--- /dev/null
@@ -0,0 +1,131 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils bash-completion-r1
+
+DESCRIPTION="Open Source Flight Simulator"
+HOMEPAGE="http://www.flightgear.org/"
+SRC_URI="mirror://sourceforge/flightgear/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dbus debug examples qt5 test +udev +utils vim-syntax"
+
+COMMON_DEPEND="
+       dev-db/sqlite:3
+       >=dev-games/openscenegraph-3.2.0[png]
+       ~dev-games/simgear-${PV}
+       media-libs/openal
+       media-libs/speex
+       media-sound/gsm
+       sys-libs/zlib
+       x11-libs/libX11
+       dbus? ( >=sys-apps/dbus-1.6.18-r1 )
+       qt5? (
+               >=dev-qt/qtcore-5.4.1:5
+               >=dev-qt/qtgui-5.4.1:5
+               >=dev-qt/qtwidgets-5.4.1:5
+       )
+       udev? ( virtual/udev )
+       utils? (
+               media-libs/freeglut
+               media-libs/libpng:0
+               virtual/opengl
+       )
+"
+DEPEND="${COMMON_DEPEND}
+       >=dev-libs/boost-1.44
+       >=media-libs/plib-1.8.5
+"
+RDEPEND="${COMMON_DEPEND}
+       ~games-simulation/${PN}-data-${PV}
+"
+
+DOCS=(AUTHORS ChangeLog NEWS README Thanks)
+
+src_configure() {
+       local mycmakeargs=(
+               -DENABLE_FGCOM=$(usex utils)
+               -DENABLE_FGELEV=$(usex utils)
+               -DENABLE_FGJS=$(usex utils)
+               -DENABLE_FGVIEWER=$(usex utils)
+               -DENABLE_FLITE=OFF
+               -DENABLE_GPSSMOOTH=$(usex utils)
+               -DENABLE_JS_DEMO=$(usex utils)
+               -DENABLE_JSBSIM=ON
+               -DENABLE_LARCSIM=ON
+               -DENABLE_LOGGING=$(usex test)
+               -DENABLE_METAR=$(usex utils)
+               -DENABLE_PROFILE=OFF
+               -DENABLE_QT=$(usex qt5)
+               -DENABLE_RTI=OFF
+               -DENABLE_TERRASYNC=$(usex utils)
+               -DENABLE_TESTS=$(usex test)
+               -DENABLE_UIUC_MODEL=ON
+               -DENABLE_YASIM=ON
+               -DEVENT_INPUT=$(usex udev)
+               -DFG_DATA_DIR=/usr/share/${PN}
+               -DJSBSIM_TERRAIN=ON
+               -DSIMGEAR_SHARED=ON
+               -DSP_FDMS=ON
+               -DSYSTEM_FLITE=ON
+               -DSYSTEM_HTS_ENGINE=ON
+               -DSYSTEM_SPEEX=ON
+               -DSYSTEM_GSM=ON
+               -DSYSTEM_SQLITE=ON
+               -DUSE_DBUS=$(usex dbus)
+               -DWITH_FGPANEL=$(usex utils)
+       )
+
+       cmake-utils_src_configure
+}
+
+src_install() {
+       cmake-utils_src_install
+
+       # Install icons and menu entry
+       local s
+       for s in 16 22 24 32 48 64 128; do
+               doicon -s ${s} icons/${s}x${s}/apps/${PN}.png
+               use utils && doicon -s ${s} icons/${s}x${s}/apps/fgcom.png
+       done
+       doicon -s scalable icons/scalable/${PN}.svg
+       use utils && doicon -s scalable icons/scalable/fgcom.svg
+
+       newmenu package/${PN}.desktop ${PN}.desktop
+
+       # Install bash completion (TODO zsh)
+       # Uncomment below when scripts stops writing files...
+#      sed -e "s|/usr/local/share/FlightGear|${GAMES_DATADIR}/${PN}|" \
+#              -i scripts/completion/fg-completion.bash || die 'unable to replace FG_ROOT'
+#      newbashcomp scripts/completion/fg-completion.bash ${PN}
+
+       # Install examples and other misc files
+       if use examples; then
+               insinto /usr/share/doc/"${PF}"/examples
+               doins -r scripts/java scripts/perl scripts/python
+               insinto /usr/share/doc/"${PF}"/examples/c++
+               doins -r scripts/example/*
+               insinto /usr/share/doc/"${PF}"/tools
+               doins -r scripts/atis scripts/tools/*
+       fi
+
+       # Install nasal script syntax
+       if use vim-syntax; then
+               insinto /usr/share/vim/vimfiles/syntax
+               doins scripts/syntax/{ac3d,nasal}.vim
+               insinto /usr/share/vim/vimfiles/ftdetect/
+               doins "${FILESDIR}"/{ac3d,nasal}.vim
+       fi
+}
+
+pkg_postinst() {
+       einfo "Please note that data files location changed to /usr/share/flightgear"
+       if use qt5; then
+               einfo "To use launcher, run fgfs with '--launcher' parameter"
+       fi
+}
index 2d73c20cd971823cf47ae7ebf8a72e256360f3fc..d512c59ef7600fdf4e5ca2a2a4605376cc461aee 100644 (file)
@@ -4,7 +4,6 @@
 
 EAPI=6
 
-CMAKE_WARN_UNUSED_CLI=1
 inherit cmake-utils bash-completion-r1 git-r3
 
 DESCRIPTION="Open Source Flight Simulator"