dev-php/sebastian-recursion-context: Version bump for 3.0.0
authorBrian Evans <grknight@gentoo.org>
Thu, 19 Dec 2019 21:14:01 +0000 (16:14 -0500)
committerBrian Evans <grknight@gentoo.org>
Thu, 19 Dec 2019 21:50:54 +0000 (16:50 -0500)
Signed-off-by: Brian Evans <grknight@gentoo.org>
dev-php/sebastian-recursion-context/Manifest
dev-php/sebastian-recursion-context/sebastian-recursion-context-3.0.0.ebuild [new file with mode: 0644]

index 44b59353ecc3408277dd9f783092fd3632147aa7..75c7c5f109e9e063575a0c393b791dcaf2ee9c28 100644 (file)
@@ -1 +1,2 @@
 DIST sebastian-recursion-context-2.0.0.tar.gz 4526 BLAKE2B 54ecdfc255c3bdbedc2a909f5b569c62b19e2e66fc5ea4ae7be8401516c142b43e611d5e8f1c056be329983f21e1a8b85e7fb2ff1ddb92a2f6aad4d4191418a6 SHA512 9d25d148decc81f5a21d7a4e1f966563bf6ec765fcc1b1ce779668b74dfa39959db07cf296e9cffcbcb3943c8911709bb73f22c5bfcc81c5d2fcbb51967cf75e
+DIST sebastian-recursion-context-3.0.0.tar.gz 4414 BLAKE2B 04a0aca4b6012013306c813109c0ed6f60d2f4f1381ba6506398388b5065d69375191290d33cdc4b82359dc30b1fd98ef61005a657fa8db302472597950255b5 SHA512 0fce5709cb22818de6bbfda1ba2a99fea511d5b36bcbe7955661d756a6f82ba84cbf8fb4eb421d6b51ae9e36a8edac56c5bafbccf8b665a0296883ea0dbb3b91
diff --git a/dev-php/sebastian-recursion-context/sebastian-recursion-context-3.0.0.ebuild b/dev-php/sebastian-recursion-context/sebastian-recursion-context-3.0.0.ebuild
new file mode 100644 (file)
index 0000000..d604ca5
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/sebastian-//}"
+
+DESCRIPTION="Recursively process PHP variables"
+HOMEPAGE="http://phpunit.de"
+SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+       =dev-lang/php-7*:*"
+
+src_install() {
+       insinto /usr/share/php/SebastianBergmann/RecursionContext
+       doins -r src/*
+       doins "${FILESDIR}/autoload.php"
+}