1.2.4 had build problems on some systems - replace with 1.2.5.
authorJoshua Baergen <joshuabaergen@gentoo.org>
Sat, 2 Dec 2006 16:20:53 +0000 (16:20 +0000)
committerJoshua Baergen <joshuabaergen@gentoo.org>
Sat, 2 Dec 2006 16:20:53 +0000 (16:20 +0000)
Package-Manager: portage-2.1.2_rc2-r3

x11-libs/libXfont/ChangeLog
x11-libs/libXfont/files/digest-libXfont-1.2.5 [new file with mode: 0644]
x11-libs/libXfont/libXfont-1.2.5.ebuild [new file with mode: 0644]

index 6cec709599a501b99d1cb726c5c4691c9504afc9..846d9824466736869e5de607191947cf777027ff 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for x11-libs/libXfont
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXfont/ChangeLog,v 1.52 2006/12/02 16:13:25 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXfont/ChangeLog,v 1.53 2006/12/02 16:20:53 joshuabaergen Exp $
+
+*libXfont-1.2.5 (02 Dec 2006)
+
+  02 Dec 2006; Joshua Baergen <joshuabaergen@gentoo.org>
+  -libXfont-1.2.4.ebuild, +libXfont-1.2.5.ebuild:
+  1.2.4 had build problems on some systems - replace with 1.2.5.
 
 *libXfont-1.2.4 (02 Dec 2006)
 
diff --git a/x11-libs/libXfont/files/digest-libXfont-1.2.5 b/x11-libs/libXfont/files/digest-libXfont-1.2.5
new file mode 100644 (file)
index 0000000..87186d4
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 373e14323b70e33c7dfed7e4cf9ebbf7 libXfont-1.2.5.tar.bz2 581174
+RMD160 9c2c400021ce79c443c74b51917357c517f0e3df libXfont-1.2.5.tar.bz2 581174
+SHA256 f41c83e6c2c72fca3f374d1aba22896aa78ca8a5e35a06d01121bf680151ef2f libXfont-1.2.5.tar.bz2 581174
diff --git a/x11-libs/libXfont/libXfont-1.2.5.ebuild b/x11-libs/libXfont/libXfont-1.2.5.ebuild
new file mode 100644 (file)
index 0000000..fdc4b5a
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXfont/libXfont-1.2.5.ebuild,v 1.1 2006/12/02 16:20:53 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+# SNAPSHOT="yes"
+
+inherit x-modular flag-o-matic
+
+DESCRIPTION="X.Org Xfont library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ipv6"
+
+RDEPEND="x11-libs/xtrans
+       x11-libs/libfontenc
+       x11-proto/xproto
+       x11-proto/fontsproto
+       >=media-libs/freetype-2"
+DEPEND="${RDEPEND}
+       x11-proto/fontcacheproto"
+
+CONFIGURE_OPTIONS="$(use_enable ipv6)
+       --with-encodingsdir=/usr/share/fonts/encodings"
+
+pkg_setup() {
+       # No such function yet
+       # x-modular_pkg_setup
+
+       # (#125465) Broken with Bdirect support
+       filter-flags -Wl,-Bdirect
+       filter-ldflags -Bdirect
+       filter-ldflags -Wl,-Bdirect
+}