games-strategy/maxr: Update icon cache
authorJames Le Cuirot <chewi@gentoo.org>
Mon, 26 Mar 2018 21:23:24 +0000 (22:23 +0100)
committerJames Le Cuirot <chewi@gentoo.org>
Mon, 26 Mar 2018 21:25:01 +0000 (22:25 +0100)
Package-Manager: Portage-2.3.24, Repoman-2.3.6

games-strategy/maxr/maxr-0.2.9.ebuild

index 1835decca3616f42b187287fd89540abd0adec21..624345a06b3081de8ec86c442b930033aee8cf37 100644 (file)
@@ -2,7 +2,8 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-inherit cmake-utils desktop
+
+inherit cmake-utils desktop gnome2-utils
 
 DESCRIPTION="Mechanized Assault and Exploration Reloaded"
 HOMEPAGE="http://www.maxr.org/"
@@ -20,14 +21,19 @@ DEPEND="${RDEPEND}"
 
 src_configure() {
        mycmakeargs=(
-               -DMAXR_BUILD_DEDICATED_SERVER="$(usex dedicated)"
-               "-DCMAKE_BUILD_TYPE=Release")
+               -DMAXR_BUILD_DEDICATED_SERVER=$(usex dedicated)
+               -DCMAKE_BUILD_TYPE=Release
+       )
 
        cmake-utils_src_configure
 }
 
 src_install() {
-       doicon data/maxr.png
-       make_desktop_entry maxr "Mechanized Assault and Exploration Reloaded"
        cmake-utils_src_install
+       doicon -s 128 data/${PN}.png
+       make_desktop_entry ${PN} "Mechanized Assault and Exploration Reloaded"
 }
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }